1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52
|
From: Marcus Meissner <marcus@jet.franken.de>
Date: Wed, 6 Dec 2023 17:20:50 +0100
Subject: use CDK_CONST to match whatever const mode cdk was built with.
https://github.com/gphoto/gphoto2/issues/615
Closes: #1075036
gphoto2/gphoto2-cmd-config.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/gphoto2/gphoto2-cmd-config.c b/gphoto2/gphoto2-cmd-config.c
index 9c9149a..f79bead 100644
@@ -59,8 +59,8 @@ static int
set_config (CmdConfig *cmd_config)
{
int result, selection;
- const char *msg[10];
- const char *buttons[] = {N_("</B/24>Continue"), N_("</B16>Cancel")};
+ CDK_CONST char *msg[10];
+ CDK_CONST char *buttons[] = {N_("</B/24>Continue"), N_("</B16>Cancel")};
CDKDIALOG *question = NULL;
result = gp_camera_set_config (cmd_config->camera, cmd_config->window,
@@ -124,7 +124,7 @@ show_section (CmdConfig *cmd_config, CameraWidget *section)
count++;
scroll = newCDKScroll (cmd_config->screen, CENTER, CENTER, RIGHT,
10, 50, title,
- (const char**)items, count, NUMBERS, A_REVERSE, TRUE, FALSE);
+ (CDK_CONST char**)items, count, NUMBERS, A_REVERSE, TRUE, FALSE);
if (!scroll)
return (GP_ERROR);
@@ -318,7 +318,7 @@ show_radio (CmdConfig *cmd_config, CameraWidget *radio)
}
list = newCDKItemlist (cmd_config->screen, CENTER, CENTER,
- title, _("Value: "), (const char**)items, count,
+ title, _("Value: "), (CDK_CONST char**)items, count,
current, TRUE, FALSE);
if (!list)
return (GP_ERROR);
@@ -368,7 +368,7 @@ show_toggle (CmdConfig *cmd_config, CameraWidget *toggle)
int value, selection;
const char *label;
char title[1024];
- const char *info[] = {N_("Yes"), N_("No")};
+ CDK_CONST char *info[] = {N_("Yes"), N_("No")};
CHECK (gp_widget_get_value (toggle, &value));
CHECK (gp_widget_get_label (toggle, &label));
|