File: changelog

package info (click to toggle)
gr-gsm 0.42.2-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 3,760 kB
  • sloc: python: 13,418; ansic: 11,578; cpp: 11,105; xml: 1,800; sh: 153; makefile: 27
file content (94 lines) | stat: -rw-r--r-- 3,845 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
gr-gsm (0.42.2-1) unstable; urgency=medium

  * New upstream version 0.42.2.
  * Changed Standards-Version from 4.1.4 to 4.2.0.
  * Removed 0000-soname-0-42-1.patch applied upstream.

 -- Petter Reinholdtsen <pere@debian.org>  Sat, 18 Aug 2018 19:20:42 +0200

gr-gsm (0.42.1-2) unstable; urgency=medium

  * Update build depend list based on pacages in Debian_testing.docker to
    fix build failure.

 -- Petter Reinholdtsen <pere@debian.org>  Sat, 11 Aug 2018 13:55:50 +0200

gr-gsm (0.42.1-1) unstable; urgency=medium

  * New upstream version 0.42.1
   - Fixes python import problem (Closes: #890914)
  * New upstream URL.  Updated d/control and d/copyright.
  * Updated watch file to use new upstream location.
  * Removed 1010-hackrf-scanner.patch now applied upstream.
  * Updated Standards-Version from 4.1.0 to 4.1.4.
  * Added 0000-soname-0-42-1.patch from upstream to correct library soname.

 -- Petter Reinholdtsen <pere@debian.org>  Sat, 11 Aug 2018 05:10:02 +0000

gr-gsm (0.41.2-2) unstable; urgency=medium

  * Add doxygen as build dependency to include documentation in package.
  * Added 1010-hackrf-scanner.patch to stop grgsm_scanner from crashing
    with HackRF.
  * Added 1020-reproducible-build.patch to make build timestamp more
    reproducible (Closes: 891405)
  * Update Vcs links to salsa.
  * Changed debhelper compat level from 9 to  10.
  * Remove no longer needed --parallel from d/rules.  Thanks lintian.

 -- Petter Reinholdtsen <pere@debian.org>  Wed, 21 Mar 2018 08:41:10 +0000

gr-gsm (0.41.2-1) unstable; urgency=medium

  * New upstream version 0.41.2.
  * Removed 0000-livemon-arfcn.patch and 1010-rst-man-install.patch
    included upstream.

 -- Petter Reinholdtsen <pere@debian.org>  Sun, 24 Sep 2017 00:11:12 +0200

gr-gsm (0.41.1-2) unstable; urgency=medium

  * Added 0000-livemon-arfcn.patch from upstream for livemon to report
    arfcn and remove the use of 'band' command line arguments.
  * Added 1010-rst-man-install.patch to install manual page using
    patch proposed upstream.
  * Updated and renamed 1000-no-libexec-script.patch to
    1000-desktop-file-location.patch to install desktop file in the
    correct location.
  * Added dh-python as build depend as requested by dh_python2.

 -- Petter Reinholdtsen <pere@debian.org>  Sun, 17 Sep 2017 06:57:37 +0200

gr-gsm (0.41.1-1) unstable; urgency=medium

  * New upstream version 0.41.1 from master branch.
  * Added d/watch file after upstream added a release tag.
  * Changed Standards-Version from 4.0.1 to 4.1.0.
  * Added 1000-no-libexec-script.patch to not install desktop
    install/deinstall script in /usr/libexec/.
  * Modified build rules to install rst2man generated manual page.

 -- Petter Reinholdtsen <pere@debian.org>  Sat, 02 Sep 2017 19:56:36 +0000

gr-gsm (0.0.20170831.1e8a03c-1) unstable; urgency=medium

  * New upstream version from packaging branch.
  * Removed upstream merged patches 2000-no-compat-symlinks.patch
    and 2010-cmake-project-name.patch.
  * Updated d/copyright based on source code headers.
  * Removed header files in the binary package until the ABI is stable.

 -- Petter Reinholdtsen <pere@debian.org>  Thu, 31 Aug 2017 20:54:26 +0000

gr-gsm (0.0.20170807.6c4304d-1) unstable; urgency=medium

  * Initial upload based on Debian packaging from upstream (Closes: #871055).
  * Clean up d/copyright after reading the source.
  * Added extended package description.
  * Added 2000-no-compat-symlinks.patch to avoid compatibility symlinks in binary package.
  * Renamed programs after installation to avoid the .py file ending.
  * Disabled automatic testing during build until it start working.
  * Made sure to use jquery from libjs-jquery.
  * Added 2010-cmake-project-name.patch to correct documentation path.

 -- Petter Reinholdtsen <pere@debian.org>  Wed, 09 Aug 2017 22:34:52 +0200