1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165
|
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-include /usr/share/dpkg/buildflags.mk
version = 2.8.35
soversion = 10
export SOURCE_DATE_EPOCH = \
$(shell date -d "$$(dpkg-parsechangelog -c 1 -S Date)" +%s)
configure: configure-stamp
configure-stamp:
dh_testdir
find . -name '*.xml' -exec chmod a-x {} ';'
chmod a-x gsoap/doc/fonts/*
dh_autoreconf
CFLAGS='$(CFLAGS)' CXXFLAGS='$(CXXFLAGS)' \
CPPFLAGS='$(CPPFLAGS)' LDFLAGS='$(LDFLAGS)' ./configure \
--prefix=/usr \
--libdir='$${prefix}/lib/$(DEB_HOST_MULTIARCH)' \
--enable-ipv6 \
--enable-samples
touch $@
build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp: configure-stamp
dh_testdir
$(MAKE) -j1 SOVERSION=$(soversion)
for f in gsoap/doc/*/Doxyfile ; do \
( cd `dirname $$f` ; doxygen Doxyfile ) ; \
done
touch $@
clean:
dh_testdir
dh_testroot
if [ -r Makefile ]; then $(MAKE) -j1 reallyveryveryclean; fi
dh_autoreconf_clean
rm -rf gsoap/doc/*/html
rm -f gsoap/doc/*/doxygen_sqlite3.db
rm -f build-stamp configure-stamp
dh_clean
install: build-stamp
dh_testdir
dh_testroot
dh_prep
dh_installdirs
$(MAKE) -j1 install SOVERSION=$(soversion) DESTDIR=$(CURDIR)/debian/tmp
install -p -m 644 debian/WS-README \
$(CURDIR)/debian/tmp/usr/share/gsoap/WS
rm $(CURDIR)/debian/tmp/usr/lib/*/*.la
binary: binary-arch binary-indep
binary-arch: install
dh_testdir
dh_testroot
dh_installdocs -a
dh_installchangelogs -a
dh_install -a --fail-missing
dh_installman -a
dh_link -a
dh_strip -a -X/bin/ --dbg-package=libgsoap-dbg
dh_strip -a -X/lib/ --dbg-package=gsoap-dbg
dh_compress -a
dh_fixperms -a
dh_makeshlibs -a
dh_installdeb -a
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a
dh_builddeb -a
binary-indep: install
dh_testdir
dh_testroot
dh_installdocs -i
find $(CURDIR)/debian/gsoap-doc -name Doxyfile -exec rm {} ';'
dh_installchangelogs -i
dh_install -i --fail-missing
dh_installman -i
dh_lintian -i
dh_link -i
dh_compress -i
dh_fixperms -i
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
get-orig-source:
if [ -r gsoap_$(version).orig.tar.gz ] ; then \
echo "gsoap_$(version).orig.tar.gz already exists." ; \
else \
if [ -d "gsoap-2.8" ]; then \
echo "Please remove existing directory 'gsoap-2.8'" ; \
exit 1 ; \
fi ; \
if [ -d "gsoap-$(version)" ]; then \
echo "Please remove existing directory 'gsoap-$(version)'" ; \
exit 1 ; \
fi ; \
if [ -r gsoap_$(version).zip ]; then \
echo "Using existing ZIP archive gsoap_$(version).zip" ; \
echo "Delete the file and rerun if you want to redownload" ; \
else \
echo "Fetching upstream ZIP archive" ; \
wget http://downloads.sourceforge.net/gsoap2/gsoap_$(version).zip ; \
fi ; \
echo "Unpacking and renaming folder" ; \
unzip gsoap_$(version).zip ; \
mv gsoap-2.8 gsoap-$(version) ; \
echo "Deleting precompiled binaries" ; \
rm -rf gsoap-$(version)/gsoap/bin \
gsoap-$(version)/gsoap/samples/calc_vs2005/calc_vs2005/soapcpp2.exe \
gsoap-$(version)/gsoap/VisualStudio2005/wsdl2h/wsdl2h/soapcpp2.exe ; \
( cd gsoap-$(version)/gsoap/samples/link++ ; make distclean ) ; \
echo "Deleting pre-generated doxygen documentaion" ; \
rm -rf gsoap-$(version)/gsoap/doc/*/html ; \
echo "Deleting code with only non-free licenses" ; \
rm -rf gsoap-$(version)/gsoap/extras \
gsoap-$(version)/gsoap/mod_gsoap \
gsoap-$(version)/gsoap/Symbian ; \
echo "Deleting xsd and wsdl files" ; \
rm -rf gsoap-$(version)/gsoap/WS/*.xsd \
gsoap-$(version)/gsoap/WS/*.wsdl \
gsoap-$(version)/gsoap/samples/autotest/*.xsd \
gsoap-$(version)/gsoap/samples/autotest/*.wsdl \
gsoap-$(version)/gsoap/uddi2/*.xsd \
gsoap-$(version)/gsoap/uddi2/*.wsdl ; \
echo "Repacking" ; \
tar -z -c -f gsoap_$(version).orig.tar.gz gsoap-$(version) ; \
echo "Cleaning up" ; \
rm -rf gsoap-$(version) ; \
echo "Done" ; \
fi
.PHONY: binary binary-arch binary-indep build build-arch build-indep clean configure install get-orig-source
|