File: README

package info (click to toggle)
gspell 1.6.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 3,860 kB
  • sloc: ansic: 8,234; sh: 4,814; makefile: 336; sed: 16; xml: 7
file content (75 lines) | stat: -rw-r--r-- 2,025 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
gspell - a spell-checking library for GTK+ applications
=======================================================

This is version 1.6.1 of gspell.

gspell provides a flexible API to add spell checking to a GTK+ application.

The gspell library is free software and is released under the terms of the GNU
LGPL version 2.1 or later. See the file 'COPYING' for more information.

The official web site is:

    https://wiki.gnome.org/Projects/gspell

About versions
--------------

gspell follows the GNOME release schedule and uses the same versioning scheme:

    https://developer.gnome.org/programming-guidelines/stable/versioning.html.en

gspell 0.1.x should be installed alongside GNOME 3.18.
gspell 1.0.x should be installed alongside GNOME 3.20.
gspell 1.2.x should be installed alongside GNOME 3.22.
gspell 1.4.x should be installed alongside GNOME 3.24.
gspell 1.6.x should be installed alongside GNOME 3.26.

The 0.1 version didn't have a stable API, and there has been lots of API
changes between 0.1 and 1.0. The 0.1 and 1.0 versions are not completely
parallel-installable, only the libtool version has been bumped. Using the 0.1
version is highly discouraged.

Dependencies
------------

* GLib >= 2.44
* GTK+ >= 3.20
* Enchant >= 1.6.0
* iso-codes

Notes for packagers
-------------------

At least on GNU/Linux, it is better to install hunspell. aspell can be
considered deprecated and doesn't work well with gspell. If both hunspell and
aspell are installed, Enchant prefers hunspell.

See also:

    https://fedoraproject.org/wiki/Releases/FeatureDictionary
    https://wiki.ubuntu.com/ConsolidateSpellingLibs

Installation from a tarball
---------------------------

Simple install procedure:

  $ ./configure
  $ make
  [ Become root if necessary ]
  $ make install

See the file 'INSTALL' for more detailed information.

Installation from Git
---------------------

It is recommended to use Jhbuild:

    https://wiki.gnome.org/Projects/Jhbuild

How to contribute
-----------------

See the file 'HACKING'.