1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81
|
CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS|sed 's/-O2//') $(CPPFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS) -Wl,-Bsymbolic-functions
build: build-arch build-indep
build-arch: build-arch-stamp
build-arch-stamp:
dh_testdir
CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" $(MAKE)
touch $@
build-indep: build-indep-stamp
build-indep-stamp:
clean:
dh_testdir
dh_testroot
rm -f *-stamp
[ ! -f Makefile ] || $(MAKE) clean
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
$(MAKE) DESTDIR=$(CURDIR)/debian/gspiceui/usr install
rm -f debian/gspiceui/usr/share/gspiceui/INSTALL
mv -f debian/gspiceui/usr/share/gspiceui/* debian/gspiceui/usr/share/doc/gspiceui/
rmdir debian/gspiceui/usr/share/gspiceui
mkdir -p debian/gspiceui/usr/share/pixmaps
cp src/icons/gspiceui-32x32.xpm debian/gspiceui/usr/share/pixmaps
mkdir -p debian/gspiceui/usr/share/applications
cp debian/gspiceui.desktop debian/gspiceui/usr/share/applications/
rm -f debian/gspiceui/usr/share/doc/gspiceui/ChangeLog
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs ChangeLog
dh_installdocs
dh_installexamples
dh_installmenu
dh_installman
dh_link
dh_lintian
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
get-orig-source:
VER=$(shell dpkg-parsechangelog | sed -rne 's,^Version: ([^-+~]+).*,\1,p'); \
uscan --force-download --rename --download-version=$$VER --destdir=. && (\
tar -xz --exclude lib -f gspiceui_$$VER.orig.tar.gz ; \
mv gspiceui-v$$VER gspiceui-$$VER+dfsg;\
GZIP="--best --no-name" tar --owner=root --group=root --mode=a+rX -czf gspiceui_$$VER+dfsg.orig.tar.gz gspiceui-$$VER+dfsg; \
rm -rf gspiceui-$$VER+dfsg ;\
rm -f gspiceui_$$VER.orig.tar.gz);
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
|