File: changelog

package info (click to toggle)
gssdp 1.0.1-1
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 2,452 kB
  • ctags: 857
  • sloc: ansic: 5,580; sh: 4,223; makefile: 169
file content (414 lines) | stat: -rw-r--r-- 12,434 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
gssdp (1.0.1-1) unstable; urgency=medium

  * New upstream release.

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 23 Oct 2016 21:13:39 +0200

gssdp (1.0.0-1) unstable; urgency=medium

  * New upstream release.

 -- Andreas Henriksson <andreas@fatal.se>  Thu, 22 Sep 2016 20:05:14 +0200

gssdp (0.14.16-2) unstable; urgency=medium

  * Convert from cdbs to dh
  * Bump dh compat to 10 (automatic dh-autoreconf)
  * Drop libgssdp-1.0-dbg in favour of automatic dbgsym
  * debian/gbp.conf: import upstream-vcs-tag automatically
  * Drop '*.la' and use --fail-missing

 -- Andreas Henriksson <andreas@fatal.se>  Tue, 13 Sep 2016 11:23:02 +0200

gssdp (0.14.16-1) unstable; urgency=medium

  * New upstream release.
  * Update libgssdp-1.0-3.symbols with new symbols
  * Bump Standards-Version to 3.9.8

 -- Andreas Henriksson <andreas@fatal.se>  Thu, 07 Jul 2016 17:19:47 +0200

gssdp (0.14.14-2) unstable; urgency=medium

  [ Matthias Klose ]
  * Multiarchify the library packages (Closes: #812960)

  [ Andreas Henriksson ]
  * debian/copyright: Updated and switched to DEP5 format
  * Hand over maintenance to Debian GNOME Team
    - build-depend on gnome-pkg-tools
    - include uploaders.mk and gnome-get-source.mk in debian/rules
    - copy debian/control to debian/control.in
    - set Maintainer to Debian GNOME Team and Uploaders to autogenerated.
    - update Vcs-* fields for move from collab-maint to pkg-gnome
  * Bump Standards-Version to 3.9.7

 -- Andreas Henriksson <andreas@fatal.se>  Wed, 09 Mar 2016 15:29:55 +0100

gssdp (0.14.14-1) unstable; urgency=medium

  * New upstream release.
  * Drop Ross Burton from Maintainer on his request.

 -- Andreas Henriksson <andreas@fatal.se>  Fri, 12 Feb 2016 19:52:08 +0100

gssdp (0.14.13-1) unstable; urgency=medium

  * Add debian/gbp.conf
  * Imported Upstream version 0.14.13

 -- Andreas Henriksson <andreas@fatal.se>  Sat, 09 Jan 2016 18:09:09 +0100

gssdp (0.14.12-1) unstable; urgency=medium

  * Imported Upstream version 0.14.12

 -- Andreas Henriksson <andreas@fatal.se>  Tue, 01 Dec 2015 19:32:25 +0100

gssdp (0.14.11-1) unstable; urgency=medium

  * Imported Upstream version 0.14.11

 -- Andreas Henriksson <andreas@fatal.se>  Wed, 29 Apr 2015 19:48:02 +0200

gssdp (0.14.10-1) unstable; urgency=medium

  * Imported Upstream version 0.14.10

 -- Andreas Henriksson <andreas@fatal.se>  Fri, 15 Aug 2014 22:59:58 +0200

gssdp (0.14.8-2) unstable; urgency=medium

  [ Andreas Henriksson ]
  * Bump Standards-Version to 3.9.5

  [ Paulo Flabiano Smorigo ]
  * Add autoreconf during the build to enable new architectures
    (Closes: #753599)

  [ Andreas Henriksson ]
  * Add missing build-dependencies dh-autoreconf and gtk-doc-tools
    - needed for autoreconf during build.

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 13 Jul 2014 16:35:02 +0200

gssdp (0.14.8-1) unstable; urgency=medium

  * Imported Upstream version 0.14.8
  * Update debian/libgssdp-1.0-3.symbols with three additions

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 13 Jul 2014 16:20:08 +0200

gssdp (0.14.7-1) unstable; urgency=medium

  * Use DEB_LDFLAGS_MAINT_APPEND instead of LDFLAGS
  * Make dh_makeshlibs fail on symbols mismatch
  * Imported Upstream version 0.14.7

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 16 Feb 2014 23:28:28 +0100

gssdp (0.14.6-1) unstable; urgency=low

  * Imported Upstream version 0.14.6
  * Update debian/libgssdp-1.0-3.symbols

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 03 Nov 2013 18:51:13 +0100

gssdp (0.14.5-1) unstable; urgency=low

  * Imported Upstream version 0.14.5

 -- Andreas Henriksson <andreas@fatal.se>  Thu, 17 Oct 2013 21:02:57 +0200

gssdp (0.14.4-1) unstable; urgency=low

  * Imported Upstream version 0.14.4

 -- Andreas Henriksson <andreas@fatal.se>  Sat, 03 Aug 2013 02:36:17 +0200

gssdp (0.14.3-1) unstable; urgency=low

  * Imported Upstream version 0.14.3
  * Switch build-dependency to gtk+ 3
  * Add autotools-dev build-dependency
    - fixes outdated-autotools-helper-file with help from CDBS
  * Don't manually run dh_girepository anymore
    - This is handled by CDBS since 0.4.90

 -- Andreas Henriksson <andreas@fatal.se>  Tue, 04 Jun 2013 13:52:35 +0200

gssdp (0.14.2-2) unstable; urgency=low

  * Upload to unstable.

 -- Andreas Henriksson <andreas@fatal.se>  Sat, 18 May 2013 01:54:22 +0200

gssdp (0.14.2-1) experimental; urgency=low

  * Merge 0.12.2.1-2 changes into experimental branch.
  * Imported Upstream version 0.14.2

 -- Andreas Henriksson <andreas@fatal.se>  Thu, 07 Mar 2013 16:31:25 +0100

gssdp (0.14.1-1) experimental; urgency=low

  * Imported Upstream version 0.14.1
  * Bump glib build-dep version to 2.32 according to configure.ac

 -- Andreas Henriksson <andreas@fatal.se>  Fri, 22 Feb 2013 18:34:00 +0100

gssdp (0.14.0-1) experimental; urgency=low

  * Tighten dev -> gir package dependency
  * Bump standards version to 3.9.4
  * Imported Upstream version 0.14.0
  * Update symbols file for added rescan method

 -- Andreas Henriksson <andreas@fatal.se>  Wed, 20 Feb 2013 14:46:25 +0100

gssdp (0.13.2-1) experimental; urgency=low

  * Imported Upstream version 0.13.2

 -- Andreas Henriksson <andreas@fatal.se>  Sat, 08 Dec 2012 23:09:02 +0100

gssdp (0.13.1-1) experimental; urgency=low

  * Imported Upstream version 0.13.1

 -- Andreas Henriksson <andreas@fatal.se>  Thu, 25 Oct 2012 12:42:20 +0200

gssdp (0.13.0-1) experimental; urgency=low

  * Imported Upstream version 0.13.0
    - Beware! this version stops leaking gio and gobject linker flags!
    - If you use symbols from a library, you need to link to it!
    - Also link your modules with "-Wl,-z,defs" in LDFLAGS to
      catch errors at build time!

 -- Andreas Henriksson <andreas@fatal.se>  Mon, 08 Oct 2012 22:34:15 +0200

gssdp (0.12.2.1-2) unstable; urgency=low

  * libgssdp-1.0-dev now breaks gupnp-vala (<= 0.10.4) for policy compliance.
    Thanks to to Andreas Beckmann for finding and describing the problem.
    (Closes: #696099)
  * Also break (the ancient) gir-repository-dev (<= 0.6.5-5) for correctness

 -- Andreas Henriksson <andreas@fatal.se>  Fri, 22 Feb 2013 22:18:33 +0100

gssdp (0.12.2.1-1) unstable; urgency=low

  * Bump to debhelper compatibility level 9
  * Imported Upstream version 0.12.2.1
  * Vala API is now generated from introspection:
    - build-depend on valac (>= 0.14)
    - install gssdp-1.0.{vapi,deps} in libgssdp-1.0-dev
    - replace existing versions of gupnp-vala
      (0.10.4 will no longer build these files, if built on top
       of this gssdp version)

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 02 Sep 2012 18:32:18 +0200

gssdp (0.12.1-2) unstable; urgency=low

  * Move gssdp gir package to introspection section
  * Upload to unstable

 -- Andreas Henriksson <andreas@fatal.se>  Fri, 16 Dec 2011 14:18:29 +0100

gssdp (0.12.1-1) experimental; urgency=low

  * Imported Upstream version 0.12.1

 -- Andreas Henriksson <andreas@fatal.se>  Fri, 16 Dec 2011 13:23:27 +0100

gssdp (0.12.0-1) experimental; urgency=low

  * Imported Upstream version 0.12.0
  * Update debian/watch for ftp.gnome.org
  * Switch to debian source format 3.0 (quilt)
    - needed for xz orig tarball.
  * Rename library package to match new soname.
    - also update symbols
  * Fix lintian warning about bracket expansion in debhelper install file

 -- Andreas Henriksson <andreas@fatal.se>  Tue, 30 Aug 2011 16:27:08 +0200

gssdp (0.10.0-2) unstable; urgency=low

  * Upload to unstable.

 -- Andreas Henriksson <andreas@fatal.se>  Mon, 11 Apr 2011 12:54:03 +0200

gssdp (0.10.0-1) experimental; urgency=low

  * Make -dev package depend or gir1.2- package.
  * Imported Upstream version 0.10.0
  * debian/rules: fix dh_girepository hook for gir1.2
  * Update symbols file for 0.10 release.
  * Bump policy version to 3.9.2
  * Upload to experimental for now to avoid disrupting
    the gobject-introspection.

 -- Andreas Henriksson <andreas@fatal.se>  Fri, 08 Apr 2011 14:51:59 +0200

gssdp (0.8.2-2) unstable; urgency=low

  * Linking tests with gold linker fixed by upstream in 0.8.1 (Closes: #618075)
  * Bump libsoup2.4-dev build dependency to >= 2.26.1 (Closes: #607778)
  * Upload to unstable.

 -- Andreas Henriksson <andreas@fatal.se>  Wed, 23 Mar 2011 16:41:07 +0100

gssdp (0.8.2-1) experimental; urgency=low

  [ Andreas Henriksson ]
  * Imported Upstream version 0.8.2
  * Only watch for stable releases

  [ Sebastien Bacher ]
  * build-depends on libgtk2.0-dev rather than libglade2-dev (Closes:
    #599440)

  [ Andreas Henriksson ]
  * Update to new gir policy (gir 1.2):
  - Rename gir1.0-gssdp-1.0 to gir1.2-gssdp-1.0
    (and conflict/replace the old name)
  - Bump gobject-introspection build dependency to (>= 0.9.12-4~)
    and libgirepository1.0-dev to (>= 0.9.12)
  - Build-depend on gir1.2-glib-2.0

 -- Andreas Henriksson <andreas@fatal.se>  Tue, 14 Dec 2010 11:13:42 +0100

gssdp (0.8.0-2) unstable; urgency=low

  * Add symbols file for libgssdp-1.0-2
  * Upload to unstable

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 03 Oct 2010 16:37:36 +0200

gssdp (0.8.0-1) experimental; urgency=low

  * debian/watch: fix for new gupnp.org site layout.
  * Imported Upstream version 0.8.0

 -- Andreas Henriksson <andreas@fatal.se>  Mon, 20 Sep 2010 20:53:10 +0200

gssdp (0.7.2-2) unstable; urgency=low

  * Call dh_girepository
  * Add missing build-dependency on gir1.0-glib-2.0

 -- Andreas Henriksson <andreas@fatal.se>  Mon, 26 Apr 2010 12:07:41 +0200

gssdp (0.7.2-1) unstable; urgency=low

  * New upstream release
  * Include new GObject Introspection data.
    + ship .gir in -dev package.
    + Add new gir1.0-gssdp-1.0 package with typelib.
  * Use multi-line build-dependencies and add gobject-introspection.
  * Add build-dependency on libgirepository1.0-dev
  * Add a versioned replaces on libgssdp1.0-dev against gir-repository-dev
    (<= 0.6.5-5), to prevent .gir file collisions.
  * Add Homepage and Vcs-* fields
  * Bump to policy version 3.8.4
  * Add myself to Uploaders (acknowledged by Ross Burton)

 -- Andreas Henriksson <andreas@fatal.se>  Tue, 20 Apr 2010 14:18:22 +0200

gssdp (0.7.1-1) unstable; urgency=low

  * New upstream release.
  * Clarify copyright

 -- Ross Burton <ross@debian.org>  Mon, 25 Jan 2010 09:07:49 +0000

gssdp (0.7.0-1) unstable; urgency=low

  * New upstream release.

 -- Ross Burton <ross@debian.org>  Thu, 24 Sep 2009 13:38:33 +0100

gssdp (0.6.4-2) unstable; urgency=low

  * Bump libglib2.0 build-dependency (Closes: #517392)

 -- Ross Burton <ross@debian.org>  Sun, 08 Mar 2009 00:12:33 +0000

gssdp (0.6.4-1) unstable; urgency=low

  * New upstream release.

 -- Ross Burton <ross@debian.org>  Fri, 20 Feb 2009 12:00:22 +0000

gssdp (0.6.2-1) unstable; urgency=low

  * New upstream release.

 -- Ross Burton <ross@debian.org>  Tue, 30 Sep 2008 15:49:01 +0100

gssdp (0.6.1-1) unstable; urgency=low

  * Brown paper bag upstream release which bumps soname because of the ABI
    breakage.
  * Fix libsoup dependency on -dev
  * Add --as-needed to link flags

 -- Ross Burton <ross@debian.org>  Mon, 19 May 2008 21:39:42 +0100

gssdp (0.6-1) unstable; urgency=low

  * New upstream release.
    - Uses libsoup2.4 rather than 2.2

 -- Ross Burton <ross@debian.org>  Tue, 13 May 2008 17:39:44 +0100

gssdp (0.4.2-1) unstable; urgency=low

  * New upstream release.
  * Build-depend on libgnutls-dev to fix libsoup2.2-dev build failure.

 -- Ross Burton <ross@debian.org>  Sun, 24 Feb 2008 17:23:12 +0000

gssdp (0.4.1-3) unstable; urgency=low

  * Add debian/watch.
  * Bump Standards
  * Refer to common GFDL license instead of containing the full text
  * Make -dbg package priority extra.
  * Don't use Source-Version

 -- Ross Burton <ross@debian.org>  Thu, 21 Feb 2008 10:24:13 +0000

gssdp (0.4.1-2) unstable; urgency=low

  * Add -dbg package.

 -- Ross Burton <ross@debian.org>  Tue, 16 Oct 2007 17:10:26 +0100

gssdp (0.4.1-1) unstable; urgency=low

  * New upstream release.

 -- Ross Burton <ross@debian.org>  Sun, 23 Sep 2007 14:44:20 +0100

gssdp (0.4-2) unstable; urgency=low

  * Add missing libsoup2.2-dev depends on libgssdp-1.0-dev.

 -- Ross Burton <ross@debian.org>  Thu, 23 Aug 2007 17:15:30 +0100

gssdp (0.4-1) unstable; urgency=low

  * New upstream release.

 -- Ross Burton <ross@debian.org>  Thu, 26 Jul 2007 19:20:04 +0100

gssdp (0.1-1) unstable; urgency=low

  * Initial packaging.

 -- Ross Burton <ross@debian.org>  Wed, 13 Jun 2007 09:52:29 +0100