File: REQUIREMENTS

package info (click to toggle)
gst-plugins-base0.10 0.10.19-2
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 17,772 kB
  • ctags: 15,183
  • sloc: ansic: 107,732; sh: 9,748; makefile: 1,618; xml: 1,610; perl: 1,513; python: 424; sed: 16
file content (105 lines) | stat: -rw-r--r-- 2,702 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
GStreamer uses a *large* array of tools and libraries, most of which are
optional.  We have attempted to make sure that any code that depends on
optional libraries doesn't get built unless you have those libraries.  If
you find this not to be the case, please, let us know by filing a bug
report at http://bugzilla.gnome.org/.


Required tools:
===============

An extra set of tools is required if you wish to build GStreamer out of
CVS (using autogen.sh):

autoconf 2.52 or better 
automake 1.5
gettext 0.11.5
libtool v1.4 or better
pkgconfig 0.9.0 or better (http://www.freedesktop.org/software/pkgconfig/)

Required libraries:
===================

The core GStreamer libraries. See the gstreamer/ module in GStreamer cvs, or
the version that corresponds to this plugin release.

Package:	GStreamer
Version:	0.10.11.2
Recommended:	0.10.latest
URL:		http://gstreamer.freedesktop.org/
DebianPackage:	libgstreamer0.10-dev
Notes:		The required version is updated frequently, so the version
	listed in this file is often wrong.  If you are compiling from CVS,
	the required version is often the latest GStreamer CVS.

Package:	liboil
Version:	>= 0.3.8
Recommended:	0.3.latest
URL:		http://liboil.freedesktop.org/
DebianPackage:	liboil0.3-dev


Optional libraries:
===================

This file lists supporting libraries for which gst-plugins-base contains
plugins, as well as their minimum version.  You can find the corresponding
plugins in ext/(library)

Package:	GTK+
Version:	>= 2.0
Recommended:	>= 2.2
URL:		http://www.gtk.org/
DebianPackage:	libgtk2.0-dev
Notes:		Required by several examples

Package:	Xlib
Plugins:	xvimagesink, ximagesink, v4l (v4lsrc), ximagesrc
DebianPackage:	libx11-dev libxv-dev libxt-dev

Package:	Alsa
Version:	>= 0.9.1
Plugins:	alsa (alsasrc, alsasink)
URL:		http://www.alsa-project.org/
DebianPackage:	libasound2-dev

Package:	CDParanoia
Plugins:	cdparanoia
URL:		http://xiph.org/paranoia/
DebianPackage:	libcdparanoia0-dev

Package:	GnomeVFS
Version:	>= 2.0 (2.4?)
Plugins:	gnomevfs (gnomevfssrc)
URL:		http://www.gnome.org/
DebianPackage:	libgnomevfs2-dev

Package:	libvisual
Version:	>= 0.2.0
Recommended:	0.4.0
Plugins:	libvisual
URL:		http://localhost.nl/~synap/libvisual-wiki/index.php/Main_Page
DebianPackage:	libvisual0.4-dev

Package:	Ogg
Version:	>= 1.0
Plugins:	ogg (oggdemux, oggmux)
URL:		http://xiph.org/ogg/
DebianPackage:	libogg-dev

Package:	Pango
Plugins:	pango
DebianPackage:	libpango1.0-dev
URL:		http://www.pango.org/

Package:	Theora
Plugins:	theora (theoradec, theoraenc)
URL:		http://www.theora.org/
DebianPackage:	libtheora-dev

Package:	Vorbis
Plugins:	vorbis (vorbisdec, vorbisenc)
DebianPackage:	libvorbis-dev
URL:		http://www.vorbis.com/