File: README.Debian

package info (click to toggle)
gst-plugins-ugly0.10 0.10.8-1
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 6,920 kB
  • ctags: 3,310
  • sloc: ansic: 35,465; sh: 9,814; perl: 1,476; xml: 845; cpp: 641; makefile: 535; python: 465; sed: 16
file content (84 lines) | stat: -rw-r--r-- 2,581 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
Gstreamer for Debian
====================
This package contains the GStreamer plugin distribution.

More information can be found at http://gstreamer.net/

As of GStreamer plugins version 0.8.0 all packages are versioned and
parallel installable with other releases with other major.minor
versions.  For example, 0.8.x series is versioned as 0.8 and parallel
installable with both unversioned 0.6.x series and future 0.9.x and
beyond.  The version part is represented as VER below.

GStreamer plugins are split into a number of packages:

plugins without external dependencies:

   gstreamerVER-plugins-ugly     many independent plugins

documentation:

   gstreamerVER-plugins-ugly-doc		html documentation


Notes
=====

ChangeLog
---------

The upstream ChangeLog is not included in all the plugin packages due to its
large size.  Please see upstream sources if you are interested in detailed
source changes.

Unofficial plugin packages
--------------------------

Various plugins in the upstream source are not yet packaged or not officially
supported.  This is most likely due to:

  * upstream considers them too unstable
  * libraries they depend on are not are yet in Debian or are poorly supported

To build additional unofficial plugin packages:

  * Get the source and Debian diff (for example, "apt-get source gst-plugins")
  * Add new package name to the EXTRA_PLUGINS variable in debian/rules
  * Add appropriate dependency and control info to debian/extra
  * Add a .install file for the package
  * Rebuild

Currently available untested and unsupported info has been added for:
  * gstreamer-amrnb
  * gstreamer-lame

mp3 encoding plugins are NOT officially packaged.  Specifically, the LAME
plugin is NOT packaged due to Debian not including the LAME libraries.
Please see the following links for more information:

  http://www.debian.org/devel/wnpp/unable-to-package
  http://lists.debian.org/debian-devel-0006/msg01213.html
  http://www.mp3dev.org/

Ogg Vorbis provides a good alternative to mp3s.  Try the
gstreamer-vorbis package.  For more information:

  http://www.vorbis.com/


External tools support
----------------------

Your favorite codec isn't wrapped as a plugin?  External programs can be
used to process streams.  Take a look at "pipefilter" element or try
something like this (untested):

  $ mkfifo fifo
  $ gst-launch myaudiosrc ! filesink location=fifo &
  $ cat fifo | my_encoder > output_file


David I. Lehn <dlehn@debian.org>  Tue, 23 Mar 2004 04:38:37 -0500

update:
Sebastien Bacher <seb128@debian.org>  Wed, 14 Dec 2005 17:00:21 +0100