1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
|
PACKAGE=gtkpool
include /usr/share/quilt/quilt.make
arch := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
CFLAGS := -g -Wall
ifneq "$(findstring noopt,$(DEB_BUILD_OPTIONS))" ""
CFLAGS += -O0
else
CFLAGS += -O2
endif
ifeq "$(arch)" "alpha"
CFLAGS += -mieee
endif
build: patch config.status gtkpool/gtkpool
config.status: configure
autoreconf --install
CXXFLAGS="$(CFLAGS)" ./configure --prefix=/usr --sysconfdir=/etc \
--mandir='$${prefix}/share/man'
gtkpool/gtkpool:
dh_testdir
$(MAKE) CFLAGS="$(CFLAGS)"
clean: unpatch
dh_testdir
dh_testroot
[ ! -f Makefile ] || $(MAKE) distclean
rm -rf admin Makefile.dist configure.in.in subdirs acinclude.m4 stamp-h.in
dh_clean stamp-build
binary-indep:
binary-arch: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs usr/games usr/lib/gtkpool
$(MAKE) install bindir='$${prefix}/games' DESTDIR=$(CURDIR)/debian/gtkpool
dh_installdocs README TODO
dh_installman debian/gtkpool.6
dh_installchangelogs ChangeLog
dh_installmenu
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary
|