File: changelog

package info (click to toggle)
guice 4.2.1-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 8,032 kB
  • sloc: xml: 83,536; java: 65,101; sh: 111; jsp: 12; makefile: 7
file content (165 lines) | stat: -rw-r--r-- 5,048 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
guice (4.2.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream release

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 16 Oct 2018 15:51:07 +0200

guice (4.2-3) unstable; urgency=medium

  * Team upload.
  * Added the missing build dependency on libeasymock-java

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 19 Sep 2018 09:46:02 +0200

guice (4.2-2) unstable; urgency=medium

  * Team upload.
  * Removed the --has-package-version flag (pom version 4.2.0 doesn't match
    the package version)

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 30 Jul 2018 14:59:12 +0200

guice (4.2-1) unstable; urgency=medium

  * Team upload.

  [ Miguel Landaeta ]
  * Remove myself from uploaders list. (Closes: #871859)
  * Update copyright info.

  [ Emmanuel Bourg ]
  * New upstream release
  * Removed the Maven 2 compatibility patch
  * Standards-Version updated to 4.1.5
  * Switch to debhelper level 11
  * Use salsa.debian.org Vcs-* URLs
  * Replaced debian/orig-tar.sh with the File-Excluded field in debian/copyright

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 24 Jul 2018 09:10:31 +0200

guice (4.0-4) unstable; urgency=medium

  * Team upload.
  * Rebuild with cglib 3.2.5 (Closes: #866411)
  * Standards-Version updated to 4.0.0
  * Switch to debhelper level 10

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 29 Jun 2017 19:10:50 +0200

guice (4.0-3) unstable; urgency=medium

  * Team upload.
  * Depend on libasm-java (>= 5.0) instead of libasm4-java
  * Standards-Version updated to 3.9.8
  * Use a secure Vcs-Git URL

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 04 Oct 2016 15:29:40 +0200

guice (4.0-2) unstable; urgency=medium

  * Team upload.
  * Fixed the build failure with Java 8
  * Depend on libcglib-java (>= 3.2) instead of libcglib3-java
  * Standards-Version updated to 3.9.7 (no changes)

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 10 Feb 2016 09:59:49 +0100

guice (4.0-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Build with maven-debian-helper
  * Install the no_aop artifact linked to the main jar in /usr/share/maven-repo
  * Added the Built-Using field with the versions of ASM and CGLIB used

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 19 Nov 2015 19:18:34 +0100

guice (4.0~beta5-2) unstable; urgency=medium

  * Team upload.

  [ Emmanuel Bourg ]
  * Fixed debian/watch to catch the version 4.0~beta.

  [ Markus Koschany ]
  * Vcs-Browser: Use https.
  * Switch to bnd1.50 because guice FTBFS with bnd >= 2.1.
  * Change homepage and Source field to new github.com address.

 -- Markus Koschany <apo@debian.org>  Sat, 14 Nov 2015 16:39:26 +0100

guice (4.0~beta5-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - New dependency on libguava-java
    - Removed the copyright info about the deleted Jsr166HashMap class
    - Removed 04_java8-compatibility.diff and 05_upgrade-asm-and-cglib.patch
      (fixed upstream)
  * Use XZ compression for the upstream tarball
  * debian/watch: Watch the release tags on Github

 -- Emmanuel Bourg <ebourg@apache.org>  Sat, 18 Oct 2014 17:39:12 +0200

guice (3.0-6) unstable; urgency=medium

  * Team upload.
  * Build and install the grapher, jmx, jndi, servlet, multibindings, spring
    and throwingproviders extensions (Closes: #685871)
  * Fixed a build failure caused by the cglib/asm transition
  * Use links to the system jars instead of patching the build script
  * debian/rules: Use mh_install once instead of mh_installpoms/mh_installjar
  * Standards-Version updated to 3.9.6 (no changes)

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 09 Oct 2014 16:08:42 +0200

guice (3.0-5) unstable; urgency=medium

  * Team upload.
  * Depend on libasm4-java instead of libasm3-java
  * Depend on libcglib3-java instead of libcglib-java
  * Switch to debhelper level 9

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 15 Sep 2014 15:22:19 +0200

guice (3.0-4) unstable; urgency=medium

  [ Emmanuel Bourg ]
  * Team upload.
  * Fixed a build failure with Java 8 (Closes: #750750)
  * Use XZ compression for the upstream tarball
  * Exclude the IntelliJ project files from the upstream tarball
  * Use canonical URLs for the Vcs-* fields

  [ tony mancill ]
  * Bump Standards-Version to 3.9.5 (no changes).

 -- Emmanuel Bourg <ebourg@apache.org>  Fri, 08 Aug 2014 18:21:01 +0200

guice (3.0-3) unstable; urgency=low

  * Team upload.
  * Remove deprecated DMUA flag.
  * Bump Standards-Version to 3.9.4. No changes required.

 -- tony mancill <tmancill@debian.org>  Wed, 15 May 2013 20:07:04 -0700

guice (3.0-2) experimental; urgency=low

  [ Miguel Landaeta ]
  * Enable assistedinject extension. (Closes: #683644).
  * Add Build-Depends on libjarjar-java.
  * Bump Standards-Version to 3.9.3. No changes were required.
  * Update copyright file.

  [ tony mancill ]
  * Set DMUA flag.

 -- Miguel Landaeta <miguel@miguel.cc>  Mon, 13 Aug 2012 19:34:14 -0430

guice (3.0-1) unstable; urgency=low

  * Initial release. (Closes: #579121)

 -- Miguel Landaeta <miguel@miguel.cc>  Wed, 14 Sep 2011 20:25:17 +0200