File: INSTALL

package info (click to toggle)
gworkspace 0.9.4-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 20,832 kB
  • sloc: objc: 69,382; sh: 488; makefile: 39
file content (26 lines) | stat: -rw-r--r-- 896 bytes parent folder | download | duplicates (5)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Installing GWorkspace
=========================

GWorkspace requires GNUstep to be installed. Make sure that you have an
up to date version installed on your system! 

  ./configure
  make install

If you are on Linux and want to use the new inotify-based fswatcher, you can pass --with-inotify to configure.

To enable the new metadata indexing and searching system, cd into the GWMetadata directory and:

  ./configure
  make
  make install

To enable all the GWorkspace features you need also:

* The PDFKit framework (version >= 0.9) downloadable from the GWorkspace home page.
PDFKit is needed to build the pdf contents inspector and to extract metadata from pdf files.

* System Preferences available from the GNUstep SVN repository.
  svn co http://svn.gna.org/svn/gnustep/apps/systempreferences/trunk
  If you install the GWMetadata system, SystemPreferences is needed to configure it.