1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
|
export LC_ALL=C.UTF-8
%:
dh $@ --with gir
override_dh_auto_configure:
dh_auto_configure --builddir build-main -- --with-graphite2=yes --enable-introspection --with-gobject --enable-gtk-doc --enable-static
dh_auto_configure --builddir build-udeb -- --with-graphite2=no
override_dh_auto_clean:
dh_auto_clean --builddir build-main
dh_auto_clean --builddir build-udeb
override_dh_auto_build:
dh_auto_build --builddir build-main
dh_auto_build --builddir build-udeb
override_dh_auto_test:
dh_auto_test --builddir build-main
dh_auto_test --builddir build-udeb
override_dh_auto_install:
dh_auto_install --builddir build-main
override_dh_install:
dh_install --exclude=subset
override_dh_makeshlibs:
dh_makeshlibs --version-info --add-udeb="libharfbuzz0-udeb" -- -c4
|