1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
export DH_VERBOSE=1
%:
dh $@
DESTDIR:=`pwd`/debian/tmp/
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
LIBDIR:=/usr/lib/$(DEB_HOST_MULTIARCH)
WITH_HDF5:=--with-hdf5=/usr/lib/$(DEB_HOST_MULTIARCH)/hdf5/serial
override_dh_auto_configure:
./configure --prefix=/usr --libdir=$(LIBDIR) \
--enable-python \
$(WITH_HDF5) \
HDF4_INCLUDE=/usr/include/hdf \
UDUNITS2LIBS=-ludunits2 \
PYTHON=python3
override_dh_auto_build:
-($(MAKE) doc || true)
dh_auto_build
override_dh_auto_install:
dh_auto_install
find debian -name '*.la' -delete
rm debian/tmp/usr/share/harp/doc/html/_static/jquery*
rm debian/tmp/usr/share/harp/doc/html/_static/underscore*
rm debian/tmp/usr/share/harp/doc/html/_static/doctools.js
rm debian/tmp/usr/share/harp/doc/html/_static/language_data.js
rm debian/tmp/usr/share/harp/doc/html/_static/searchtools.js
rm -rf debian/tmp/usr/share/harp/doc/html/_static/fonts
|