File: contravariant-extras.cabal

package info (click to toggle)
haskell-contravariant-extras 0.3.5.1-2
  • links: PTS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 84 kB
  • sloc: haskell: 363; makefile: 5
file content (36 lines) | stat: -rw-r--r-- 1,672 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
name: contravariant-extras
version: 0.3.5.1
category: Control
synopsis: Extras for the "contravariant" package
homepage: https://github.com/nikita-volkov/contravariant-extras
bug-reports: https://github.com/nikita-volkov/contravariant-extras/issues
author: Nikita Volkov <nikita.y.volkov@mail.ru>
maintainer: Nikita Volkov <nikita.y.volkov@mail.ru>
copyright: (c) 2015, Nikita Volkov
license: MIT
license-file: LICENSE
build-type: Simple
cabal-version: >=1.10

source-repository head
  type: git
  location: git://github.com/nikita-volkov/contravariant-extras.git

library
  hs-source-dirs: library
  default-extensions: Arrows, BangPatterns, ConstraintKinds, DataKinds, DefaultSignatures, DeriveDataTypeable, DeriveFoldable, DeriveFunctor, DeriveGeneric, DeriveTraversable, EmptyDataDecls, FlexibleContexts, FlexibleInstances, FunctionalDependencies, GADTs, GeneralizedNewtypeDeriving, LambdaCase, LiberalTypeSynonyms, MagicHash, MultiParamTypeClasses, MultiWayIf, NoImplicitPrelude, NoMonomorphismRestriction, OverloadedStrings, PatternGuards, ParallelListComp, QuasiQuotes, RankNTypes, RecordWildCards, ScopedTypeVariables, StandaloneDeriving, TemplateHaskell, TupleSections, TypeFamilies, TypeOperators, UnboxedTuples
  default-language: Haskell2010
  exposed-modules:
    Contravariant.Extras
    Contravariant.Extras.Contrazip
    Contravariant.Extras.ContrazipLifting
    Contravariant.Extras.Op
    Contravariant.Extras.Op.Contrazip
  other-modules:
    Contravariant.Extras.TH
    Contravariant.Extras.Prelude
  build-depends:
    base >=4.10 && <5,
    contravariant >=1.3 && <2,
    template-haskell >=2.8 && <3,
    template-haskell-compat-v0208 >=0.1.2 && <2