1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125
|
Source: haskell-hashtables
Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Uploaders:
Iain Lane <laney@debian.org>,
Priority: extra
Section: haskell
Build-Depends:
cdbs,
debhelper (>= 9),
ghc (>= 8),
ghc-prof,
haskell-devscripts (>= 0.13),
libghc-hashable-dev,
libghc-hashable-prof,
libghc-primitive-dev,
libghc-primitive-prof,
libghc-vector-dev (<< 0.12),
libghc-vector-dev (>= 0.7),
libghc-vector-prof,
Build-Depends-Indep:
ghc-doc,
libghc-hashable-doc,
libghc-primitive-doc,
libghc-vector-doc,
Standards-Version: 3.9.8
Homepage: http://github.com/gregorycollins/hashtables
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/DHG_packages.git/tree/p/haskell-hashtables
Vcs-Git: https://anonscm.debian.org/git/pkg-haskell/DHG_packages.git
Package: libghc-hashtables-dev
Architecture: any
Depends:
${haskell:Depends},
${misc:Depends},
${shlibs:Depends},
Recommends:
${haskell:Recommends},
Suggests:
${haskell:Suggests},
Provides:
${haskell:Provides},
Description: mutable hash tables${haskell:ShortBlurb}
This package provides a couple of different implementations of mutable hash
tables in the ST monad, as well as a typeclass abstracting their common
operations, and a set of wrappers to use the hash tables in the IO monad.
.
There are three hash table implementations:
.
* Data.HashTable.ST.Basic contains a basic open-addressing hash table using
linear probing as the collision strategy. This should currently be the
fastest available hash table implementation for lookups, although it has a
higher memory overhead than others.
* Data.HashTable.ST.Cuckoo contains an implementation of "cuckoo hashing".
Cuckoo hashing has worst-case O(1) lookups and performs well even when the
table is highly loaded.
* Data.HashTable.ST.Linear contains a linear hash table, which trades some
insert and lookup performance for higher space efficiency and much shorter
delays when expanding the table.
.
${haskell:Blurb}
Package: libghc-hashtables-prof
Architecture: any
Depends:
${haskell:Depends},
${misc:Depends},
${shlibs:Depends},
Recommends:
${haskell:Recommends},
Suggests:
${haskell:Suggests},
Provides:
${haskell:Provides},
Description: mutable hash tables -- profiling libraries${haskell:ShortBlurb}
This package provides a couple of different implementations of mutable hash
tables in the ST monad, as well as a typeclass abstracting their common
operations, and a set of wrappers to use the hash tables in the IO monad.
.
There are three hash table implementations:
.
* Data.HashTable.ST.Basic contains a basic open-addressing hash table using
linear probing as the collision strategy. This should currently be the
fastest available hash table implementation for lookups, although it has a
higher memory overhead than others.
* Data.HashTable.ST.Cuckoo contains an implementation of "cuckoo hashing".
Cuckoo hashing has worst-case O(1) lookups and performs well even when the
table is highly loaded.
* Data.HashTable.ST.Linear contains a linear hash table, which trades some
insert and lookup performance for higher space efficiency and much shorter
delays when expanding the table.
.
${haskell:Blurb}
Package: libghc-hashtables-doc
Architecture: all
Section: doc
Depends:
${haskell:Depends},
${misc:Depends},
${shlibs:Depends},
Recommends:
${haskell:Recommends},
Suggests:
${haskell:Suggests},
Provides:
${haskell:Provides},
Description: mutable hash tables -- documentation${haskell:ShortBlurb}
This package provides a couple of different implementations of mutable hash
tables in the ST monad, as well as a typeclass abstracting their common
operations, and a set of wrappers to use the hash tables in the IO monad.
.
There are three hash table implementations:
.
* Data.HashTable.ST.Basic contains a basic open-addressing hash table using
linear probing as the collision strategy. This should currently be the
fastest available hash table implementation for lookups, although it has a
higher memory overhead than others.
* Data.HashTable.ST.Cuckoo contains an implementation of "cuckoo hashing".
Cuckoo hashing has worst-case O(1) lookups and performs well even when the
table is highly loaded.
* Data.HashTable.ST.Linear contains a linear hash table, which trades some
insert and lookup performance for higher space efficiency and much shorter
delays when expanding the table.
.
${haskell:Blurb}
|