1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
|
Description: Don't list -l flags in Makefile dependencies.
hercules fails to cross build from source, because an upstream
Makefile.am includes -lltdl in a Makefile dependency. This triggers
architecture-specific behaviour in make. It looks up the flag using the
built-in library search path (for the build architecture). However
libltdl is only installed for the host architecture, so the library
isn't found and make gives up. One shouldn't list such flags in
dependencies. Please consider applying the attached patch to make
hercules cross buildable.
Author: Helmut Grohne <helmut@subdivi.de>
diff -u hercules-3.13/Makefile.am hercules-3.13/Makefile.am
@@ -446,13 +446,13 @@
hercules_LDFLAGS = $(HLDFLAGS)
- hercules_DEPENDENCIES = libherc.la libhercs.la libhercd.la libhercu.la -lltdl $(HDEPS)
+ hercules_DEPENDENCIES = libherc.la libhercs.la libhercd.la libhercu.la $(HDEPS)
if BUILD_SHARED
herclin_SOURCES = herclin.c hdlmain.c
herclin_LDADD = libherc.la libhercs.la libhercd.la libhercu.la -lltdl $(LDADD)
herclin_LDFLAGS = $(HLDFLAGS)
-herclin_DEPENDENCIES = libherc.la libhercs.la libhercd.la libhercu.la -lltdl $(HDEPS)
+herclin_DEPENDENCIES = libherc.la libhercs.la libhercd.la libhercu.la $(HDEPS)
endif
#
|