1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
|
%:
dh $@ --with sphinxdoc
override_dh_installinit:
dh_installinit --name=hippotatd
ifeq (,$(filter upstream-cargo, $(DEB_BUILD_PROFILES)))
include /usr/share/dpkg/architecture.mk
include /usr/share/dpkg/buildflags.mk
include /usr/share/rustc/architecture.mk
export CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
export DEB_HOST_RUST_TYPE DEB_HOST_GNU_TYPE
PATH:=/usr/share/cargo/bin:$(PATH)
CARGO_HOME=$(shell pwd)/debian/cargo_home
DEB_CARGO_CRATE=hippotat
export PATH CARGO_HOME DEB_CARGO_CRATE
TARGET_RELEASE_DIR = target/$(DEB_HOST_RUST_TYPE)/release
export TARGET_RELEASE_DIR
execute_before_dh_auto_build:
if test -f Cargo.lock; then mv Cargo.lock Cargo.lock.upstream; fi
cargo prepare-debian /usr/share/cargo/registry
execute_before_dh_auto_clean:
if test -f Cargo.lock.upstream; \
then mv Cargo.lock.upstream Cargo.lock; fi
execute_after_dh_auto_clean:
$(MAKE) very-clean
rm -rf debian/cargo_home
override_dh_auto_test:
@echo not running tests during build - they need unshare
override_dh_missing:
dh_missing --fail-missing
endif
|