File: changelog

package info (click to toggle)
hyphy 2.5.1+dfsg-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 29,104 kB
  • sloc: cpp: 117,933; sh: 11,503; python: 3,026; xml: 467; lisp: 341; makefile: 315; ansic: 308
file content (155 lines) | stat: -rw-r--r-- 4,637 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
hyphy (2.5.1+dfsg-3) unstable; urgency=medium

  * Versioned Depends: hyphy-common (= ${source:Version})
    Closes: #948093

 -- Andreas Tille <tille@debian.org>  Tue, 07 Jan 2020 21:23:52 +0100

hyphy (2.5.1+dfsg-2) unstable; urgency=medium

  * Fix installation of NEWS.Debian to enable arch all only builds
  * Make autopkgtest more verbose

 -- Andreas Tille <tille@debian.org>  Sat, 04 Jan 2020 21:21:58 +0100

hyphy (2.5.1+dfsg-1) unstable; urgency=medium

  [ Helmut Grohne ]
  * Add pkg-config to Build-Depends as FindMPI.cmake will need it for cross
    compilation. (Closes: #943311)

  [ Andreas Tille ]
  * New upstream version
  * debhelper-compat 12
  * Secure URI in copyright format
  * Remove trailing whitespace in debian/changelog
  * New upstream version
  * Standards-Version: 4.4.1
  * Use secure URI in Homepage field.
  * Remove patches msse_option_only_if_available.patch that are missing
    from debian/patches/series.
  * Skip GTEST target for the moment since this is currently in flux
    see https://github.com/veg/hyphy/issues/1058
  * No need to rename executables any more since upstream is doing this now
  * Autopkgtest exists since last release - so close bug
    Closes: #909707

 -- Andreas Tille <tille@debian.org>  Fri, 06 Dec 2019 22:47:47 +0100

hyphy (2.3.14+dfsg-2) unstable; urgency=medium

  [ Saira Hussain ]
  * Team upload.
  * Add unit test description file
  * Add the SimpleAnalyses suite for testing
  * Add control file for AUTOPKGTESTS

  [ Andreas Tille ]
  * Standards-Version: 4.3.1

 -- Saira Hussain <saira.0213@zoho.com>  Fri, 05 Jul 2019 13:45:06 +0000

hyphy (2.3.14+dfsg-1) unstable; urgency=medium

  * New upstream version
  * debhelper 11
  * Standards-Version: 4.2.1

 -- Andreas Tille <tille@debian.org>  Wed, 26 Sep 2018 16:55:30 +0200

hyphy (2.3.13+dfsg-1) unstable; urgency=medium

  * Team upload.

  [ Steffen Moeller ]
  * debian/upstream/metadata: Added ref to OMICtools

  [ Andreas Tille ]
  * New upstream version
  * debhelper 11
  * Add Build-Depends: opencl-dev
  * debian/rules:
     - Do not parse d/changelog
     - regard $(DEB_BUILD_OPTIONS) for override_dh_auto_test

  [ Liubov Chuprikova ]
  * Drop hyphygui as it was removed from upstream
  * Point Vcs fields to salsa.debian.org
  * Standards-Version: 4.1.5

 -- Liubov Chuprikova <chuprikovalv@gmail.com>  Tue, 10 Jul 2018 08:39:13 +0200

hyphy (2.2.7+dfsg-1) unstable; urgency=medium

  * New upstream version
  * Use xz compression in d/watch
  * python-hyphy is now distributed in separate source archive so
    removing it from this package

 -- Andreas Tille <tille@debian.org>  Fri, 14 Oct 2016 08:01:08 +0200

hyphy (2.2.6+dfsg-5) unstable; urgency=medium

  * Fix error: narrowing conversion from 'double' to 'unsigned char'
  * Fix error: replacing false with nil
    Closes: #811866

 -- Andreas Tille <tille@debian.org>  Mon, 15 Aug 2016 12:44:58 +0200

hyphy (2.2.6+dfsg-4) unstable; urgency=medium

  * Fix gcc-6 build issue by incorporating upstream patch
    Closes: #811866
  * cme fix dpkg-control
  * Fix more spelling errors
  * hardening=+bindnow

 -- Andreas Tille <tille@debian.org>  Fri, 22 Jul 2016 15:05:54 +0200

hyphy (2.2.6+dfsg-3) unstable; urgency=medium

  * Change build-dep on python3-dev to python3-all-dev to enable building for
    all supported python3 versions (thanks to Scott Kitterman
    <debian@kitterman.com> for the patch)
    Closes: #809452

 -- Andreas Tille <tille@debian.org>  Wed, 30 Dec 2015 21:49:03 +0100

hyphy (2.2.6+dfsg-2) unstable; urgency=medium

  [ Matthias Klose ]
  * Hand-edit swig generated file to build with Python3.5.
    Closes: #802999

  [ Andreas Tille ]
  * Remove arch specific flags
    Closes: #802994

 -- Andreas Tille <tille@debian.org>  Mon, 26 Oct 2015 11:20:39 +0100

hyphy (2.2.6+dfsg-1) unstable; urgency=medium

  * New upstream version
  * Hack around a mac-ism in setup.py

 -- Andreas Tille <tille@debian.org>  Tue, 22 Sep 2015 17:50:33 +0200

hyphy (2.2.5+dfsg-2) unstable; urgency=medium

  * Versioned Build-Depends: cmake (>= 3.0)
  * Drop profiling option (Thanks for the hint to Michael Banck
    <mbanck@debian.org>)
    Closes: #793345
  * Disable unneded test that breaks on 32 bit architectures (Thanks for
    the hint to Jakub Wilk <jwilk@debian.org>)
    Closes: #793346
  * Make sure that also in tests the existence of SSE3 extension is done
    Closes: #793344

 -- Andreas Tille <tille@debian.org>  Thu, 23 Jul 2015 17:13:45 +0200

hyphy (2.2.5+dfsg-1) unstable; urgency=low

  * Initial release (Closes: #792087)

 -- Andreas Tille <tille@debian.org>  Sat, 11 Jul 2015 06:57:36 +0200