File: changelog

package info (click to toggle)
ibus-m17n 1.4.3-1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye
  • size: 380 kB
  • sloc: ansic: 1,973; xml: 536; makefile: 229; sh: 18
file content (217 lines) | stat: -rw-r--r-- 6,313 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
ibus-m17n (1.4.3-1) unstable; urgency=medium

  * Team upload.
  * New upstream release 1.4.3. 
  * Use default libexecdir. (Closes: #955238)
    + Also add version limit for ibus.

 -- Boyuan Yang <byang@debian.org>  Tue, 30 Jun 2020 09:34:30 -0400

ibus-m17n (1.4.2-1) unstable; urgency=medium

  * Team upload.
  * New upstream release 1.4.2.
  * debian/control:
    + Bump Standards-Version to 4.5.0.
    + Bump debhelper compat to v12.
  * debian/upstream/metadata: Add Repository, Repository-Browse.

 -- Boyuan Yang <byang@debian.org>  Tue, 28 Jan 2020 12:38:27 -0500

ibus-m17n (1.4.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 1.4.1.
  * debian/rules: Enable -Wl,--as-needed.
  * debian/patches: Remove all obsolete patches.

 -- Boyuan Yang <byang@debian.org>  Sat, 27 Oct 2018 14:13:22 -0400

ibus-m17n (1.3.4-6) unstable; urgency=medium

  * Team upload.
  * Modernize packaging instructions.
    + Bump Standards-Version to 4.2.1.
    + Bump debhelper compat to v11.
    - Remove unnecessary autotools build dependencies in debian/control.
    + Update maintainer to Debian Input Method Team. (Closes: #899828)
    + Use "dh_missing --fail-missing" in debian/rules.
    + Slight update to debian/copyright file.

 -- Boyuan Yang <byang@debian.org>  Mon, 22 Oct 2018 13:51:44 -0400

ibus-m17n (1.3.4-5) unstable; urgency=medium

  * Fix watch and URLs.
  * Update uploaders.  Closes: #841797
  * Install manpage into the binary package.
  * Set hardening=+all.

 -- Osamu Aoki <osamu@debian.org>  Sun, 11 Dec 2016 01:05:14 +0900

ibus-m17n (1.3.4-4) unstable; urgency=medium

  * Team upload.
  * Build with dh-autoreconf.  Closes: #727265
  * Fix build with clang. Closes: #743129

 -- Osamu Aoki <osamu@debian.org>  Mon, 27 Oct 2014 00:04:33 +0900

ibus-m17n (1.3.4-3) unstable; urgency=low

  * Team upload.
  * Add patches from FC19:
    - ibus-m17n-fix-preedit-color.patch by Mike FABIAN.
    - ibus-m17n-hide-title-status.patch by Daiki Ueno.
  * Build with GTK+ 3.0.
  * ibus 1.5 transition.

 -- Osamu Aoki <osamu@debian.org>  Sun, 08 Sep 2013 23:36:24 +0900

ibus-m17n (1.3.4-2) unstable; urgency=low

  * Team upload.
  * Fix libexecdir. Closes: #712579

 -- Osamu Aoki <osamu@debian.org>  Wed, 19 Jun 2013 21:49:24 +0900

ibus-m17n (1.3.4-1) unstable; urgency=low

  * New upstream release.
  * Fix "uncommitted preedit text lost when switching IM" (Closes: #661212)
  * Temporarily Disable dh_auto_test
  * Bump standards version to 3.9.3

 -- Daiki Ueno <ueno@unixuser.org>  Wed, 09 May 2012 05:52:37 +0900

ibus-m17n (1.3.3-1) unstable; urgency=low

  * New upstream release.
  * Fix "new upstream version 1.3.3" (Closes: #639823)
  * Use dh in debian/rules
  * Set vcs to git.debian.org
  * set DM-Upload-Allowed to yes

 -- Asias He <asias.hejun@gmail.com>  Sat, 03 Sep 2011 23:43:18 +0800

ibus-m17n (1.3.2-1) unstable; urgency=low

  * New upstream release.

 -- LI Daobing <lidaobing@debian.org>  Wed, 09 Mar 2011 00:02:15 +0800

ibus-m17n (1.3.1-1) unstable; urgency=low

  [ Asias He ]
  * New upstream release.
  * debian/watch: use http://googlecode.debian.net

  [ LI Daobing ]
  * debian/control: build depends on libgtk2.0-dev

 -- LI Daobing <lidaobing@debian.org>  Sat, 04 Sep 2010 22:17:41 +0800

ibus-m17n (1.3.0-2) unstable; urgency=low

  [ Asias He ]
  * debian/control:
    - set maintainer to pkg-ime, add LI Daobing <lidaobing@debian.org>
      & Asias He <asias.hejun@gmail.com> to uploaders.
    - update Vcs-* fields.

  [ LI Daobing ]
  * debian/control:
    - bump standards version to 3.9.1.
  * debian/watch:
    - updated.
  * Fix "Does not provide any input methods" (Closes: #593315)
    - rebuild can fix this bug.

 -- LI Daobing <lidaobing@debian.org>  Tue, 17 Aug 2010 22:57:14 +0800

ibus-m17n (1.3.0-1) unstable; urgency=low

  * New upstream release.
  * debian/source/format: 3.0.

 -- LI Daobing <lidaobing@debian.org>  Sat, 03 Apr 2010 21:08:51 +0800

ibus-m17n (1.2.99.20100202-1) experimental; urgency=low

  * New upstream release.
  * debian/control: bump standards version to 3.8.4.
  * debian/control: switch to ibus 1.3.

 -- LI Daobing <lidaobing@debian.org>  Sun, 21 Mar 2010 19:08:48 +0800

ibus-m17n (1.2.0.20091217-1) unstable; urgency=low

  * New upstream release.

 -- LI Daobing <lidaobing@debian.org>  Thu, 17 Dec 2009 20:12:36 +0800

ibus-m17n (1.2.0.20091120-1) unstable; urgency=low

  * New upstream release.

 -- LI Daobing <lidaobing@debian.org>  Sun, 22 Nov 2009 12:36:08 +0800

ibus-m17n (1.2.0.20090930-1) unstable; urgency=low

  * new upstream release.
  * debian/control: bump standards version to 3.8.3.

 -- LI Daobing <lidaobing@debian.org>  Wed, 30 Sep 2009 23:15:39 +0800

ibus-m17n (1.2.0.20090617-1ubuntu1) karmic; urgency=low

  * debian/control: update Vcs-* fields.

 -- LI Daobing <lidaobing@debian.org>  Mon, 31 Aug 2009 20:44:21 +0800

ibus-m17n (1.2.0.20090617-1) unstable; urgency=low

  * new upstream release.
  * debian/control:
    - build-depends: libibus-dev >= 1.2
    - depends: ibus >= 1.2
    - bump standards version to 3.8.2

 -- LI Daobing <lidaobing@debian.org>  Sat, 20 Jun 2009 23:42:07 +0800

ibus-m17n (1.1.0.20090211-1) unstable; urgency=low

  * initial release to Debian (closes: 521631)
  * new upstream release.
    - no longer depends on python.
  * debian/control:
    - build depends on libibus-dev.
    - change maintainer's email.
    - bump standards version to 3.8.1.
    - remove swig, python-dev and python-support from build-depends.
  * debian/rules:
    - add "-Wl,--as-needed" to LDFLAGS.
    - remove dh_pysupport.

 -- LI Daobing <lidaobing@debian.org>  Thu, 23 Apr 2009 20:26:01 +0800

ibus-m17n (1.1.0.20090211-0ubuntu1) karmic; urgency=low

  * new upstream release (LP: #370212)
    - no longer depends on python.
  * debian/control:
    - build depends on libibus-dev.
    - change maintainer's email.
    - bump standards version to 3.8.1.
    - remove swig, python-dev and python-support from build-depends.
  * debian/rules:
    - add "-Wl,--as-needed" to LDFLAGS.
    - remove dh_pysupport.

 -- LI Daobing <lidaobing@debian.org>  Fri, 01 May 2009 14:27:55 +0800

ibus-m17n (0.1.1.20081013-0ubuntu1) jaunty; urgency=low

  * Initial release (LP: #312683)

 -- LI Daobing <lidaobing@gmail.com>  Wed, 31 Dec 2008 20:11:11 +0800