File: run-php5.3.php

package info (click to toggle)
icingaweb2-module-director 1.6.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye
  • size: 8,464 kB
  • sloc: php: 60,573; sql: 7,643; javascript: 585; sh: 365; xml: 37; makefile: 18
file content (26 lines) | stat: -rw-r--r-- 660 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
<?php

use Icinga\Application\Icinga;

use Icinga\Exception\IcingaException;
use Icinga\Web\Url;

if (Icinga::app()->isCli()) {
    throw new IcingaException(
        "PHP version 5.4.x is required for Director >= 1.4.0, you're running %s."
        . ' Please either upgrade PHP or downgrade Icinga Director',
        PHP_VERSION
    );
} else {
    $request = Icinga::app()->getRequest();
    $path = $request->getPathInfo();
    if (! preg_match('#^/director#', $path)) {
        return;
    }
    if (preg_match('#^/director/phperror/error#', $path)) {
        return;
    }

    header('Location: ' . Url::fromPath('director/phperror/error'));
    exit;
}