1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
|
MODULE := statusmap
DEBDIR := debian/icingaweb2-module-$(MODULE)
%:
dh ${@}
override_dh_auto_install:
mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/COPYING.md
rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/README.md
mkdir -p $(DEBDIR)/etc/icingaweb2/enabledModules
ln -s /usr/share/icingaweb2/modules/$(MODULE) $(DEBDIR)/etc/icingaweb2/enabledModules/$(MODULE)
|