1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
|
DH_OPTIONS=
DH=dh $(DH_OPTIONS)
ifneq ($(DEB_CCACHE_DIR),)
export PATH:=$(DEB_CCACHE_DIR):${PATH}
endif
build build-arch build-indep install binary-arch binary-indep binary: %:
dh $@ $(DH_OPTIONS)
override_dh_auto_configure:
autoreconf -vif
dh_auto_configure -- \
--enable-shared \
--with-yaz=/usr/bin \
--with-tclconfig=/usr/lib/tcl8.6
override_dh_auto_clean:
dh_auto_clean
$(RM) stamp-*
$(RM) test/gils/socket
clean:
dh clean $(DH_OPTIONS)
$(RM) doc/*.html doc/manref.xml doc/htmlhelp.hhp doc/toc.hhc \
doc/*.1 doc/*.8 doc/gils.txt doc/gils.ps \
test/gils/out test/zsh/test*.zsh.out \
doc/manref.xml
find . -name Makefile.in -exec $(RM) {} \;
$(RM) aclocal.m4 configure config/* m4/libtool.m4 \
config.guess config.sub m4/lt*.m4
$(RM) doc/local.ent doc/common/print.dsl idzebra.spec \
idzebra-config-2.0 Doxyfile win/version.nsi \
include/idzebra/version.h
-test -d .git && git checkout -- $$(git status | \
sed -e '/^#[[:space:]]*deleted:[[:space:]]*/s/^#[[:space:]]*deleted:[[:space:]]*//p;d' | \
grep -v '^debian/')
override_dh_install:
dh_install --sourcedir=debian/tmp
override_dh_makeshlibs:
dh_makeshlibs -a -V 'libidzebra-2.0-0 (>= 2.0.40)' -X mod-
override_dh_shlibdeps:
dh_shlibdeps -a -- --warnings=7
.PHONY: build clean binary-indep binary-arch binary install configure
|