1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181
|
debian_patches = automakehash autodicooption
IFRENCH_GUT=$(shell pwd)/debian/ifrench-gut
MYSPELL_FR_GUT=$(shell pwd)/debian/myspell-fr-gut
configure: configure-stamp
configure-stamp: patched-stamp
dh_testdir
touch configure-stamp
build: build-stamp
build-stamp: configure-stamp
dh_testdir
./makehash
is2my-spell.pl francais.aff > fr-pre.aff
LC_ALL=C sed -e 's/^SET.*/SET ISO8859-15/;s/^TRY.*/TRY aeiosinrtlcdugmphbyfvkw/' \
-e 's/^\([PS]FX[[:space:]]\+.[[:space:]]\+[^[:space:]]\+[[:space:]]\+[^[:space:]]\+[[:space:]]\+\)\([^[:space:]]\+\)$$/\1 \2/' \
fr-pre.aff > fr.aff
wc -l < francais.dico > francais.dico.cnt
cat francais.dico.cnt francais.dico > fr.dic
touch build-stamp
build-arch: build
build-indep: build
clean: reverse-patches
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
rm -f francais.hash francais-TeX8b.hash
rm -f francais.dico* francais.stat
rm -f fr-pre.aff fr.aff fr.dic
dh_clean
install-indep: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
install -m 0644 fr.aff $(MYSPELL_FR_GUT)/usr/share/hunspell
install -m 0644 fr.dic $(MYSPELL_FR_GUT)/usr/share/hunspell
ln -s /usr/share/hunspell/fr.aff $(MYSPELL_FR_GUT)/usr/share/myspell/dicts/fr.aff
ln -s /usr/share/hunspell/fr.dic $(MYSPELL_FR_GUT)/usr/share/myspell/dicts/fr.dic
for CC in FR BE LU CH; do for SUF in aff dic; do\
ln -s fr.$${SUF} $(MYSPELL_FR_GUT)/usr/share/hunspell/fr_$${CC}.$${SUF}; \
ln -s /usr/share/hunspell/fr.$${SUF} $(MYSPELL_FR_GUT)/usr/share/myspell/dicts/fr_$${CC}.$${SUF}; \
done; done
install-arch: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
install -m 0644 francais.aff $(IFRENCH_GUT)/usr/lib/ispell/french.aff
install -m 0644 francais.hash $(IFRENCH_GUT)/usr/lib/ispell/french.hash
install -m 0644 francais-TeX8b.aff $(IFRENCH_GUT)/usr/lib/ispell/french-TeX8b.aff
install -m 0644 francais-TeX8b.hash $(IFRENCH_GUT)/usr/lib/ispell/french-TeX8b.hash
dh_link usr/lib/ispell/french.aff usr/lib/ispell/francais.aff
dh_link usr/lib/ispell/french.hash usr/lib/ispell/francais.hash
dh_link usr/lib/ispell/french.aff usr/lib/ispell/frenchb.aff
dh_link usr/lib/ispell/french.hash usr/lib/ispell/frenchb.hash
dh_link usr/lib/ispell/french-TeX8b.aff usr/lib/ispell/francais-TeX8b.aff
dh_link usr/lib/ispell/french-TeX8b.hash usr/lib/ispell/francais-TeX8b.hash
binary-indep: build install-indep
dh_testdir
dh_testroot
dh_installdocs -i
dh_installchangelogs -i
dh_link -i
installdeb-myspell -p myspell-fr-gut
dh_compress -i
dh_fixperms -i
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
binary-arch: build install-arch
dh_testdir
dh_testroot
installdeb-ispell -p ifrench-gut
dh_installdocs -a
dh_installchangelogs -a
dh_strip -a
dh_compress -a
dh_fixperms -a
dh_installdeb -a
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a
dh_builddeb -a
binary: binary-indep binary-arch
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install configure
patch_dir = debian/patches
apply-patches: patched-stamp
reverse-patches:
@for stamp in none patched-*; do \
case "$$stamp" in none|patched-stamp|patched-\*) continue; esac; \
patch=`echo $$stamp | sed -e 's/patched-//'`; \
echo "trying to revert patch $$patch ..."; \
if [ -x $(patch_dir)/$$patch.dpatch ]; then true; else \
chmod +x $(patch_dir)/$$patch.dpatch; fi; \
if $(patch_dir)/$$patch.dpatch -unpatch; then \
echo "reverted $$patch patch."; \
rm -f $$stamp; \
else \
echo "error in reverting $$patch patch."; \
exit 1; \
fi; \
done
@echo "Removing patched-stamp"
@rm -f patched-stamp
patched-%: $(patch_dir)/%.dpatch
@if [ -x $< ]; then true; else chmod +x $<; fi
@if [ -f $@ ]; then \
echo "$* patches already applied."; exit 1; \
fi
$< -patch
@echo "$* patches applied." > $@
patched-stamp: $(foreach p,$(debian_patches),patched-$(p))
@printf "\nPatches applied:\n" >> pxxx
@for i in none $(debian_patches); do \
if [ -r debian/patches/$$i.dpatch ]; then \
printf "\n$$i:\n" >> pxxx; \
sed -n 's/^
fi \
done
@echo "Writing patched-stamp"
@mv -f pxxx patched-stamp
|