1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85
|
DEB_AUTO_UPDATE_LIBTOOL = pre
DEB_AUTO_UPDATE_AUTOCONF = 2.68
DEB_AUTO_UPDATE_ACLOCAL = 1.11
DEB_AUTO_UPDATE_AUTOMAKE = 1.11
DEB_AUTOMAKE_ARGS = --add-missing
include /usr/share/cdbs/1/class/autotools.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/rules/utils.mk
libpkgname = libijs-$(DEB_UPSTREAM_VERSION)
DEB_COPYRIGHT_CHECK_IGNORE_REGEX = ^(ijs_spec\.pdf|debian/(changelog|copyright(|_hints|_newhints)))$
DEB_CONFIGURE_EXTRA_FLAGS += --enable-shared --libdir=/usr/lib/$(DEB_HOST_MULTIARCH)
DEB_MAKE_BUILD_TARGET =
ifneq (,$(filter libijs-dev,$(shell dh_listpackages)))
DEB_MAKE_BUILD_TARGET += all
endif
ifneq (,$(filter libijs-doc,$(shell dh_listpackages)))
DEB_MAKE_BUILD_TARGET += doc
endif
DEB_DH_MAKESHLIBS_ARGS_$(libpkgname) = -V'$(libpkgname) (>= $(DEB_UPSTREAM_VERSION))'
upstreamtmpfiles = ltmain.sh configure aclocal.m4 Makefile.in ijs_spec.pdf
pre-build:: debian/stamp-upstreamtmpstuff
debian/stamp-upstreamtmpstuff: debian/stamp-copyright-check
for file in $(upstreamtmpfiles); do \
[ ! -e $$file ] || [ -e $$file.upstream ] || cp -a $$file $$file.upstream; \
done
touch $@
clean::
for file in $(upstreamtmpfiles); do \
[ ! -e $$file.upstream ] || mv -f $$file.upstream $$file; \
done
rm -f debian/stamp-upstreamtmpstuff
binary: fail-missing
fail-missing: binary-arch binary-indep list-missing
cat debian/cdbs-package-list | sort | uniq | \
grep -v 'DEBIAN' | \
grep -v '/usr/share/doc' | \
grep -v '/usr/share/lintian/overrides' | \
grep -v '/usr/share/menu' | \
grep -v '/usr/bin/.*_example' | \
> debian/cdbs-reduced-package-list
cat debian/cdbs-install-list | sort | uniq | \
> debian/cdbs-reduced-install-list
diff -u debian/cdbs-reduced-install-list \
debian/cdbs-reduced-package-list \
> debian/cdbs-install-diff \
|| true
@if [ "`wc -l debian/cdbs-install-diff`" != "0 debian/cdbs-install-diff" ]; then \
echo "ERROR: Differences between intermediary installed and packaged files:"; \
echo; \
cat debian/cdbs-install-diff; \
echo; \
echo "Individual binary packages may work, but whole package build failed!"; \
exit 1; \
fi
clean::
rm -f debian/cdbs-reduced-package-list debian/cdbs-reduced-install-list debian/cdbs-install-diff
|