File: control

package info (click to toggle)
imagemagick 8:6.9.10.23+dfsg-2.1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 62,332 kB
  • sloc: ansic: 344,643; cpp: 21,804; xml: 9,842; perl: 6,403; sh: 5,895; makefile: 3,020; tcl: 459
file content (750 lines) | stat: -rw-r--r-- 29,521 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
650
651
652
653
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
673
674
675
676
677
678
679
680
681
682
683
684
685
686
687
688
689
690
691
692
693
694
695
696
697
698
699
700
701
702
703
704
705
706
707
708
709
710
711
712
713
714
715
716
717
718
719
720
721
722
723
724
725
726
727
728
729
730
731
732
733
734
735
736
737
738
739
740
741
742
743
744
745
746
747
748
749
750
# Autogenerated Sun Jan  6 21:18:32 CET 2019 from make -f debian/rules update_pkg
Source: imagemagick
Section: graphics
Priority: optional
Maintainer: ImageMagick Packaging Team <pkg-gmagick-im-team@lists.alioth.debian.org>
Uploaders: Luciano Bello <luciano@debian.org>,
 Nelson A. de Oliveira <naoliv@debian.org>,
 Bastien Roucariès <rouca@debian.org>,
Standards-Version: 4.3.0
# for dbg-sym
Build-Depends: debhelper (>= 11),
# for improving build
 dh-exec,
# ABI dump
 g++ (>= 4:7),
# for linking compiling ...
 pkg-config, libltdl-dev,
# for libtool does not link to depends lib
 chrpath,
# for special function
 libfftw3-dev, liblcms2-dev, liblqr-1-0-dev,
# for fonts
 libfreetype6-dev, libfontconfig1-dev, gsfonts,
# for compression
 zlib1g-dev, liblzma-dev, libbz2-dev,
# for X
 libx11-dev, libxext-dev, libxt-dev,
# for plugins
 ghostscript, libdjvulibre-dev, libexif-dev,
 libjpeg-dev, libopenjp2-7-dev,
 libopenexr-dev, libperl-dev, libpng-dev, libtiff-dev,
 libwmf-dev, libheif-dev, libwebp-dev,
# libgraphviz-dev, incompatible license against fftw
# for converting svg
 libpango1.0-dev, librsvg2-bin, librsvg2-dev, libxml2-dev,
# for easy symbols of c++ lib
 pkg-kde-tools,
# for libgomp symbols
 dpkg-dev (>= 1.17.6)
# for documentation
Build-Depends-Indep: doxygen, doxygen-latex, graphviz,
		     libxml2-utils,
		     xsltproc,
		     jdupes
Vcs-Browser: https://salsa.debian.org/debian/imagemagick
Vcs-Git: https://salsa.debian.org/debian/imagemagick.git
Homepage: https://www.imagemagick.org/

# arch all package
# do not forget to add breaks if config file syntax change.
Package: imagemagick-6-common
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends}
Breaks: libmagickcore-6.q16-4 (<< 8:6.9.8.9+dfsg-1~),
	libmagickcore-6.q16hdri-4 (<< 8:6.9.8.9+dfsg-1~),
        libmagickcore-6.q16-3 (<< 8:6.9.6.8+dfsg-1~),
	libmagickcore-6.q16-2 (<< 8:6.9.6.2+dfsg-3~),
	imagemagick-common (<< 8:6.9.2.10+dfsg-1~)
Provides: imagemagick-common
# remove breaks/replaces after strech + 2 for imagemagick-common
# remove breaks/replace after strech + 2 for libmagickcore-6.q16 (<< 8:6.9.6.2+dfsg-3)
Replaces: imagemagick-common (<< 8:6.9.2.10+dfsg-1~),
 libmagickcore-6.q16 (<< 8:6.9.6.2+dfsg-3~)
Description: image manipulation programs -- infrastructure
 imagemagick-common contains the filesystem infrastructure required for
 further installation of imagemagick in any configuration; it does not provide
 a full installation of binaries, libraries, and utilities
 required to run imagemagick.
 .
 This package is independent of channel depth.

Package: imagemagick-6-doc
Architecture: all
Multi-Arch: foreign
Section: doc
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ${misc:Depends}, ${doxygen:Depends},
	 imagemagick-6-common
Recommends: www-browser,
	    libjs-jquery,
	    libjs-bootstrap (>=3.3.5+dfsg-1),
	    libjs-jquery-mousewheel,
	    libjs-jquery-fancybox,
Suggests: imagemagick
Provides: imagemagick-doc
# remove breaks/replaces after strech + 2
Replaces: imagemagick-doc (<< 8:6.9.2.10+dfsg-1~), imagemagick (<< 8:6.9.2.10+dfsg-1~)
Breaks: imagemagick-doc (<< 8:6.9.2.10+dfsg-1~)
Built-using: ${doxygen:Built-Using}
Description: document files of ImageMagick
 This package contains the document files shipped with ImageMagick, a software
 suite to create, edit, and compose bitmap images.
 .
 Documentations includes html manuals, examples files, and doxygen generated API
 documentation.

Package: libmagickcore-6-headers
Architecture: all
Multi-Arch: foreign
Section: libdevel
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ${misc:Depends}
Description: low-level image manipulation library - header files
 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package includes the architecture independent header files
 needed to compile programs using MagickCore.
 .
 This package is independent of channel depth.

Package: libmagickwand-6-headers
Architecture: all
Multi-Arch: foreign
Section: libdevel
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: libmagickcore-6-headers (= ${source:Version}),
 ${misc:Depends}
Description: image manipulation library - headers files
 The MagickWand API is the recommended interface between the C programming
 language and the ImageMagick image processing libraries. Unlike the
 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
 available to set or get important wand properties.
 .
 This package includes header files needed to compile
 programs using MagickWand.
 .
 This package is independent of channel depth.

Package: libmagick++-6-headers
Architecture: all
Multi-Arch: foreign
Section: libdevel
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: libmagickwand-6-headers (= ${source:Version}),
 libmagickcore-6-headers (= ${source:Version}),
 ${misc:Depends}
Description: object-oriented C++ interface to ImageMagick - header files
 The Magick++ library is a set of C++ wrapper classes that provides access
 to the ImageMagick package functionality from within a C++ application.
 .
 This package includes header files needed to compile
 programs using Magick++.
 .
 This package is independent of channel depth.


Package: libimage-magick-perl
Architecture: all
Multi-Arch: allowed
Section: perl
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ${perl:Depends}, ${shlibs:Depends}, ${misc:Depends},
	 libimage-magick-q16-perl
Provides: perlmagick
# remove breaks/replaces after jessie +2
Replaces: perlmagick (<< 8:6.8.3.10-1~)
Breaks: perlmagick (<< 8:6.8.3.10-1~)
Suggests: imagemagick-doc
Description: Perl interface to the ImageMagick graphics routines
 PerlMagick is an objected-oriented Perl interface to ImageMagick.
 Use the module to read, manipulate, or write an image or image sequence from
 within a Perl script. This makes it very suitable for Web CGI scripts.
 .
 This is the compatibility (wrapper) perlmagick package that
 use the default channel depth.
 .
 This package provides the perl Image::Magick class.

# quantum independent
Package: libmagickcore-6-arch-config
Architecture: any
Multi-Arch: same
Section: libdevel
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ${misc:Depends},
	 libmagickcore-6-headers (= ${source:Version}),
	 imagemagick-6-common (>= 8:6.9.6.2+dfsg-3)
Description: low-level image manipulation library - architecture header files
 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package includes the architecture dependent part of the
 headers files used by MagickCore.
 .
 This package is independent of channel depth.

# quantum dependant
Package: imagemagick-6.q16
Architecture: any
Multi-Arch: foreign
Depends: ${shlibs:Depends}, ${misc:Depends}, hicolor-icon-theme
Recommends: libmagickcore-6.q16-6-extra, ghostscript, netpbm
Suggests: imagemagick-doc, autotrace, cups-bsd | lpr | lprng, curl, enscript,
 ffmpeg, gimp, gnuplot, grads, graphviz, groff-base, hp2xx, html2ps,
 libwmf-bin, mplayer,
 povray, radiance, sane-utils, texlive-base-bin, transfig,
 ufraw-batch, xdg-utils
Replaces: imagemagick (<< 8:6.9.2.10+dfsg-2~)
Breaks: libmagickcore-dev (<< 8:6.9.2.10+dfsg-2~)
Provides: imagemagick, imagemagick-6.defaultquantum
Description: image manipulation programs -- quantum depth Q16
 ImageMagick is a software suite to create, edit, and compose bitmap images.
 It can read, convert and write images in a variety of formats (over 100)
 including DPX, EXR, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript,
 SVG, and TIFF. Use ImageMagick to translate, flip, mirror, rotate, scale,
 shear and transform images, adjust image colors, apply various special
 effects, or draw text, lines, polygons, ellipses and Bézier curves.
 All manipulations can be achieved through shell commands as well as through
 an X11 graphical interface (display).
 .
 For working with the SVG, WMF, OpenEXR, DjVu and Graphviz formats,
 you need to install the libmagickcore-6.q16-6-extra package.
 .
 This version of imagemagick is compiled for a channel
 depth of 16 bits (Q16).

# predepend on dpkg (>= 1.17.6) for libgomp symbols remove after jeesie +2
# normally depends on imagemagick-6-common >= ${source:version} except
# here when some files were moved between two packages
Package: libmagickcore-6.q16-6
Architecture: any
Multi-Arch: same
Section: libs
Pre-Depends: ${misc:Pre-Depends}, dpkg (>= 1.17.6)
Depends: ${shlibs:Depends}, ${misc:Depends},
 imagemagick-6-common (>= 8:6.9.6.2+dfsg-3)
Recommends: ghostscript, gsfonts
Suggests: libmagickcore-6.q16-6-extra
Description: low-level image manipulation library -- quantum depth Q16
 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package contains the C libraries needed to run executables that make
 use of MagickCore.
 .
 This version of libmagickcore is compiled for a channel
 depth of 16 bits (Q16).

Package: libmagickcore-6.q16-6-extra
Architecture: any
Multi-Arch: same
Section: libs
Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
Enhances: libmagickcore-6.q16-6
Provides: libmagickcore-extra, libmagickcore-6.q16-1-extra,
 libmagickcore-6.q16-2-extra,
 libmagickcore-6.q16-3-extra,
 libmagickcore-6.q16-4-extra,
 libmagickcore-6.q16-5-extra
Suggests: inkscape
Recommends: libjxr-tools
Description: low-level image manipulation library - extra codecs (Q16)
 This package adds support for SVG, WMF, OpenEXR, DjVu and Graphviz to
 MagickCore.
 .
 This version of libmagickcore-extra is compiled for a channel
 depth of 16 bits (Q16).

Package: libmagickcore-6.q16-dev
Architecture: any
Multi-Arch: same
Section: libdevel
Pre-Depends: dpkg (>= 1.17.11)
Depends:
 libmagickcore-6-arch-config (= ${binary:Version}),
 libmagickcore-6.q16-6 (= ${binary:Version}),
 libmagickcore-6.q16-6-extra (= ${binary:Version}),
 libbz2-dev, libdjvulibre-dev,
 libexif-dev, libfreetype6-dev, libjpeg-dev, libopenjp2-7-dev,
 liblcms2-dev, liblqr-1-0-dev, libltdl-dev, libopenexr-dev, libpng-dev,
 librsvg2-dev, libtiff-dev, libwmf-dev, libx11-dev, libxext-dev, libxml2-dev,
 libxt-dev, zlib1g-dev,
 pkg-config,
 ${misc:Depends}
# remove breaks/replaces after jessie +2
Replaces: libmagickcore-dev (<< 8:6.8.3.10-1~)
Breaks: libmagickcore-dev (<< 8:6.8.3.10-1~)
Provides: libmagickcore-6.defaultquantum-dev, libmagickcore-dev (=${binary:Version}),
Description: low-level image manipulation library - development files (Q16)
 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package includes header static libraries needed to compile
 programs using MagickCore.
 .
 This version of libmagickcore-dev is compiled for a channel
 depth of 16 bits (Q16).

# predepend on dpkg (>= 1.17.6)  for libgomp symbols remove after jeesie + 2
Package: libmagickwand-6.q16-6
Architecture: any
Multi-Arch: same
Section: libs
Pre-Depends: ${misc:Pre-Depends}, dpkg (>= 1.17.6)
Depends: ${shlibs:Depends}, ${misc:Depends},
	 imagemagick-6-common (>= 8:6.9.6.2+dfsg-3)
Description: image manipulation library -- quantum depth Q16
 The MagickWand API is the recommended interface between the C programming
 language and the ImageMagick image processing libraries. Unlike the
 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
 available to set or get important wand properties.
 .
 This package contains the C libraries needed to run executables that make
 use of MagickWand.
 .
 This version of libmagickwand is compiled for a channel
 depth of 16 bits (Q16).

Package: libmagickwand-6.q16-dev
Architecture: any
Multi-Arch: same
Section: libdevel
Pre-Depends: dpkg (>= 1.17.11)
Depends: libmagickwand-6-headers (= ${source:Version}),
 libmagickwand-6.q16-6 (= ${binary:Version}),
 libmagickcore-6.q16-6-extra (= ${binary:Version}),
 libmagickcore-6.q16-dev (= ${binary:Version}),
 pkg-config,
 ${misc:Depends}
Provides: libmagickwand-6.defaultquantum-dev, libmagickwand-dev (=${binary:Version}),
Replaces: libmagickwand-dev (<< 8:6.8.3.10-1~)
Breaks: libmagickwand-dev (<< 8:6.8.3.10-1~)
Description: image manipulation library - development files (Q16)
 The MagickWand API is the recommended interface between the C programming
 language and the ImageMagick image processing libraries. Unlike the
 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
 available to set or get important wand properties.
 .
 This package the static libraries needed to compile
 programs using MagickWand.
 .
 This version of libmagickwand-dev is compiled for a channel
 depth of 16 bits (Q16).

Package: libmagick++-6.q16-8
Architecture: any
Multi-Arch: same
Section: libs
Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: C++ interface to ImageMagick -- quantum depth Q16
 The Magick++ library is a set of C++ wrapper classes that provides access
 to the ImageMagick package functionality from within a C++ application.
 .
 This package contains the C++ libraries needed to run executables that make
 use of libMagick++.
 .
 This version of libmagick++ is compiled for a channel
 depth of 16 bits (Q16).

Package: libmagick++-6.q16-dev
Architecture: any
Multi-Arch: same
Section: libdevel
Pre-Depends: dpkg (>= 1.17.11)
Depends: libmagick++-6-headers (= ${source:Version}),
 libmagick++-6.q16-8 (= ${binary:Version}),
 libmagickcore-6.q16-dev (= ${binary:Version}),
 libmagickwand-6.q16-dev (= ${binary:Version}),
 pkg-config,
 ${misc:Depends}
Replaces: libmagick++-dev (<< 8:6.8.3.10-1~)
Breaks: libmagick++-dev (<< 8:6.8.3.10-1~)
Provides: libmagick++-6.defaultquantum-dev, libmagick++-dev (=${binary:Version})
Description: C++ interface to ImageMagick - development files (Q16)
 The Magick++ library is a set of C++ wrapper classes that provides access
 to the ImageMagick package functionality from within a C++ application.
 .
 This package includes header files and static libraries needed to compile
 programs using Magick++.
 .
 This version of libmagick++-dev is compiled for a channel
 depth of 16 bits (Q16).

Package: libimage-magick-q16-perl
Architecture: any
Multi-Arch: allowed
Section: perl
Pre-Depends: dpkg (>= 1.17.11)
Depends: ${perl:Depends}, ${shlibs:Depends}, ${misc:Depends}
Suggests: imagemagick-doc
Provides: libimage-magick-defaultquantum-perl, perlmagick (=${binary:Version})
# remove breaks/replaces after jessie +2
Replaces: perlmagick (<< 8:6.8.3.10-1~)
Breaks: perlmagick (<< 8:6.8.3.10-1~)
Description: Perl interface to the ImageMagick graphics routines -- Q16 version
 PerlMagick is an objected-oriented Perl interface to ImageMagick.
 Use the module to read, manipulate, or write an image or image sequence from
 within a Perl script. This makes it very suitable for Web CGI scripts.
 .
 This version of libimage-magick is compiled for a channel
 depth of 16 bits (Q16).
 .
 This package provides the perl Image::Magick::Q16 class.

# quantum dependant
Package: imagemagick-6.q16hdri
Architecture: any
Multi-Arch: foreign
Depends: ${shlibs:Depends}, ${misc:Depends}, hicolor-icon-theme
Recommends: libmagickcore-6.q16hdri-6-extra, ghostscript, netpbm
Suggests: imagemagick-doc, autotrace, cups-bsd | lpr | lprng, curl, enscript,
 ffmpeg, gimp, gnuplot, grads, graphviz, groff-base, hp2xx, html2ps,
 libwmf-bin, mplayer,
 povray, radiance, sane-utils, texlive-base-bin, transfig,
 ufraw-batch, xdg-utils
Replaces: imagemagick (<< 8:6.9.2.10+dfsg-2~)
Breaks: libmagickcore-dev (<< 8:6.9.2.10+dfsg-2~)
Description: image manipulation programs -- quantum depth Q16HDRI
 ImageMagick is a software suite to create, edit, and compose bitmap images.
 It can read, convert and write images in a variety of formats (over 100)
 including DPX, EXR, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript,
 SVG, and TIFF. Use ImageMagick to translate, flip, mirror, rotate, scale,
 shear and transform images, adjust image colors, apply various special
 effects, or draw text, lines, polygons, ellipses and Bézier curves.
 All manipulations can be achieved through shell commands as well as through
 an X11 graphical interface (display).
 .
 For working with the SVG, WMF, OpenEXR, DjVu and Graphviz formats,
 you need to install the libmagickcore-6.q16hdri-6-extra package.
 .
 This version of imagemagick is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

# predepend on dpkg (>= 1.17.6) for libgomp symbols remove after jeesie +2
# normally depends on imagemagick-6-common >= ${source:version} except
# here when some files were moved between two packages
Package: libmagickcore-6.q16hdri-6
Architecture: any
Multi-Arch: same
Section: libs
Pre-Depends: ${misc:Pre-Depends}, dpkg (>= 1.17.6)
Depends: ${shlibs:Depends}, ${misc:Depends},
 imagemagick-6-common (>= 8:6.9.6.2+dfsg-3)
Recommends: ghostscript, gsfonts
Suggests: libmagickcore-6.q16hdri-6-extra
Description: low-level image manipulation library -- quantum depth Q16HDRI
 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package contains the C libraries needed to run executables that make
 use of MagickCore.
 .
 This version of libmagickcore is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

Package: libmagickcore-6.q16hdri-6-extra
Architecture: any
Multi-Arch: same
Section: libs
Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
Enhances: libmagickcore-6.q16hdri-6
Provides: libmagickcore-extra, libmagickcore-6.q16hdri-1-extra,
 libmagickcore-6.q16hdri-2-extra,
 libmagickcore-6.q16hdri-3-extra,
 libmagickcore-6.q16hdri-4-extra,
 libmagickcore-6.q16hdri-5-extra
Suggests: inkscape
Recommends: libjxr-tools
Description: low-level image manipulation library - extra codecs (Q16HDRI)
 This package adds support for SVG, WMF, OpenEXR, DjVu and Graphviz to
 MagickCore.
 .
 This version of libmagickcore-extra is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

Package: libmagickcore-6.q16hdri-dev
Architecture: any
Multi-Arch: same
Section: libdevel
Pre-Depends: dpkg (>= 1.17.11)
Depends:
 libmagickcore-6-arch-config (= ${binary:Version}),
 libmagickcore-6.q16hdri-6 (= ${binary:Version}),
 libmagickcore-6.q16hdri-6-extra (= ${binary:Version}),
 libbz2-dev, libdjvulibre-dev,
 libexif-dev, libfreetype6-dev, libjpeg-dev, libopenjp2-7-dev,
 liblcms2-dev, liblqr-1-0-dev, libltdl-dev, libopenexr-dev, libpng-dev,
 librsvg2-dev, libtiff-dev, libwmf-dev, libx11-dev, libxext-dev, libxml2-dev,
 libxt-dev, zlib1g-dev,
 pkg-config,
 ${misc:Depends}
# remove breaks/replaces after jessie +2
Replaces: libmagickcore-dev (<< 8:6.8.3.10-1~)
Breaks: libmagickcore-dev (<< 8:6.8.3.10-1~)
Description: low-level image manipulation library - development files (Q16HDRI)
 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package includes header static libraries needed to compile
 programs using MagickCore.
 .
 This version of libmagickcore-dev is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

# predepend on dpkg (>= 1.17.6)  for libgomp symbols remove after jeesie + 2
Package: libmagickwand-6.q16hdri-6
Architecture: any
Multi-Arch: same
Section: libs
Pre-Depends: ${misc:Pre-Depends}, dpkg (>= 1.17.6)
Depends: ${shlibs:Depends}, ${misc:Depends},
	 imagemagick-6-common (>= 8:6.9.6.2+dfsg-3)
Description: image manipulation library -- quantum depth Q16HDRI
 The MagickWand API is the recommended interface between the C programming
 language and the ImageMagick image processing libraries. Unlike the
 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
 available to set or get important wand properties.
 .
 This package contains the C libraries needed to run executables that make
 use of MagickWand.
 .
 This version of libmagickwand is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

Package: libmagickwand-6.q16hdri-dev
Architecture: any
Multi-Arch: same
Section: libdevel
Pre-Depends: dpkg (>= 1.17.11)
Depends: libmagickwand-6-headers (= ${source:Version}),
 libmagickwand-6.q16hdri-6 (= ${binary:Version}),
 libmagickcore-6.q16hdri-6-extra (= ${binary:Version}),
 libmagickcore-6.q16hdri-dev (= ${binary:Version}),
 pkg-config,
 ${misc:Depends}
Replaces: libmagickwand-dev (<< 8:6.8.3.10-1~)
Breaks: libmagickwand-dev (<< 8:6.8.3.10-1~)
Description: image manipulation library - development files (Q16HDRI)
 The MagickWand API is the recommended interface between the C programming
 language and the ImageMagick image processing libraries. Unlike the
 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
 available to set or get important wand properties.
 .
 This package the static libraries needed to compile
 programs using MagickWand.
 .
 This version of libmagickwand-dev is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

Package: libmagick++-6.q16hdri-8
Architecture: any
Multi-Arch: same
Section: libs
Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: C++ interface to ImageMagick -- quantum depth Q16HDRI
 The Magick++ library is a set of C++ wrapper classes that provides access
 to the ImageMagick package functionality from within a C++ application.
 .
 This package contains the C++ libraries needed to run executables that make
 use of libMagick++.
 .
 This version of libmagick++ is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

Package: libmagick++-6.q16hdri-dev
Architecture: any
Multi-Arch: same
Section: libdevel
Pre-Depends: dpkg (>= 1.17.11)
Depends: libmagick++-6-headers (= ${source:Version}),
 libmagick++-6.q16hdri-8 (= ${binary:Version}),
 libmagickcore-6.q16hdri-dev (= ${binary:Version}),
 libmagickwand-6.q16hdri-dev (= ${binary:Version}),
 pkg-config,
 ${misc:Depends}
Replaces: libmagick++-dev (<< 8:6.8.3.10-1~)
Breaks: libmagick++-dev (<< 8:6.8.3.10-1~)
Description: C++ interface to ImageMagick - development files (Q16HDRI)
 The Magick++ library is a set of C++ wrapper classes that provides access
 to the ImageMagick package functionality from within a C++ application.
 .
 This package includes header files and static libraries needed to compile
 programs using Magick++.
 .
 This version of libmagick++-dev is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

Package: libimage-magick-q16hdri-perl
Architecture: any
Multi-Arch: allowed
Section: perl
Pre-Depends: dpkg (>= 1.17.11)
Depends: ${perl:Depends}, ${shlibs:Depends}, ${misc:Depends}
Suggests: imagemagick-doc
# remove breaks/replaces after jessie +2
Replaces: perlmagick (<< 8:6.8.3.10-1~)
Breaks: perlmagick (<< 8:6.8.3.10-1~)
Description: Perl interface to the ImageMagick graphics routines -- Q16HDRI version
 PerlMagick is an objected-oriented Perl interface to ImageMagick.
 Use the module to read, manipulate, or write an image or image sequence from
 within a Perl script. This makes it very suitable for Web CGI scripts.
 .
 This version of libimage-magick is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).
 .
 This package provides the perl Image::Magick::Q16HDRI class.

# predepend on dpkg (>= 1.17.5) for dir to symlink remove after jeesie +2
# compatibility package (remove after stretch + 2)
Package: imagemagick-common
Architecture: all
Multi-Arch: foreign
Section: oldlibs
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ${misc:Depends},  imagemagick-6-common
Description: image manipulation programs -- infrastructure dummy package
 imagemagick-common contained the filesystem infrastructure required for
 further installation of imagemagick in any configuration.
 .
 This is a transitional package to help migrate systems to the new
 imagemagick-6-common package.
 .
 This is a dummy package.  You can safely purge or remove it.


# predepend on dpkg (>= 1.17.5) for dir to symlink remove after jeesie +2
# conflict/replace itself (<< 8:6.9.2.10+dfsg-1~) in order to smooth link issue remove after strech + 2
# remove after strech+2
Package: imagemagick-doc
Architecture: all
Multi-Arch: foreign
Section: oldlibs
Depends: ${misc:Depends},
	 imagemagick-6-doc (>> 8:6.9.2.10+dfsg-1), imagemagick-6-common
Pre-Depends: dpkg (>= 1.17.5)
Conflicts: imagemagick (<= 7:6.4.0)
Replaces: imagemagick-doc (<< 8:6.9.2.10+dfsg-1~)
Description: document files of ImageMagick -- dummy package
 This package contained the document files shipped with ImageMagick, a software
 suite to create, edit, and compose bitmap images.
 .
 This is a transitional package to help migrate systems to the new
 imagemagick-6-doc package.
 .
 This is a dummy package.  You can safely purge or remove it.

# compatibility package (remove after jessie+2)
Package: perlmagick
Architecture: all
Multi-Arch: foreign
Section: oldlibs
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ${misc:Depends}, libimage-magick-perl, imagemagick-6-common
Description: Perl interface to ImageMagick -- dummy package
 PerlMagick is an objected-oriented Perl interface to ImageMagick.
 Use the module to read, manipulate, or write an image or image sequence from
 within a Perl script. This makes it very suitable for Web CGI scripts.
 .
 This is a transitional package to help migrate systems to the new
 libimage-magick-perl perl library.
 .
 This is a dummy package.  You can safely purge or remove it.

# compatibility package (remove after jessie+2)
Package: libmagickcore-dev
Architecture: all
Section: oldlibs
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ${misc:Depends},
 libmagickcore-6.q16-dev,
 imagemagick-6-common
Description: low-level image manipulation library -- dummy package
 This package included header files and static libraries needed to compile
 programs using MagickCore.
 .
 This is a transitional package to help migrate systems to the new
 ABI of libmagickcore-6 development files for default channel depth.
 .
 This is a dummy package.  You can safely purge or remove it.

# compatibility package (remove after jessie+2)
Package: libmagickwand-dev
Architecture: all
Section: oldlibs
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ${misc:Depends},
 libmagickwand-6.q16-dev,
 imagemagick-6-common
Description: image manipulation library -- dummy package
 This package included the static libraries needed to compile
 programs using MagickWand.
 .
 This is a transitional package to help migrate systems to the new
 ABI of libmagickwand-6 development files for default channel depth.
 .
 This is a dummy package.  You can safely purge or remove it.

# compatibility package (remove after jessie+2)
Package: libmagick++-dev
Architecture: all
Section: oldlibs
Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ${misc:Depends},
 libmagick++-6.q16-dev,
 imagemagick-6-common
Description: object-oriented C++ interface to ImageMagick -- dummy package
 The Magick++ library was a set of C++ wrapper classes that provides access
 to the ImageMagick package functionality from within a C++ application.
 .
 This is a transitional package to help migrate systems to the new
 ABI of libmagick++-6 development files for default channel depth.
 .
 This is a dummy package.  You can safely purge or remove it.

# compatibility package (remove after jessie+2)
# due to bug #813455 arch:any
Package: imagemagick
Architecture: any
Multi-Arch: foreign
Section: oldlibs
Depends: ${misc:Depends},
 imagemagick-6.q16 (>= 8:6.9.2.10+dfsg-2~)
Description: image manipulation programs -- binaries
 ImageMagick is a software suite to create, edit, and compose bitmap images.
 It can read, convert and write images in a variety of formats (over 100)
 including DPX, EXR, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript,
 SVG, and TIFF. Use ImageMagick to translate, flip, mirror, rotate, scale,
 shear and transform images, adjust image colors, apply various special
 effects, or draw text, lines, polygons, ellipses and Bézier curves.
 All manipulations can be achieved through shell commands as well as through
 an X11 graphical interface (display).
 .
 This package include links to channel depth specific binaries and manual
 pages.
 .
 This is a dummy package.  You can safely purge or remove it.