File: changelog

package info (click to toggle)
imv 4.2.0-1
  • links: PTS, VCS
  • area: main
  • in suites:
  • size: 604 kB
  • sloc: ansic: 6,324; makefile: 8; sh: 5
file content (87 lines) | stat: -rw-r--r-- 3,884 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
imv (4.2.0-1) unstable; urgency=medium

  * New upstream version 4.2.0.
  * Use the upstream installer and handle the imv name clash in d/rules.
    Install `imv` in /usr/lib/imv/ and patch imv.desktop accordingly.
    Stop installing the `imvr` legacy symlink.
  * d/NEWS: warn that the `imvr` legacy symlink is not installed anymore.
  * d/control:
    - Update Build-Depends:
      + replace asciidoc with asciidoc-base
      + drop dh-exec, docbook-xsl, xsltproc: not needed anymore
      + drop libfontconfig1-dev: already a dependency via libpango1.0-dev
      + add libheif-dev for HEIF support
      + add libturbojpeg0-dev for SIMD-accellerated JPEG handling
      + add meson, as upstream switched to this build system.
    - Update the package description.
    - Use @alioth-lists.debian.net in the team mailing list address.
  * d/patches:
    - drop 0001-Build-against-the-Debian-packaged-libinih.patch.
      Build with system inih is now supported upstream.
    - d/patches: add debian/patches/0003-fix-flickering-in-wayland.patch.
      Fixes https://github.com/eXeC64/imv/issues/305.
  * d/imv.docs: install upstream's README.md. Contains useful examples.
  * d/copyright:
    - Drop paragraph for libinih, not vendored anymore.
    - Update copyright holders.
    - Update copyright years for debian/*.
  * d/gbp.conf: set debian-branch = debian/latest (DEP14).
  * debian/*: pl@ninthfloor.org -> paride@debian.org.

 -- Paride Legovini <paride@debian.org>  Sun, 31 Jan 2021 12:03:12 +0000

imv (4.1.0-1) unstable; urgency=medium

  * New upstream version 4.1.0 (closes: #959095).
  * Install the /etc/imv_config file.
  * d/control:
    - Bump Standards-Version to 4.5.0 (no changes needed).
    - Bump the dh compat level to 13.
    - Do not disable dh_auto_test: the tests now pass in a schroot
      environment (sbuild), let's try enabling them.
    - Drop `make doc` from override_dh_auto_install: not needed as the `all`
      target already builds `doc`.
    - Use the paride@debian.org alias in Uploaders.
  * Drop upstreamed patches:
    - 0002-Fix-typo-in-manpages.patch
    - 0003-Fix-the-name-of-the-GNU-LGPL.patch
  * Switch to a "patches applied + git debcherry" packaging workflow.

 -- Paride Legovini <paride@debian.org>  Sun, 17 May 2020 22:22:50 +0000

imv (4.0.1-1) unstable; urgency=medium

  * New upstream version 4.0.1 (closes: #905693).
  * Upstream switched from dual licensing (Expat and GPL-2+) to Expat only.
    Update d/copyright accordingly.
  * d/copyright: add the new contributors.
  * Bump Standards-Version to 4.4.1 (no changes needed).
  * Build-Depend on debhelper-compat and drop d/compat.
  * d/rules: drop DEB_BUILD_MAINT_OPTIONS = hardening=+all.
    ld --as-needed is enabled by default on Debian development versions.
  * Update Build-Depends due to upstream changes:
     - add: libegl1-mesa-dev, libglu1-mesa-dev, librsvg2-dev,
            libwayland-dev, libxkbcommon-x11-dev;
     - del: libsdl2-dev, libsdl2-ttf-dev.
  * Skip the install target and install everything with debhelper.
    New Build-Depend: dh-exec.
  * d/control: add Rules-Requires-Root: no
  * Explain the new way to invoke imv. Changes:
     - update d/README.Debian;
     - update the package description in d/control; and
     - add d/NEWS explaining how the binaries are named.
  * Provide a imvr -> imv-x11 symlink for legacy support.
  * Refresh and add new patches. Refreshed:
     - 0001-Build-against-the-Debian-packaged-libinih.patch
    New:
     - 0002-Fix-typo-in-manpages.patch (cherry-picked)
     - 0003-Fix-the-name-of-the-GNU-LGPL.patch (submitted upstream)
     - 0004-desktop-file-call-imv-x11.patch

 -- Paride Legovini <pl@ninthfloor.org>  Sat, 30 Nov 2019 18:46:48 +0000

imv (3.0.0-1) unstable; urgency=medium

  * Initial release (Closes: #898220)

 -- Paride Legovini <pl@ninthfloor.org>  Mon, 07 May 2018 15:41:49 +0000