1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
ifeq ($(DEB_HOST_ARCH),i386)
export DEB_CFLAGS_MAINT_APPEND = -msse2
endif
include /usr/share/dpkg/default.mk
pkgdata:=infernal
sampledir:=$(CURDIR)/debian/$(DEB_SOURCE)/usr/share/doc/$(DEB_SOURCE)/examples
sampledir_lib:=$(CURDIR)/debian/$(DEB_SOURCE)/usr/lib/$(DEB_TARGET_MULTIARCH)/$(DEB_SOURCE)/examples
export DATE=$(shell date --date=@$(SOURCE_DATE_EPOCH) '+%d %B %Y')
%:
dh $@
override_dh_auto_clean:
if [ -r Makefile ]; then $(MAKE) distclean; fi
-cd documentation/userguide && if [ -r Makefile ]; then make distclean; fi
-cd easel/documentation && if [ -r Makefile ]; then make distclean; fi
dh_clean *.1 */*.log *.log */Makefile Makefile documentation/manpages/*.1
rm -f testsuite/i49.tbl
override_dh_compress:
dh_compress -X.pdf
override_dh_auto_configure-arch:
dh_auto_configure -a
override_dh_auto_build-arch:
dh_auto_build -a -- V=1
override_dh_auto_build-indep_see_debian_README.source:
cd documentation/userguide ; \
sed -e 's/@INFERNAL_VERSION@/$(DEB_VERSION_UPSTREAM)/' -e 's/@INFERNAL_DATE@/$(DATE)/' titlepage.tex.in > titlepage.tex ; \
echo " LATEX Userguide.pdf (see latex.log for output)" ; \
echo "%% This chapter automatically generated. Do not edit." > manpages.tex ; \
echo "\section{Manual pages}" >> manpages.tex ; \
for file in ../manpages/*.man ; do\
rman -f LaTeX2e $$file 2>/dev/null | /usr/share/doc/hmmer/examples/easel/devkit/rmanprocess.pl >> manpages.tex ;\
done ; \
pdflatex main > latex.log 2>&1 ; \
bibtex main >> latex.log 2>&1 ; \
pdflatex main >> latex.log 2>&1 ; \
pdflatex main >> latex.log 2>&1 ; \
mv main.pdf Userguide.pdf
override_dh_auto_install-arch:
$(MAKE) install -j$(shell nproc) AM_UPDATE_INFO_DIR=no V=1 prefix=$(CURDIR)/debian/tmp
override_dh_auto_configure-indep:
override_dh_auto_build-indep:
override_dh_auto_install-indep:
echo "Nothing to do for architecture all binary packages"
override_dh_install-arch:
dh_install -a
for bin in `ls $(CURDIR)/debian/infernal/usr/lib/infernal` ; do \
if [ $$bin != cmalign ] ; then \
ln -s cmalign $(CURDIR)/debian/infernal/usr/bin/$$bin ; \
fi ; \
done
override_dh_installexamples-arch:
dh_installexamples -a
mkdir -p $(sampledir)
mkdir -p $(sampledir_lib)/src/
mkdir -p $(sampledir_lib)/easel/miniapps/
find ./src -name "*test" -exec cp \{\} $(sampledir_lib)/src/ \;
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
cp ./src/itest_brute $(sampledir_lib)/src/
endif
cp ./easel/miniapps/esl-reformat $(sampledir_lib)/easel/miniapps/
cp ./easel/miniapps/esl-shuffle $(sampledir_lib)/easel/miniapps/
cp ./easel/miniapps/esl-sfetch $(sampledir_lib)/easel/miniapps/
cd $(sampledir) && ln -s ../../../../lib/$(DEB_TARGET_MULTIARCH)/$(DEB_SOURCE)/examples/easel ./easel \
&& ln -s ../../../../lib/$(DEB_TARGET_MULTIARCH)/$(DEB_SOURCE)/examples/src ./src
cp -aR testsuite $(sampledir)/
rm -f $(sampledir)/testsuite/*.tbl
cp ./easel/devkit/sqc $(sampledir)/
|