1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
BINDIR = games
DATADIR = share/games/instead
CMAKE_FLAGS = -DWITH_HARFBUZZ=1
ifeq ($(findstring $(DEB_TARGET_ARCH), amd64 arm64 armel armhf i386 mips64el mipsel s390x powerpc riscv64 loong64),)
CMAKE_FLAGS += -DWITH_LUAJIT=0
endif
CMAKE_CACHE_FLAGS = -DBINDIR=$(BINDIR) -DDATADIR=$(DATADIR)
%:
dh $@ --buildsystem=cmake
override_dh_auto_configure:
dh_auto_configure -- $(CMAKE_FLAGS) $(CMAKE_CACHE_FLAGS)
override_dh_compress:
dh_compress --exclude=.pdf --exclude=.lua
|