1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41
|
PYTHON3S:=$(shell py3versions -vr)
%:
dh $@ --with python3
override_dh_auto_build:
set -e && for pyvers in $(PYTHON3S); do \
python$$pyvers setup.py build; \
done
override_dh_auto_install:
set -e && for pyvers in $(PYTHON3S); do \
python$$pyvers setup.py install --install-layout=deb \
--root $(CURDIR)/debian/python3-ipy; \
done
override_dh_auto_clean:
dh_auto_clean
rm -rf $(CURDIR)/build
IPy.html:
rst2html README.rst IPy.html
binary: binary-indep
binary-arch:
binary-indep: $(PYTHON3S:%=test/test-%-stamp) IPy.html
dh $@ --with python3
test/test-%-stamp:
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
python$* test/test_IPy.py
touch $@
endif
.PHONY: install get-orig-source binary binary-arch binary-indep
|