File: driver-requirements.txt

package info (click to toggle)
ironic 1:12.1.0-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye
  • size: 13,828 kB
  • sloc: python: 114,449; sh: 2,628; pascal: 639; xml: 379; makefile: 69
file content (25 lines) | stat: -rw-r--r-- 755 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
# This file lists all python libraries which are utilized by drivers,
# but not listed in global-requirements.
# It is intended to help package maintainers to discover additional
# python projects they should package as optional dependencies for Ironic.

# These are available on pypi
proliantutils>=2.7.0
pysnmp>=4.3.0,<5.0.0
python-ironic-inspector-client>=1.5.0
python-scciclient>=0.8.0
UcsSdk==0.8.2.2;python_version<'3'
python-dracclient>=1.5.0
python-xclarityclient>=0.1.6

# The CIMC drivers use the Cisco IMC SDK version 0.7.2 or greater
ImcSdk>=0.7.2

# The Redfish hardware type uses the Sushy library
sushy>=1.6.0

# Ansible-deploy interface
ansible>=2.4

# HUAWEI iBMC hardware type uses the python-ibmcclient library
python-ibmcclient>=0.1.0