File: test-requirements.txt

package info (click to toggle)
ironic 1:12.1.0-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 13,828 kB
  • sloc: python: 114,449; sh: 2,628; pascal: 639; xml: 379; makefile: 69
file content (21 lines) | stat: -rw-r--r-- 719 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=1.0.0,<1.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
mock>=2.0.0 # BSD
Babel!=2.4.0,>=2.3.4 # BSD
PyMySQL>=0.7.6 # MIT License
iso8601>=0.1.11 # MIT
oslotest>=3.2.0 # Apache-2.0
stestr>=1.0.0 # Apache-2.0
psycopg2>=2.7.3 # LGPL/ZPL
testtools>=2.2.0 # MIT
testresources>=2.0.0 # Apache-2.0/BSD
testscenarios>=0.4 # Apache-2.0/BSD
WebTest>=2.0.27 # MIT
bashate>=0.5.1 # Apache-2.0
flake8-import-order>=0.13 # LGPLv3
Pygments>=2.2.0 # BSD