1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297
|
From: Robert Luberda <robert@debian.org>
Date: Mon, 7 Mar 2011 21:04:36 +0100
Subject: 0020 Mark Rcs_Id as unused
Fix `'Rcs_Id' defined but not used' warnings given by gcc -Wall.
Do the same for VersionID variable.
buildhash.c | 2 +-
correct.c | 2 +-
defmt.c | 2 +-
deformatters/defmt-c.c | 2 +-
deformatters/defmt-sh.c | 2 +-
dump.c | 2 +-
exp_table.c | 2 +-
fields.c | 2 +-
good.c | 2 +-
hash.c | 2 +-
icombine.c | 2 +-
ijoin.c | 2 +-
ispell.c | 2 +-
lookup.c | 2 +-
makedent.c | 2 +-
parse.y | 2 +-
sq.c | 2 +-
term.c | 2 +-
tgood.c | 2 +-
tree.c | 2 +-
unsq.c | 2 +-
version.h | 4 ++--
xgets.c | 2 +-
23 files changed, 24 insertions(+), 24 deletions(-)
diff --git a/buildhash.c b/buildhash.c
index b3e9be3..d060dcc 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: buildhash.c,v 1.77 2023-10-30 13:29:43-07 geoff Exp $";
#endif
diff --git a/correct.c b/correct.c
index deb679c..e719228 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: correct.c,v 1.87 2021-01-09 13:12:35-08 geoff Exp $";
#endif
diff --git a/defmt.c b/defmt.c
index d1b9d07..bd7990f 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: defmt.c,v 1.65 2020-12-30 22:33:41-08 geoff Exp $";
#endif
diff --git a/deformatters/defmt-c.c b/deformatters/defmt-c.c
index 8c5192b..70119ca 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: deformat-c.c,v 1.3 2001/07/25 21:51:48 geoff Exp geoff $";
#endif
diff --git a/deformatters/defmt-sh.c b/deformatters/defmt-sh.c
index 27d46fc..713fec6 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: deformat-sh.c,v 1.4 2001/07/25 21:51:48 geoff Exp geoff $";
#endif
diff --git a/dump.c b/dump.c
index dc11b6b..0478cfe 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: dump.c,v 1.19 2005/04/14 14:38:23 geoff Exp $";
#endif
diff --git a/exp_table.c b/exp_table.c
index 941a9ee..35addb5 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: exp_table.c,v 1.4 2005/06/11 22:43:53 geoff Exp $";
#endif
diff --git a/fields.c b/fields.c
index b6e479e..3c03e9a 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: fields.c,v 1.13 2021-06-02 16:52:07-07 geoff Exp $";
#endif
diff --git a/good.c b/good.c
index 466e2ff..d9179f4 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: good.c,v 1.51 2005/04/14 14:38:23 geoff Exp $";
#endif
diff --git a/hash.c b/hash.c
index 0f7f1e4..d2ad1cb 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: hash.c,v 1.25 2005/04/14 14:38:23 geoff Exp $";
#endif
diff --git a/icombine.c b/icombine.c
index 57efbd3..7ec699b 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: icombine.c,v 2.33 2005/04/20 23:16:32 geoff Exp $";
#endif
diff --git a/ijoin.c b/ijoin.c
index f8d8a02..56b97cf 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: ijoin.c,v 1.13 2021-06-02 16:52:07-07 geoff Exp $";
#endif
diff --git a/ispell.c b/ispell.c
index 49ead07..9eb1fe4 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: ispell.c,v 1.163 2022-02-06 00:55:29-08 geoff Exp $";
#endif
diff --git a/lookup.c b/lookup.c
index b1984cb..5089157 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: lookup.c,v 1.55 2022-02-05 23:23:17-08 geoff Exp $";
#endif
diff --git a/makedent.c b/makedent.c
index 3df9253..fb7a9e0 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: makedent.c,v 1.62 2021-01-09 13:12:35-08 geoff Exp $";
#endif
diff --git a/parse.y b/parse.y
index 8c35fae..7396e86 100644
@@ -1,6 +1,6 @@
%{
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: parse.y,v 1.67 2021-01-09 13:12:35-08 geoff Exp $";
#endif
diff --git a/sq.c b/sq.c
index c931421..9b19e1f 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: sq.c,v 1.16 2005/04/14 14:38:23 geoff Exp $";
#endif
diff --git a/term.c b/term.c
index 24bebcc..799dc0b 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: term.c,v 1.57 2020-12-30 22:33:41-08 geoff Exp $";
#endif
diff --git a/tgood.c b/tgood.c
index 5a71cb8..3cc753f 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: tgood.c,v 1.43 2005/04/14 14:38:23 geoff Exp $";
#endif
diff --git a/tree.c b/tree.c
index 073a6a6..f143787 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: tree.c,v 1.66 2005/04/14 14:43:46 geoff Exp $";
#endif
diff --git a/unsq.c b/unsq.c
index 125f654..d698841 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: unsq.c,v 1.18 2005/04/14 14:38:23 geoff Exp $";
#endif
diff --git a/version.h b/version.h
index e81d7d9..16a4622 100644
@@ -9,7 +9,7 @@
* incorrect translation.
*/
-static char * Version_ID[] = {
+static char * Version_ID[] __attribute__ ((unused)) = {
"@(#) International Ispell Version 3.4.06 30 Oct 2023",
"@(#) Copyright (c), 1983, by Pace Willisson",
"@(#) International version Copyright (c) 1987, 1988, 1990-1995, 1999,",
@@ -62,7 +62,7 @@ static char * Version_ID[] = {
NULL
};
-static char RCS_Version_ID[] =
+static char RCS_Version_ID[] __attribute__ ((unused)) =
"$Id: version.h,v 1.68 2023-10-30 13:31:08-07 geoff Exp $";
#endif /* VERSION_H_INCLUDED */
diff --git a/xgets.c b/xgets.c
index 44a7d51..293ec07 100644
@@ -1,5 +1,5 @@
#ifndef lint
-static char Rcs_Id[] =
+static char Rcs_Id[] __attribute__ ((unused)) =
"$Id: xgets.c,v 1.28 2005/04/14 14:38:23 geoff Exp $";
#endif
|