File: faq.html

package info (click to toggle)
jas 2.5.4408-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, jessie, jessie-kfreebsd, sid, stretch
  • size: 10,976 kB
  • ctags: 15,216
  • sloc: java: 111,905; python: 11,461; ruby: 9,204; makefile: 401; xml: 240; sh: 194
file content (98 lines) | stat: -rw-r--r-- 3,211 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>Frequently asked questions</title>
    <link rel="stylesheet" type="text/css" href="html.css" />
  </head>

  <body>
    <h1>Frequently asked questions</h1>

<p>In this page we give answers to frequently asked questions about JAS.
</p>

<ol>
<li><a href="#no001">When using the bytecode from *-bin.jar, I get "Bad version number in .class"</a>
</li>
<li><a href="#no002">When trying to compile JAS with "ant compile", I get NoClassDefFoundError: org/apache/tools/ant/launch/Launcher</a>
</li>
<li><a href="#no003">When compiling a sample code I get '(' or '[' expected errors</a>
</li>
<li><a href="#no004">After compiling a sample code I get NoClassDefFoundError: org/apache/log4j/Logger</a>
</li>
<li><a href="#no005">I can not use Apache log4j in my project for some reason.</a>
</li>

<!--
<li><a href="#no002"></a>
</li>
-->
</ol>


<h4><a name="no001">When using the bytecode from *-bin.jar I get "Bad version number in .class"</a></h4>
<p>
This error occurs if your Java virtual maschine is older than the 
Java used in compiling the classes. Use the JAS source to compile 
the .class files with your version of the Java VM.
See e.g. <a href="download.html#eclipse" target="main">Eclipse</a>.
</p>

<h4><a name="no002">When trying to compile JAS with "ant compile", I get NoClassDefFoundError: org/apache/tools/ant/launch/Launcher</a></h4>
<p>
Ant uses a wrong Java version. 
Define the Java home directory in the environment. 
E.g. in Linux use <br />
<code>export JAVA_HOME=/usr/java/jdk1.6.0_02</code>
<br />
or the directory of your installed Java version.
</p>

<h4><a name="no004">When compiling a sample code I get '(' or '[' expected errors</a></h4>
<p>
JAS uses the new generic type parameters, which where introduced 
in Java version 5.
So you must use at least a Java Development Kit 5 or later.
See <a href="http://java.sun.com/" target="sun">Java.sun.com</a> 
for the latest Java releases.
</p>

<h4><a name="no004">After compiling a sample code I get NoClassDefFoundError: org/apache/log4j/Logger</a></h4>
<p>
You must include the Log4j classes in the classpath. e.g.
<br />
<code>java -cp log4j.jar:. mysample</code>
</p>

<h4><a name="no005">I can not use Apache log4j in my project for some reason.</a></h4>
<p>
We provide an adapter package for Java logging with <a href="mylog.jar">mylog.jar</a>. 
The package contians classes which delegate all logging calls to <code>java.util.logging</code> 
classes. Java logging must be configured to your needs - we do not provide sample configurations.
You use it inplace of <code>log4j.jar</code>, for example  
<br />
<code>java -cp mylog.jar:. mysample</code>
</p>

<!--
<h4><a name="no002"></a></h4>

<p>
</p>
-->
    <hr />
    <address><a href="mailto:kredel at rz.uni-mannheim.de">Heinz Kredel</a></address>
<p>
<!-- Created: Sun Nov 11 15:56:30 CET 2007 -->
<!-- hhmts start -->
Last modified: Thu Jan 29 22:23:30 CET 2009
<!-- hhmts end -->
</p>
<!--
<p>$Id: faq.html 2379 2009-01-29 21:23:54Z kredel $
</p>
-->
  </body>
</html>