1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135
|
Source: jaxb
Section: java
Priority: optional
Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Uploaders: Timo Aaltonen <tjaalton@debian.org>
Build-Depends:
debhelper (>= 11),
default-jdk,
javahelper (>= 0.43),
libargs4j-java,
libbuild-helper-maven-plugin-java,
libdtd-parser-java,
libfastinfoset-java,
libistack-commons-java,
libjaxb-api-java (>= 2.3.1),
libmaven-dependency-plugin-java,
libmaven-javadoc-plugin-java,
librelaxng-datatype-java,
libxml-commons-resolver1.1-java,
maven-debian-helper (>= 2.2)
Standards-Version: 4.2.1
Vcs-Git: https://salsa.debian.org/java-team/jaxb.git
Vcs-Browser: https://salsa.debian.org/java-team/jaxb
Homepage: https://javaee.github.io/jaxb-v2/
Package: libjaxb-java
Architecture: all
Depends:
libcodemodel-java (>= 2.6+jaxb${source:Version}),
librngom-java (>= ${source:Version}),
libtxw2-java (>= ${source:Version}),
libxml-commons-resolver1.1-java,
${maven:Depends},
${misc:Depends}
Suggests: ${maven:OptionalDepends}
Description: JAXB Reference Implementation
GlassFish Java Architecture for XML Binding (JAXB) Reference
Implementation.
.
Java Architecture for XML Binding (JAXB) provides a fast and convenient
way to bind XML schemas and Java representations, making it easy for
Java developers to incorporate XML data and processing functions in Java
applications. As part of this process, JAXB provides methods for
unmarshalling (reading) XML instance documents into Java content trees,
and then marshalling (writing) Java content trees back into XML instance
documents. JAXB also provides a way to generate XML schema from Java
objects.
Package: libjaxb-java-doc
Architecture: all
Section: doc
Depends: ${maven:DocDepends}, ${misc:Depends}
Recommends: ${maven:DocOptionalDepends}
Description: JAXB Reference Implementation -- documentation
GlassFish Java Architecture for XML Binding (JAXB) Reference
Implementation.
.
Java Architecture for XML Binding (JAXB) provides a fast and convenient
way to bind XML schemas and Java representations, making it easy for
Java developers to incorporate XML data and processing functions in Java
applications. As part of this process, JAXB provides methods for
unmarshalling (reading) XML instance documents into Java content trees,
and then marshalling (writing) Java content trees back into XML instance
documents. JAXB also provides a way to generate XML schema from Java
objects.
.
This package contains the Javadoc API.
Package: libcodemodel-java
Architecture: all
Depends: libistack-commons-java, ${misc:Depends}
Description: Java library for code generators
CodeModel is a Java library for code generators; it provides a way to
generate Java programs in a way much nicer than
PrintStream.println(). This project is a spin-off from the JAXB
Reference Implementation for its schema compiler to generate Java
source files.
Package: librngom-java
Architecture: all
Depends: librelaxng-datatype-java, ${misc:Depends}
Description: Java library for parsing RELAX NG grammars
RNGOM is an open-source Java library for parsing RELAX NG grammars.
.
In particular, RNGOM can:
* parse the XML syntax
* parse the compact syntax
* check all the semantic restrictions as specified in the specification
* parse RELAX NG into application-defined data structures
* build a default data structure based around the binarized simple syntax
or another data structure that preserves more of the parsed information
* parse foreign elements/attributes in a schema
* parse comments in a schema
Package: libtxw2-java
Architecture: all
Depends:
libargs4j-java,
libcodemodel-java (>= 2.6+jaxb${source:Version}),
librngom-java (>= ${source:Version}),
libxsom-java (>= ${source:Version}),
${misc:Depends}
Description: Typed XML Writer for Java
A Java library that allows client applications to write arbitrary
well-formed typed XML documents.
Package: libxsom-java
Architecture: all
Depends: librelaxng-datatype-java, ${misc:Depends}
Description: XML Schema Object Model Java library
XML Schema Object Model (XSOM) is a Java library that allows applications
to easily parse XML Schema documents and inspect information in them. It
is expected to be useful for applications that need to take XML Schema
as an input.
Package: jaxb
Architecture: all
Depends:
default-jre-headless (>= 2:1.8) | java8-runtime-headless,
libjaxb-java (>= ${source:Version}),
${misc:Depends}
Description: JAXB Reference Implementation (Command Line Tools)
GlassFish Java Architecture for XML Binding (JAXB) Reference
Implementation.
.
Java Architecture for XML Binding (JAXB) provides a fast and convenient
way to bind XML schemas and Java representations, making it easy for
Java developers to incorporate XML data and processing functions in Java
applications. As part of this process, JAXB provides methods for
unmarshalling (reading) XML instance documents into Java content trees,
and then marshalling (writing) Java content trees back into XML instance
documents. JAXB also provides a way to generate XML schema from Java
objects.
.
This package contains the xjc and schemagen command line tools.
|