1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57
|
include /usr/share/dpkg/architecture.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
DOCS_stem = README
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
DOCS = $(addsuffix .html,$(DOCS_stem)) $(addsuffix .txt,$(DOCS_stem))
MANPAGES = jbig2.1
endif
%:
dh $@
%.html: %.md
cmark-gfm $< > $@
%.txt: %.md
cmark-gfm --to plaintext $< > $@
override_dh_autoreconf:
dh_autoreconf --as-needed
override_dh_auto_configure:
dh_auto_configure -- --disable-static --disable-rpath
execute_after_dh_auto_build: $(DOCS) $(MANPAGES)
execute_after_dh_auto_install:
find debian/ -name "*.la" -delete
d-shlibmove --commit \
--t64 \
--devunversioned \
--exclude-la \
--exclude-a \
--multiarch \
--movedev "debian/tmp/usr/include/*" usr/include/ \
debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.so
override_dh_install:
dh_install -Xpdf.py
override_dh_installdocs:
dh_installdocs --all -- $(DOCS)
override_dh_installchangelogs:
dh_installchangelogs -- ChangeLog
jbig2.1: %.1: src/%
LD_LIBRARY_PATH=src/.libs help2man --section 1 --no-info --no-discard-stderr \
--name "encoder for JBIG2" \
--output $@ $< \
|| { $1 --help; false; }
|