File: jekyll.gemspec

package info (click to toggle)
jekyll 2.2.0+dfsg-2
  • links: PTS, VCS
  • area: main
  • in suites: jessie, jessie-kfreebsd
  • size: 2,908 kB
  • ctags: 687
  • sloc: ruby: 6,811; sh: 121; xml: 106; makefile: 35
file content (63 lines) | stat: -rw-r--r-- 2,672 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
# coding: utf-8
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'jekyll/version'

Gem::Specification.new do |s|
  s.specification_version = 2 if s.respond_to? :specification_version=
  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.rubygems_version = '2.2.2'
  s.required_ruby_version = '>= 1.9.3'

  s.name              = 'jekyll'
  s.version           = Jekyll::VERSION
  s.license           = 'MIT'

  s.summary     = "A simple, blog aware, static site generator."
  s.description = "Jekyll is a simple, blog aware, static site generator."

  s.authors  = ["Tom Preston-Werner"]
  s.email    = 'tom@mojombo.com'
  s.homepage = 'https://github.com/jekyll/jekyll'

  s.files         = `git ls-files`.split($/)
  s.executables   = s.files.grep(%r{^bin/}) { |f| File.basename(f) }
  s.test_files    = s.files.grep(%r{^(test|spec|features)/})
  s.require_paths = ["lib"]

  s.rdoc_options = ["--charset=UTF-8"]
  s.extra_rdoc_files = %w[README.markdown LICENSE]

  s.add_runtime_dependency('liquid',    "~> 2.6.1")
  s.add_runtime_dependency('kramdown',  "~> 1.3")
  s.add_runtime_dependency('mercenary', "~> 0.3.3")
  s.add_runtime_dependency('safe_yaml', "~> 1.0")
  s.add_runtime_dependency('colorator', "~> 0.1")

  # Before 3.0 drops, phase the following gems out as dev dependencies
  # and gracefully handle their absence.
  s.add_runtime_dependency('classifier', "~> 1.3")
  s.add_runtime_dependency('pygments.rb', "~> 0.6.0")
  s.add_runtime_dependency('redcarpet', "~> 3.1")
  s.add_runtime_dependency('toml', '~> 0.1.0')
  s.add_runtime_dependency('jekyll-paginate', '~> 1.0')
  s.add_runtime_dependency('jekyll-gist', '~> 1.0')
  s.add_runtime_dependency('jekyll-coffeescript', '~> 1.0')
  s.add_runtime_dependency('jekyll-sass-converter', '~> 1.0')
  s.add_runtime_dependency('jekyll-watch', '~> 1.0')

  s.add_development_dependency('rake', "~> 10.1")
  s.add_development_dependency('rdoc', "~> 3.11")
  s.add_development_dependency('redgreen', "~> 1.2")
  s.add_development_dependency('shoulda', "~> 3.5")
  s.add_development_dependency('rr', "~> 1.1")
  s.add_development_dependency('cucumber', "1.3.11")
  s.add_development_dependency('RedCloth', "~> 4.2")
  s.add_development_dependency('maruku', "~> 0.7.0")
  s.add_development_dependency('rdiscount', "~> 1.6")
  s.add_development_dependency('mime-types', "~> 1.5")
  s.add_development_dependency('activesupport')
  s.add_development_dependency('jekyll_test_plugin')
  s.add_development_dependency('jekyll_test_plugin_malicious')
  s.add_development_dependency('rouge', '~> 1.3')
end