1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
|
Description: Changes for compatibility with Java 9
Besides the JSpecView error caused by
changes to DefaultMutableTreeNode in Java 9 there is an error caused by
the use of sun.audio.* classes (replaced by equivalent classes in
javax.sound.sampled in the patch), and another one during the generation
of the javadoc caused by the use of a debug method named '_()' (fixed by
setting the source level to 1.7).
Author: Emmanuel Bourg <ebourg@apache.org>
Last-Update: 2021-09-11
Bug-Debian: https://bugs.debian.org/875585
Forwarded: not-needed
@@ -17,10 +17,10 @@
PanelNode getPanelNode();
- Enumeration<JSVTreeNode> children();
+ Enumeration children();
int getIndex();
void setIndex(int index);
-}
\ No newline at end of file
+}
@@ -12,7 +12,7 @@
* @param msg
*
*/
- public static void _(String msg) {
+ public static void test(String msg) {
/**
* @j2sNative
*
|