1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
From: Boyuan Yang <byang@debian.org>
Date: Fri, 22 Sep 2023 17:34:23 -0400
Subject: Fix conformance test
Bug-Debian: https://bugs.debian.org/1051560
tools/conformance/generator.py | 2 +-
tools/conformance/tooling_test.sh | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
@@ -67,7 +67,7 @@ def GenerateConformanceCorpus(args):
cmd.extend(['--icc_out', pixel_prefix + '.icc'])
# Decode and generate the reference files.
- subprocess.check_call(cmd)
+ subprocess.check_call(' '.join(cmd), shell=True)
with open(metadata_filename, 'r') as f:
metadata = json.load(f)
@@ -42,6 +42,7 @@ main() {
build_dir=$(realpath "${MYDIR}/../../build")
fi
+ export LD_LIBRARY_PATH=${build_dir}
local decoder="${build_dir}/tools/djxl"
"${MYDIR}/generator.py" \
--decoder="${decoder}" \
|