File: control

package info (click to toggle)
jupyter-notebook 6.2.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 13,444 kB
  • sloc: javascript: 23,377; python: 15,064; makefile: 252; sh: 66
file content (133 lines) | stat: -rw-r--r-- 5,185 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
Source: jupyter-notebook
Maintainer: Debian Python Team <team+python@tracker.debian.org>
Uploaders: Gordon Ball <gordon@chronitis.net>, Jerome Benoit <calculus@rezozer.net>
Section: python
Priority: optional
Standards-Version: 4.5.0
Homepage: https://github.com/jupyter/notebook
Vcs-Git: https://salsa.debian.org/python-team/packages/jupyter-notebook.git
Vcs-Browser: https://salsa.debian.org/python-team/packages/jupyter-notebook
Build-Depends: debhelper-compat (= 13),
               dh-python,
               python3-all,
               python3-setuptools,
               python3-argon2,
               python3-nose <!nocheck>,
               python3-requests <!nocheck>,
               python3-requests-unixsocket <!nocheck>,
               python3-ipython <!nocheck>,
               python3-jupyter-core (>= 4.6.1) <!nocheck>,
               python3-jupyter-client (>= 5.3.4) <!nocheck>,
               python3-tornado (>= 6.1) <!nocheck>,
               python3-nbformat (>= 4.4) <!nocheck>,
               python3-nbconvert (>= 5) <!nocheck>,
               python3-ipykernel <!nocheck>,
               python3-prometheus-client <!nocheck>,
               python3-pytest <!nocheck>,
               python3-terminado (>= 0.8.3) <!nocheck>,
               python3-entrypoints <!nocheck>,
               python3-send2trash (>= 1.5) <!nocheck>,
               python3-zmq <!nocheck>,
               python3-sphinx <!nodoc>,
               python3-sphinx-rtd-theme <!nodoc>,
               python3-nbsphinx <!nodoc>,
               libjs-backbone (>= 1.2),
               libjs-bootstrap (>= 3.3),
               libjs-bootstrap-tour (>= 0.9),
               libjs-codemirror (>= 5.56),
               libjs-es6-promise (>= 1.0),
               fonts-font-awesome (>= 4.2),
               libjs-jed (>= 1.1.1),
               libjs-jquery (>= 3.5),
               libjs-jquery-ui (>= 1.12),
               libjs-marked (>= 0.7),
               libjs-mathjax (>= 2.5),
               libjs-moment (>= 2.8.4),
               libjs-requirejs (>= 2.1),
               libjs-requirejs-text,
               libjs-text-encoding (>= 0.1),
               libjs-underscore (>= 1.5),
               libjs-jquery-typeahead (>= 2.0),
               libjs-xterm (>= 3.8.1-3~),
               nodejs,
               node-less (>= 1.5),
               node-source-map,
               node-requirejs (>= 2.3),
               node-react (>= 16.13),
               node-po2json,
               node-fbjs,
               node-loose-envify,
               node-object-assign,
               uglifyjs,
               webpack,
               pandoc
Testsuite: autopkgtest-pkg-python
Rules-Requires-Root: no

Package: python3-notebook
Architecture: all
Depends: ${misc:Depends},
         ${python3:Depends},
         python3-terminado (>= 0.8.3),
         libjs-backbone (>= 1.2),
         libjs-bootstrap (>= 3.3),
         libjs-bootstrap-tour (>= 0.9),
         libjs-codemirror (>= 5.56),
         libjs-es6-promise (>= 1.0),
         fonts-font-awesome (>= 4.2),
         libjs-jed (>= 1.1.1),
         libjs-jquery (>= 3.5),
         libjs-jquery-ui (>= 1.12),
         libjs-marked (>= 0.7),
         libjs-mathjax (>= 2.5),
         libjs-moment (>= 2.8.4),
         libjs-requirejs (>= 2.1),
         libjs-requirejs-text,
         libjs-text-encoding (>= 0.1),
         libjs-underscore (>= 1.5),
         libjs-jquery-typeahead (>= 2.0),
         libjs-xterm (>= 3.8.1-3~),
Recommends: python3-ipywidgets,
            python3-ipykernel
Suggests: python-notebook-doc
Breaks: jupyter-nbextension-jupyter-js-widgets (<< 6.0.0-6~)
Built-Using: ${js:Built-Using}
Description: Jupyter interactive notebook (Python 3)
 The Jupyter Notebook is a web application that allows you to create and
 share documents that contain live code, equations, visualizations, and
 explanatory text. The Notebook has support for multiple programming
 languages, sharing, and interactive widgets.
 .
 This package contains the Python 3 library.

Package: python-notebook-doc
Build-Profiles: <!nodoc>
Architecture: all
Section: doc
Depends: ${misc:Depends},
         ${sphinxdoc:Depends},
         libjs-mathjax
Built-Using: ${sphinxdoc:Built-Using}
Description: Jupyter interactive notebook (documentation)
 The Jupyter Notebook is a web application that allows you to create and
 share documents that contain live code, equations, visualizations, and
 explanatory text. The Notebook has support for multiple programming
 languages, sharing, and interactive widgets.
 .
 This package contains the documentation.

Package: jupyter-notebook
Architecture: all
Section: science
Depends: ${misc:Depends},
         ${python3:Depends},
         python3-notebook (= ${binary:Version}),
         jupyter-core
Description: Jupyter interactive notebook
 The Jupyter Notebook is a web application that allows you to create and
 share documents that contain live code, equations, visualizations, and
 explanatory text. The Notebook has support for multiple programming
 languages, sharing, and interactive widgets.
 .
 This package provides the jupyter subcommands "notebook", "nbextension",
 "serverextension" and "bundlerextension".