File: changelog

package info (click to toggle)
kawari8 8.2.8-9
  • links: PTS
  • area: main
  • in suites: bullseye, sid
  • size: 1,380 kB
  • sloc: makefile: 24
file content (122 lines) | stat: -rw-r--r-- 4,443 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
kawari8 (8.2.8-9) unstable; urgency=low

  * debian/patches/012_python3.patch: Transit to python3 (Closes: #936781)
  * Update debian/copyright
  * Bump Standards-Version to 4.4.0

 -- Ying-Chun Liu (PaulLiu) <paulliu@debian.org>  Sun, 01 Sep 2019 15:18:27 +0800

kawari8 (8.2.8-8) unstable; urgency=low

  * Don't use stlport4.6. (Closes: #710000)
  * Update 009_kawari8-64bit-fix.patch to fix 64-bit crash (Closes: #702238)
  * Bump debhelper version to 9
  * Bump Standards-Version to 3.9.3

 -- Ying-Chun Liu (PaulLiu) <paulliu@debian.org>  Wed, 29 May 2013 15:29:19 +0800

kawari8 (8.2.8-7) unstable; urgency=low

  * Fix segfaults on 64bit arch (Closes: #693893)
    - Add patch 009_kawari8-64bit-fix.patch
    - Thanks to Shyouzou Sugitani <shy@users.sourceforge.jp>

 -- Ying-Chun Liu (PaulLiu) <paulliu@debian.org>  Sat, 24 Nov 2012 10:50:41 +0800

kawari8 (8.2.8-6.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix "ftbfs with GCC-4.7": add patch 008_fix_gcc4.7_FTBFS.patch (this->
    qualifier).
    Closes: #667219

 -- gregor herrmann <gregoa@debian.org>  Sun, 06 May 2012 16:28:01 +0200

kawari8 (8.2.8-6) unstable; urgency=low

  * debian/patches/007_fix_gcc4.5_FTBFS.patch: Fix FTBFS with gcc-4.5
    (Closes: #615675)

 -- Ying-Chun Liu (PaulLiu) <paulliu@debian.org>  Wed, 16 Mar 2011 03:09:23 +0800

kawari8 (8.2.8-5) unstable; urgency=low

  * debian/patches/006_fix_crash_on_dlclose.patch:
    - Fix segfault on dlclose() in load_library(). (Closes: #602611)
    - Thanks to Shyouzou Sugitani <shy@m3.catvmics.ne.jp>
  * Bump Standards-Version to 3.9.1 - Nothing need to be changed.

 -- Ying-Chun Liu (PaulLiu) <paulliu@debian.org>  Tue, 09 Nov 2010 01:33:18 +0800

kawari8 (8.2.8-4) unstable; urgency=low

  * Only use STLport4.6 on i386 architecture.
  * debian/patches/005_add_missing_includes.patch:
    - Add missing includes to fix FTBFS

 -- Ying-Chun Liu (PaulLiu) <paulliu@debian.org>  Wed, 10 Feb 2010 21:30:07 +0800

kawari8 (8.2.8-3) unstable; urgency=low

  * debian/control:
    - Since stlport5.2 and stlport5.1 is going to be removed in Debian, we
      change Build-Depends back to stlport4.6
    - Change Maintainer field to my Debian account
    - Bump Standards-Version to 3.8.4: Nothing needs to be changed
    - Bump Build-Depends on debhelper 5 to 7
  * Move README.Debian-source to README.source. Add more information.
  * debian/compat: change compat from 5 to 7
  * debian/copyright: Use machine readable format

 -- Ying-Chun Liu (PaulLiu) <paulliu@debian.org>  Wed, 10 Feb 2010 07:05:59 +0800

kawari8 (8.2.8-2) unstable; urgency=low

  * Build depends on stlport5.2. (Closes: #521751)
  * Bump Standards-Version to 3.8.1 - Nothing need to be changed.

 -- Ying-Chun Liu (PaulLiu) <grandpaul@gmail.com>  Fri, 01 May 2009 13:59:07 +0800

kawari8 (8.2.8-1) unstable; urgency=low

  * New upstream release
  * Refine debian/copyright
  * Set doc-book sections to Games/Toys
  * Use python-config to build against current python version

 -- Ying-Chun Liu (PaulLiu) <grandpaul@gmail.com>  Sun, 20 Apr 2008 23:35:17 +0800

kawari8 (8.2.7-1) unstable; urgency=low

  * New upstream release
    + Remove 002_kawari_log.cpp.patch which has been merged into the upstream
    + Refresh 001_gcc.mak.patch for new upstream version
  * Fix kawari_encode.sgml for lintian warning: manpage-has-bad-whatis-entry
  * Build-depending on stlport5.1 >= 5.1.5 to fix FTBFS on arm,mips(el)
  * Bump standard versions to 3.7.3
    + Use Homepage field instead of pseudo-field in long description
  * Add optional get-orig-source rule in debian/rules
  * Fix manpage-has-errors-from-man in kawari_encode.sgml
  * Add UPSTREAM_VERSION and ZIP_VERSION variable for ease maintenance.
  * Use wildcards in .install and .docs file. Thanks to Thomas Girard.

 -- Ying-Chun Liu (PaulLiu) <grandpaul@gmail.com>  Sat, 23 Feb 2008 22:55:18 +0800

kawari8 (8.2.4-3) unstable; urgency=low

  * Link against libstlport5.1 (Closes: 448252)

 -- Ying-Chun Liu (PaulLiu) <grandpaul@gmail.com>  Sun, 28 Oct 2007 16:37:02 +0800

kawari8 (8.2.4-2) unstable; urgency=low

  * Improve package description (Closes: 421155)
  * Handling DEB_BUILD_OPTIONS=nostrip (Closes: 437247)

 -- Ying-Chun Liu (PaulLiu) <grandpaul@gmail.com>  Thu, 16 Aug 2007 00:45:10 +0800

kawari8 (8.2.4-1) unstable; urgency=low

  * Initial Release (Closes: #411612)

 -- Ying-Chun Liu (PaulLiu) <grandpaul@gmail.com>  Sun, 17 Sep 2006 21:03:52 +0800