File: configure.in.bot

package info (click to toggle)
kdelibs 4:3.5.10.dfsg.1-5+deb6u1
  • links: PTS, VCS
  • area: main
  • in suites: squeeze-lts
  • size: 98,764 kB
  • ctags: 76,783
  • sloc: cpp: 578,944; xml: 117,726; ansic: 28,321; sh: 11,188; perl: 6,290; java: 4,069; makefile: 3,795; yacc: 2,437; lex: 643; ruby: 329; asm: 166; jsp: 128; haskell: 116; f90: 99; ml: 75; awk: 71; tcl: 29; lisp: 24; php: 9
file content (138 lines) | stat: -rw-r--r-- 4,901 bytes parent folder | download | duplicates (5)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
dnl put here things which have to be done as very last part of configure

if test "x$have_ssl" != xyes; then
  echo ""
  echo "You're missing openSSL, or your version is too old (before 0.9.5a)."
  echo "KDE won't be able to access secure websites without it, so you should"
  echo "consider installing or upgrading it."
  echo "Have a look at http://www.openssl.org, or find a binary package for"
  echo "your platform."
  echo ""
  all_tests=bad
fi

if test -z "$LIBART_CONFIG"; then
  echo ""
  echo "You're missing libART LGPL, or your version is too old (before 2.3.8)."
  echo "KDE won't be able to render SVG icons without it, so you should"
  echo "consider installing or upgrading it."
  echo "Have a look at http://www.levien.com (official site) or"
  echo "http://svg.kde.org/download.html for sources, or find a binary"
  echo "package for your platform."
  echo ""
  all_tests=bad
fi

if test -z "$LIBPCRE"; then
  echo ""
  echo "You're missing libpcre."
  echo "Some web pages (using regular expressions in Javascript code) will not "
  echo "work correctly, the regexp support being limited without libpcre. "
  echo "If you plan to use Konqueror as a Web Browser, download libpcre from "
  echo "http://www.pcre.org or find a binary package for your platform."
  echo ""
  all_tests=bad
fi

if test -z "$LIBBZ2"; then
  echo ""
  echo "You're missing bzip2 development files."
  echo "KDE won't be able to provide a help ioslave (help://) without it,"
  echo "so if you want helpfiles you should consider installing it."
  echo "Have a look at http://sources.redhat.com/bzip2/ for sources, "
  echo "or find a binary package for your platform."
  echo ""
  all_tests=bad
fi

if test -z "$LIBXML_CFLAGS"; then
  echo ""
  echo "You're missing libxml2 2.4.8 or later."
  echo "KDE won't be able to provide a help ioslave (help://) without it,"
  echo "so if you want helpfiles you should consider installing it."
  echo "Have a look at ftp://xmlsoft.org/ for sources, or find a binary"
  echo "package for your platform."
  echo "You can find a copy of libxml2 in the kdesupport module if you're using CVS."
  echo ""
  all_tests=bad
fi

if test -z "$LIBXSLT_CFLAGS"; then
  echo ""
  echo "You're missing libxslt 1.0.7 or later."
  echo "KDE won't be able to provide a help ioslave (help://) without it,"
  echo "so if you want helpfiles you should consider installing it."
  echo "Have a look at ftp://xmlsoft.org/ for sources, or find a binary"
  echo "package for your platform."
  echo "You can find a copy of libxslt in the kdesupport module if you're using CVS."
  echo ""
  all_tests=bad
fi

if test -z "$jpeg_incdir" || test -z "$LIBJPEG" ; then
  echo ""
  echo "You're missing libjpeg 6 or later."
  echo "KDE won't be able to display JPEG and many web pages won't"
  echo "work because of this."
  echo "You may need to either provide correct --with-extra-... options,"
  echo "or the development package of libjpeg6b. You can get a source "
  echo "package of libjpeg from http://www.ijg.org/"
  echo ""
  all_tests=bad
fi 

if test "$kde_supports_versionmaps" != "yes"; then
  echo ""
  echo "Your ld doesn't support unversioned version scripts."
  echo "KDE will continue to build and run just fine, but you might"
  echo "experience a small performance penality."
  echo ""
  echo "If you're running Linux, your binutils are probably too old."
  echo "If you're running non-linux your platform might simply not support it."
  echo ""
  all_tests=bad
fi

if test "$ac_use_cups" != "yes"; then
  if test "$ac_have_new_cups" != "yes"; then
    echo ""
    echo "The installed CUPS version is too old. The minimum"
    echo "required version is 1.1.9. Please upgrade your CUPS"
    echo "installation from http://www.cups.org. CUPS support"
    echo "has been disabled."
    echo ""
  else
    echo ""
    echo "You're missing CUPS (Common UNIX Printing System) support."
    echo "If you want CUPS support, please install CUPS from http://www.cups.org"
    echo "or the development packages of your distribution."
    echo ""
  fi
  all_tests=bad
fi

if test "$EXRSTATUS" = "no"; then
  echo ""
  echo "No OpenEXR Libraries were found"
  echo "Install the OpenEXR package (from http://www.openexr.org)"
  echo "if you want EXR image format support"
  echo ""
fi

if test "$EXRSTATUS" = "old"; then
  echo ""
  echo "OpenEXR libraries were found, but at least version 1.1.0 is required"
  echo "Install a newer OpenEXR package (from http://www.openexr.org)"
  echo "if you want EXR image format support"
  echo ""
fi

if test "$USE_POSIX_ACL" != "yes"; then
  echo ""
  echo "libacl was not found. Without that library, you will not be able"
  echo "to manage access control lists on file systems that support them,"
  echo "such as ext3 or reiserfs."
  echo "You can download it from ftp://oss.sgi.com/projects/xfs/cmd_tars/"
  echo "(you will need attr too)"
  echo ""
fi