File: changelog

package info (click to toggle)
kexi 1:3.2.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 30,604 kB
  • sloc: cpp: 98,995; ansic: 4,556; sql: 955; sh: 628; python: 556; java: 107; makefile: 21
file content (132 lines) | stat: -rw-r--r-- 5,217 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
kexi (1:3.2.0-2) unstable; urgency=medium

  * Use the Debian postgresql-common stuff to force the default version of
    PostgreSQL:
    - invoke /usr/share/postgresql-common/supported-versions, getting the
      default version of it
    - pass -DPostgreSQL_ADDITIONAL_VERSIONS to cmake
    - drop upstream_cmake-find-PostgreSQL-12.patch, no more needed now
  * Add the libkf5doctools-dev build dependency to install the documentation
    - update kexi-data.install accordingly
    - pass -DSHOULD_BUILD_DOC=ON to cmake to enable also the English
      documentation
  * Small copyright update.

 -- Pino Toscano <pino@debian.org>  Tue, 05 Nov 2019 08:38:43 +0100

kexi (1:3.2.0-1) unstable; urgency=medium

  * New upstream release.
  * Bump the libkdb3-dev, libkproperty3-dev, and libkreport3-dev build
    dependencies to >= 3.1.91~.
  * Update the patches:
    - upstream_Fix-build-with-Qt-5.11-missing-headers.patch: drop, backported
      from upstream
    - upstream_Install-the-application-icons.patch: drop, backported from
      upstream
    - upstream_cmake-find-PostgreSQL-11.patch: drop, backported from upstream
  * Add the configuration for the CI on salsa.
  * Bump Standards-Version to 4.4.1, no changes required.
  * Backport upstream commit a86e74fc6364f3ac4adbbf6712eb4f348e68e308 to build
    with newer KF; patch upstream_Fix-build-with-Qt-5.13.patch.
  * Backport upstream commit 88ac2b4a1386bc05f0e3965f31949039eaf4d3ff to find
    PostgreSQL 12; patch upstream_cmake-find-PostgreSQL-12.patch.

 -- Pino Toscano <pino@debian.org>  Mon, 28 Oct 2019 22:56:31 +0100

kexi (1:3.1.0-4) unstable; urgency=medium

  * Backport upstream commit 54b2bcfb2ff1af6e7cbf7bdd60aef3d7c50b2785 to find
    PostgreSQL 11; patch upstream_cmake-find-PostgreSQL-11.patch.
    (Closes: #912157)

 -- Pino Toscano <pino@debian.org>  Sun, 04 Nov 2018 17:14:23 +0100

kexi (1:3.1.0-3) unstable; urgency=medium

  * Update package descriptions according to the upstream feedback.
  * Stop removing unused keximigrate_spreadsheet.mo translations, as they are
    not shipped anymore.
  * Update Vcs-* fields.
  * Backport upstream commit 1578fcb4a0407cf368edb6ee4605c4ef9e77b6ed to fix
    build with Qt >= 5.11; patch
    upstream_Fix-build-with-Qt-5.11-missing-headers.patch. (Closes: #906624)
  * Backport upstream commit 12eed3a629a06fe54f52bf0a36b4c8b81f8e5156 to
    install the application icon; patch
    upstream_Install-the-application-icons.patch
    - update kexi-data.install for this
  * Bump Standards-Version to 4.2.1, no changes required.

 -- Pino Toscano <pino@debian.org>  Mon, 03 Sep 2018 06:53:29 +0200

kexi (1:3.1.0-2) unstable; urgency=medium

  * Upload to unstable.

 -- Pino Toscano <pino@debian.org>  Fri, 09 Mar 2018 09:35:02 +0100

kexi (1:3.1.0-1) experimental; urgency=medium

  * New upstream release.
  * Bump the libkdb3-dev, libkproperty3-dev, and libkreport3-dev build
    dependencies to >= 3.1.0~.
  * Update the patches:
    - upstream_improve-.desktop-validity.patch: drop, backported from upstream
  * Update install files.
  * Simplify watch file, and switch it to https.
  * Bump Standards-Version to 4.1.3, no changes required.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
    - remove --parallel for dh, as now done by default
  * Switch from dh_install to dh_missing for --fail-missing.
  * Switch Vcs-* fields to salsa.debian.org.

 -- Pino Toscano <pino@debian.org>  Thu, 08 Mar 2018 23:51:57 +0100

kexi (1:3.0.2-4) unstable; urgency=medium

  * Add also 'tr' to the old calligra-l10n languages. (Closes: #874419)

 -- Pino Toscano <pino@debian.org>  Wed, 13 Sep 2017 07:22:25 +0200

kexi (1:3.0.2-3) unstable; urgency=medium

  [ Pino Toscano ]
  * Add breeze-icon-theme-rcc also as runtime dependency, since kexi refuses
    to start otherwise (sigh)...
  * Backport upstream commit 11b6265b8d14d58921edeed519f23d0e362cd7df to make
    the kexi .desktop file more valid; patch
    upstream_improve-.desktop-validity.patch.
  * Bump Standards-Version to 4.1.0, no changes required.
  * Explicitly add the gettext build dependency.

 -- Pino Toscano <pino@debian.org>  Fri, 01 Sep 2017 22:59:44 +0200

kexi (1:3.0.2-2) unstable; urgency=medium

  * Pass -DKEXI_QTGUI_RUNTIME_AVAILABLE=OFF to cmake, to make sure a GUI/window
    system is assumed to not be present at build time.
  * Suggest kexi-web-form-widget in kexi.

 -- Pino Toscano <pino@debian.org>  Tue, 22 Aug 2017 19:48:45 +0200

kexi (1:3.0.2-1) unstable; urgency=medium

  * New upstream release. (Closes: #871257)
  * Small copyright update.
  * Drop all the pre-Jessie replaces/breaks.
  * Bump kdb, kpropert, and kreport build dependencies to 3.0.2, to ensure
    building against the latest versions.
  * Bump Standards-Version to 4.0.1, no changes required.
  * Add Breaks/Replaces for all the calligra-l10n packages prior to < 2.9.11-2,
    i.e. when kexi was split out of calligra (in Debian).
  * Upload to unstable.

 -- Pino Toscano <pino@debian.org>  Sat, 19 Aug 2017 14:14:56 +0200

kexi (1:3.0.1.1-1) experimental; urgency=low

  * Initial release.

 -- Pino Toscano <pino@debian.org>  Sat, 24 Jun 2017 20:10:10 +0200