1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115
|
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
SYSTEM = --build $(DEB_HOST_GNU_TYPE)
else
SYSTEM = --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
endif
CONFFLAGS = $(SYSTEM) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --sysconfdir=/etc --libdir=\$${prefix}/lib
CFLAGS = -Wall -g -D_GNU_SOURCE
LDFLAGS += -Wl,--as-needed
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
configure: configure-stamp
configure-stamp:
dh_testdir
-find . \( -name config.h \
-o -name Makefile.in \) \
-execdir cp \{} \{}.debian-orig \; -fprint dist-files
rm -f config.sub && ln -sf /usr/share/misc/config.sub .
rm -f config.guess && ln -sf /usr/share/misc/config.guess .
CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" ./configure $(CONFFLAGS)
touch configure-stamp
build: build-stamp
build-stamp: configure
dh_testdir
$(MAKE)
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
if [ -f Makefile ]; then \
$(MAKE) distclean; \
fi
if [ -e dist-files ] ; then \
for f in `cat dist-files`; do mv $$f.debian-orig $$f; done; \
rm dist-files; \
fi
dh_clean config.log config.guess config.sub
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
$(MAKE) install prefix=/usr bindir=/usr/sbin DESTDIR=$(CURDIR)/debian/keytouch-editor
cd debian/keytouch-editor/usr/share/keytouch-editor/pixmaps && convert icon.png icon.xpm
cd debian/keytouch-editor/usr/sbin && mv keytouch-editor-bin keytouch-editor
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs ChangeLog
dh_installdocs debian/NEWS.Debian
dh_installexamples
dh_installmenu
dh_install
dh_installman debian/keytouch-editor.8
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
|