1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
|
From: Maximiliano Curia <maxy@gnuservers.com.ar>
Date: Wed, 16 May 2018 19:50:55 +0200
Subject: usermetadatawritertest: skip if xattr is not supported
Last-Update: 2025-02-15
autotests/usermetadatawritertest.cpp | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
@@ -70,7 +70,9 @@ void UserMetaDataWriterTest::test()
void UserMetaDataWriterTest::testMetadataSize()
{
KFileMetaData::UserMetaData md(testOutputPath(TEST_FILENAME));
- QVERIFY(md.isSupported());
+ if (!md.isSupported()) {
+ QSKIP("The system doesn't support xattr, skipping");
+ }
// In the current ext2, ext3, and ext4 filesystem implementations,
// the total bytes used by the names and values of all of a file's
|