1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71
|
From: Arthur Diniz <arthurbdiniz@gmail.com>
Date: Mon, 24 Mar 2025 17:01:41 +0000
Subject: Workaround shellescape package name change
The shellescape package has changed its upstream name and thus
the import path has changed. The packaging in debian still uses
the old import path; so patch the source code until we have the
new library packaged in debian.
Link: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1101060
Signed-off-by: Arthur Diniz <arthurbdiniz@gmail.com>
pkg/build/nodeimage/internal/kube/source.go | 2 +-
pkg/cluster/internal/create/create.go | 2 +-
pkg/cluster/internal/logs/logs.go | 2 +-
pkg/exec/helpers.go | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/pkg/build/nodeimage/internal/kube/source.go b/pkg/build/nodeimage/internal/kube/source.go
index 9e68a6c..fb0d9c7 100644
@@ -23,7 +23,7 @@ import (
"path/filepath"
"strings"
- "al.essio.dev/pkg/shellescape"
+ "github.com/alessio/shellescape"
"sigs.k8s.io/kind/pkg/errors"
"sigs.k8s.io/kind/pkg/exec"
diff --git a/pkg/cluster/internal/create/create.go b/pkg/cluster/internal/create/create.go
index a935822..351ba6c 100644
@@ -21,7 +21,7 @@ import (
"math/rand"
"time"
- "al.essio.dev/pkg/shellescape"
+ "github.com/alessio/shellescape"
"sigs.k8s.io/kind/pkg/cluster/internal/delete"
"sigs.k8s.io/kind/pkg/cluster/internal/providers"
diff --git a/pkg/cluster/internal/logs/logs.go b/pkg/cluster/internal/logs/logs.go
index 28f4c28..2dc5941 100644
@@ -24,7 +24,7 @@ import (
"path"
"path/filepath"
- "al.essio.dev/pkg/shellescape"
+ "github.com/alessio/shellescape"
"sigs.k8s.io/kind/pkg/cluster/nodes"
"sigs.k8s.io/kind/pkg/errors"
diff --git a/pkg/exec/helpers.go b/pkg/exec/helpers.go
index 0acfa44..e579589 100644
@@ -23,7 +23,7 @@ import (
"os"
"strings"
- "al.essio.dev/pkg/shellescape"
+ "github.com/alessio/shellescape"
"sigs.k8s.io/kind/pkg/errors"
)
|