1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121
|
Description: Try to fix building on kFreeBSD
Upstream's build system fails to detect GNU/kFreeBSD because its
uname output is unique. This patch sets its uname to match the
regular FreeBSD build parameters. It also sets the target build
directory to always be "installdir" (rather than uname-arch). We
only build for one architecture at a time, anyway, and this way,
we don't have to figure out which system we're building on
and mangle the uname string depending on whether we're Linux or kFreeBSD.
Author: Afif Elghraoui <afif@ghraoui.name>
Forwarded: not-needed
Last-Update: 2016-01-02
@@ -43,7 +43,7 @@
target="Darwin-amd64$opts"
fi
;;
- FreeBSD)
+ FreeBSD|"GNU/kFreeBSD")
target="FreeBSD-i386$opts"
if [ `uname -m` = "amd64" ] ; then
target="FreeBSD-amd64$opts"
@@ -137,7 +137,7 @@
CXXLIBS :=
LDFLAGS_PYTHON := -bundle -framework CoreFoundation -framework Python -dynamic
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
Darwin-i386-debug|Darwin-amd64-debug)
@@ -157,7 +157,7 @@
CXXLIBS :=
LDFLAGS_PYTHON := -bundle -framework CoreFoundation -framework Python -dynamic
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
FreeBSD-amd64)
@@ -175,7 +175,7 @@
CXXLDFLAGS := -L/usr/local/lib
CXXLIBS := -pthread -lthr
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
FreeBSD-amd64-debug)
@@ -193,7 +193,7 @@
CXXLDFLAGS := -L/usr/local/lib
CXXLIBS := -pthread -lthr
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
FreeBSD-amd64-profile)
@@ -211,7 +211,7 @@
CXXLDFLAGS := -pg -L/usr/local/lib
CXXLIBS := -pthread -lthr
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
Linux-i686)
@@ -229,7 +229,7 @@
CXXLDFLAGS := -L/usr/local/lib
CXXLIBS := -pthread -ldl
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
Linux-amd64)
@@ -247,7 +247,7 @@
CXXLDFLAGS := -L/usr/local/lib
CXXLIBS := -pthread -ldl
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
Linux-amd64-debug)
@@ -265,7 +265,7 @@
CXXLDFLAGS := -L/usr/local/lib
CXXLIBS := -pthread -ldl
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
Linux-amd64-profile)
@@ -283,7 +283,7 @@
CXXLDFLAGS := -L/usr/local/lib
CXXLIBS := -pthread -ldl
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
Linux-ia64)
@@ -301,7 +301,7 @@
CXXLDFLAGS := -L/usr/local/lib
CXXLIBS := -pthread -ldl
ARFLAGS := ruvs
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
@@ -331,7 +331,7 @@
CXXLDFLAGS :=
CXXLIBS := -lpthread -lrt
ARFLAGS := ruv
-INSTALL/ := $target/
+INSTALL/ := installdir/
EOF
;;
*)
|