1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
CFLAGS:=$(CPPFLAGS) $(CFLAGS)
CXXFLAGS:=$(CPPFLAGS) $(CXXFLAGS)
subdirectories:= $(filter-out debian/, $(shell ls -d */))
unusable:= tapper/ trie/
%:
dh $@ --with python2
override_dh_auto_build:
$(MAKE) install \
CLDFLAGS="$(LDFLAGS)" \
CXXLDFLAGS="$(LDFLAGS)"
mv installdir/bin/atac.pl installdir/bin/atac
override_dh_auto_clean:
$(MAKE) real-clean
rm -rf installdir
get-orig-source:
DEB_VERSION_UPSTREAM=$(DEB_VERSION_UPSTREAM) debian/get-orig-source
|