File: koala.xml

package info (click to toggle)
koala 0.3.2a-1
  • links: PTS
  • area: main
  • in suites: woody
  • size: 2,036 kB
  • ctags: 582
  • sloc: ansic: 29,449; makefile: 1,666; xml: 11
file content (11 lines) | stat: -rw-r--r-- 1,407 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
<?xml version="1.0"?>
<KOALACONFIG configversion="1">
In order for this configuration to be used in a larger setup,
the node ID's must be changed.
This default configuration will work for either
a client to zone setup or a client to hub to zone setup<CLIENT Background="false" NodeID="10.0.0.2">Client configuration section<Listen port="6464" bind="any"/><Log message="log/climsg.log" error="log/clierr.log"/><Timer ticklen="100000" reportingperiod="600"/><Database path="clientdb"/><Uplink>
Client daemons can only connect to a single uplink<Link address="localhost" port="8204">Localhost Uplink</Link></Uplink></CLIENT><HUB Background="false" NodeID="10.0.0.1">Hub configuration section<Listen port="8204" bind="any"/><Log message="log/hubmsg.log" error="log/huberr.log"/><Timer ticklen="100000" reportingperiod="600"/><Uplink>
Hub Daemons by default do not create any uplinks
<Link address="localhost" port="8204">Localhost Uplink</Link></Uplink></HUB><ZONE Background="false" NodeID="10.0.0.3">Zone configuration section<Listen port="8204" bind="any"/><Log message="log/zonmsg.log" error="log/zonerr.log"/><Timer ticklen="100000" reportingperiod="600"/><Database path="zonedb"/><Uplink connect="yes">
zone daemons by default connect to a local uplink
Change 'connect=yes' to 'connect=no' to change this behavior<Link address="localhost" port="8204">Localhost Uplink</Link></Uplink></ZONE></KOALACONFIG>