File: changelog

package info (click to toggle)
kodi 2:17.6+dfsg1-4
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 87,148 kB
  • sloc: cpp: 588,459; xml: 58,591; ansic: 42,735; sh: 12,932; makefile: 4,785; python: 2,803; objc: 1,075; perl: 1,041; cs: 624; java: 500; asm: 294; sed: 16
file content (644 lines) | stat: -rw-r--r-- 24,965 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
kodi (2:17.6+dfsg1-4) unstable; urgency=medium

  * debian/tests/gui: Print xvfb-run error to stdout
  * debian/tests/gui: Fix test by starting 24bit screen and waiting for
    kodi's start
  * Drop transitional packages
  * Fix FTBFS when _G_va_list is not defined, like on Ubuntu 19.04

 -- Balint Reczey <rbalint@ubuntu.com>  Tue, 20 Nov 2018 12:21:00 +0100

kodi (2:17.6+dfsg1-3) unstable; urgency=medium

  [ Balint Reczey ]
  * debian/NEWS: Fix language to keep lintian happy
  * Add simple autopkgtest

  [ Gianfranco Costamagna ]
  * Upstream fixes for new ffmpeg:
    debian/patches/19f28e88a5dfed82e9844f69210f7c045f18ca8e.patch
    debian/patches/c7e2acc1b2ee781af6e14d80da0edd0aa23bdf03.patch
    (Closes: #888383, #912994)

 -- Balint Reczey <rbalint@ubuntu.com>  Fri, 16 Nov 2018 01:42:36 +0100

kodi (2:17.6+dfsg1-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/copyright: Use https protocol in Format field
  * d/control: Set Vcs-* to salsa.debian.org

  [ Rechi ]
  * Drop build dependencies on libboost-*
    Boost isn't required since v17.

  [ Felipe Sateler ]
  * Change maintainer address to debian-multimedia@lists.debian.org

  [ Balint Reczey ]
  * Ship only Kodi desktop session without the xbmc.desktop duplicate link
  * Stop build-depending on versioned GCC, this workaround is not needed
    anymore (Closes: #892399)
    Thanks to Adrian Bunk who also proposed a patch and a delayed NMU.
  * Stop shipping kodi.service
    Please use a lightweight display manager set up to autologin instead.
  * Add d/source.lintian-overrides to d/source/lintian-overrides
    to keep lintian happy

  [ Rolf Leggewie ]
  * demote hard font dependencies from Depends to Recommends (LP: #1685918)

 -- Balint Reczey <rbalint@ubuntu.com>  Sat, 28 Apr 2018 20:50:46 +0200

kodi (2:17.6+dfsg1-1) unstable; urgency=medium

  * New upstream version 17.6 (with accumulated changes from 17.4 and 17.5):
    - https://kodi.tv/article/kodi-v174-final-just-bunch-fixes
    - https://kodi.tv/article/kodi-v175-final-another-bunch-fixes
    - https://kodi.tv/article/kodi-v176-final-very-last
  * Refresh patches
  * Depend and build-depend on python-pil instead of python-imaging
    (Closes: #866437)
  * Apply workaround for scratchy sound with FFmpeg 3.4.
    Thanks to James Cowgill for triaging and Stefan Hachmann for the patch
    (Closes: #881536)
  * Fix starting kodi on arm64 (Closes: #876876)
  * Change URLs to use HTTPS in README.Debian and drop feed URL from
    description (Closes: #860484)

 -- Balint Reczey <rbalint@ubuntu.com>  Tue, 26 Dec 2017 01:06:49 +0100

kodi (2:17.3+dfsg1-5) unstable; urgency=medium

  * Build-depend on fontforge-nox (not fontforge.
  * Use rsvg-convert to generate branding logo.
    Build-depend on (not inkscape).
  * Fix remove repository feed from kodi-data.
    Tighten kodi-repository-kodi breaks+replaces on kodi-data.

 -- Jonas Smedegaard <dr@jones.dk>  Wed, 11 Oct 2017 02:37:25 +0200

kodi (2:17.3+dfsg1-4) unstable; urgency=medium

  * Update package relations:
    + Fix have kodi-repository-kodi conflict against and replace older
      kodi/kodi-data/xbmc.
      Fixes bug#877960. Thanks to Andreas Beckmann.
    + Fix have kodi-repository-kodi conflict against (not break) virtual
      kodi-repository.
    + Fix have package kodi-repository-kodi depend on ${misc:Depends}.
    + Stop build-depend on dh-autoreconf autotools-dev: Handled by
      debhelper.
  * Rewrite copyright info, with major coverage improvements.
  * Add maintainer script copyright-check to source.
  * Update git-buildpackage config:
    + Add usage comment.
    + Filter any .git* file.
  * Override lintian regarding license in License-Reference field.
    See bug#786450.
  * Override lintian regarding obsolete-url-in-packaging: License grant
    must be included verbatim.

 -- Jonas Smedegaard <dr@jones.dk>  Tue, 10 Oct 2017 22:46:23 +0200

kodi (2:17.3+dfsg1-3) unstable; urgency=medium

  * Fix set core configure options to all instances.
  * Set configure options --disable-maintainer-mode
    --disable-silent-rules (unused now but might be added in future).
  * Fix avoid custom build rule silencing.
  * Fix FTBFS: Build-depend on and build with gcc-6 and g++-6 (until
    bug#841556 is fixed).
    Closes: Bug#853476. Thanks to Matthias Klose and Bálint Réczey.
  * Modernize Vcs-* fields:
    + Use https (not git or http) protocol.
    + Use git (not gitweb) in path.
  * Use https in Homepage URL.
  * Add myself as uploader.
  * Add patch 18 to support omitting addon repository feed.
  * Ship repository feed in separate package kodi-repository-kodi.
    Closes: Bug#877656 (or arguably only lowers severity of it, but
    since we cannot track that versioned better to close and track the
    lowered severity separately).

 -- Jonas Smedegaard <dr@jones.dk>  Wed, 04 Oct 2017 03:53:10 +0200

kodi (2:17.3+dfsg1-2) unstable; urgency=medium

  * Upload to unstable
  * Stop shipping kodi.service as an example since it is now shipped
    as a regular .service file

 -- Balint Reczey <rbalint@ubuntu.com>  Thu, 29 Jun 2017 05:15:29 +0200

kodi (2:17.3+dfsg1-1) experimental; urgency=medium

  * New upstream version 17.3
    See: https://kodi.tv/article/kodi-v173-minor-bug-fix-and-security-release
  * Refresh patches

 -- Balint Reczey <rbalint@ubuntu.com>  Fri, 26 May 2017 18:44:04 +0200

kodi (2:17.1+dfsg1-3) unstable; urgency=medium

  * Fix zip file directory traversal vulnerability (CVE-2017-8314)
    (Closes: #863230)

 -- Balint Reczey <rbalint@ubuntu.com>  Sat, 27 May 2017 00:50:34 +0200

kodi (2:17.1+dfsg1-2) unstable; urgency=medium

  * Upload to unstable

 -- Balint Reczey <rbalint@ubuntu.com>  Thu, 13 Apr 2017 23:49:12 +0200

kodi (2:17.1+dfsg1-1) experimental; urgency=medium

  * Depend on fonts-noto-mono package which contains NotoMono-Regular.ttf
    (Closes: #856668)
  * Fix FTBFS on alpha by not using Intel assempler code (Closes: #856815)
  * Imported Upstream version 17.1+dfsg1
    See: https://kodi.tv/kodi-v17-1-krypton
  * Update my Uploader email address to my Ubuntu one
  * Fix extract-components target in d/rules

 -- Balint Reczey <rbalint@ubuntu.com>  Sun, 02 Apr 2017 11:01:21 +0200

kodi (2:17.1~rc1+dfsg1-1) experimental; urgency=medium

  * Imported Upstream version 17.1~rc1+dfsg1
  * Refresh patches

 -- Balint Reczey <balint@balintreczey.hu>  Tue, 28 Feb 2017 02:21:54 +0100

kodi (2:17.0+dfsg1-3) unstable; urgency=medium

  * Ship disabled systemd service file (Closes: #854985, #801886)
  * Use systemd service file recommended on upstream wiki

 -- Balint Reczey <balint@balintreczey.hu>  Wed, 22 Feb 2017 01:28:43 +0100

kodi (2:17.0+dfsg1-2) unstable; urgency=medium

  * Apply patches to additional tarballs using quilt series file
    (Closes: #854463)

 -- Balint Reczey <balint@balintreczey.hu>  Thu, 09 Feb 2017 10:25:18 +0100

kodi (2:17.0+dfsg1-1) experimental; urgency=medium

  * Imported Upstream version 17.0+dfsg1
    See: https://kodi.tv/kodi17/

 -- Balint Reczey <balint@balintreczey.hu>  Mon, 06 Feb 2017 19:33:08 +0100

kodi (2:17.0~rc4+dfsg1-1) experimental; urgency=medium

  * Imported Upstream version 17.0~rc4+dfsg1
    See: https://kodi.tv/kodi-v17-0-krypton-release-candidate-4/
  * Refresh patches
  * Remove spaces around '=' in service file.
    Also convert service file to use Unix line ending

 -- Balint Reczey <balint@balintreczey.hu>  Sun, 05 Feb 2017 01:27:27 +0100

kodi (2:17.0~rc3+dfsg1-2) unstable; urgency=medium

  * Bump debhelper compat level to 10.
    Remove --parallel and --with autoreconf since those are now defaults
  * Build-depend on libcec-dev >= 4~ (Closes: #852216)
  * Fix make clean in debian/rules
  * Use real dlopen() for opening libdvdcss (Closes: #784578)

 -- Balint Reczey <balint@balintreczey.hu>  Wed, 25 Jan 2017 21:23:22 +0100

kodi (2:17.0~rc3+dfsg1-1) unstable; urgency=medium

  * Make default lirc device match lirc package's default (Closes: #850467)
  * Stop passing ./configure flags which are not supported anymore
  * Update fonts and font dependencies
  * Imported Upstream version 17.0~rc3+dfsg1
    See: https://kodi.tv/kodi-v17-0-krypton-release-candidate-3/
  * Refresh patches
  * Fix FTBFS due to missing AEDefines_override.h

 -- Balint Reczey <balint@balintreczey.hu>  Mon, 16 Jan 2017 21:41:03 +0100

kodi (2:17.0~rc2+dfsg1-1) unstable; urgency=medium

  * Imported Upstream version 17.0~beta7+dfsg1
    See: https://kodi.tv/kodi-v17-krypton-the-last-beta-7/
  * Refresh patches
  * Use NotoSans-Regular font from fonts-noto-hinted package
  * Imported Upstream version 17.0~rc2+dfsg1
    See: https://kodi.tv/kodi-v17-krypton-release-candidate-1/
  * Fix positioning of the "from debian" text next to KODI logo

 -- Balint Reczey <balint@balintreczey.hu>  Fri, 06 Jan 2017 18:39:14 +0100

kodi (2:17.0~beta6+dfsg1-1) unstable; urgency=medium

  * Drop new built-in webinterface addon from beta 6.
    The addon contains many generated files without source. It will
    be packaged separately.
  * Imported Upstream version 17.0~beta6+dfsg1
  * Refresh patches
  * Revert the webinterface.default addon to old web interface from beta5
  * Update lintian override about MediaLibrary.js to match new packaging
  * Revert to using libcec 3.1 until libcec4 becomes available in Debian

 -- Balint Reczey <balint@balintreczey.hu>  Thu, 22 Dec 2016 02:00:46 +0100

kodi (2:17.0~beta5+dfsg1-4) unstable; urgency=medium

  * Stop using different epoch for transitional xbmc packages
  * Use 2: epoch for kodi packages (Closes: #844541)
  * Handle original tarballs properly when epoch is present in the package version

 -- Balint Reczey <balint@balintreczey.hu>  Thu, 17 Nov 2016 15:42:51 +0100

kodi (17.0~beta5+dfsg1-3) unstable; urgency=medium

  * Generate addon API versions for architecture-specific builds only

 -- Balint Reczey <balint@balintreczey.hu>  Mon, 14 Nov 2016 16:37:40 +0100

kodi (17.0~beta5+dfsg1-2) unstable; urgency=medium

  [ Balint Reczey ]
  * Stop providing xbmc-eventclients-j2me.
    This was a transitional package originally, but Kodi stopped shipping
    J2ME client. (Closes: #843169)
  * Transition to depending on fonts-anonymous-pro.
    Also accept ttf-anonymous-pro instead to support older releases
  * Generate additional original source tarball names from current version
  * Use more absolute paths in d/rules

  [ Tobias Grimm ]
  * Updated tarball versions in `debian/rules extract-components`
  * Provide virtual packages for addon APIs and install a debhelper addon
    to enable KODI addon packages to depend on these virtual packages.
  * Standards-Version: 3.9.8

 -- Balint Reczey <balint@balintreczey.hu>  Mon, 14 Nov 2016 11:32:17 +0100

kodi (17.0~beta5+dfsg1-1) unstable; urgency=medium

  [ Lukas Rechberger ]
  * Make kodi depend on kodi-data of same version (Closes: #841937)

  [ Balint Reczey ]
  * Fix Kodi's FFmpeg API usage for allocating and freeing AVFrame
    (Closes: #831591)
  * New upstream beta release 17.0 Beta 5
    See: https://kodi.tv/kodi-v17-krypton-beta-5/
  * Refresh patches
  * Run tests only for architecture dependent package builds
  * Use Anonymous Pro font from ttf-anonymous-pro instead of from texlive-fonts-extra
    (Closes: #842717)

 -- Balint Reczey <balint@balintreczey.hu>  Wed, 02 Nov 2016 21:53:39 +0100

kodi (17.0~beta4+dfsg1-2) experimental; urgency=medium

  * Generate version of xbmc transitional packages dynamically
    (Closes: #842141)
  * Check installed headers only during architecture-specific builds

 -- Balint Reczey <balint@balintreczey.hu>  Wed, 26 Oct 2016 13:37:42 +0200

kodi (17.0~beta4+dfsg1-1) experimental; urgency=medium

  * Ship additional headers referenced from already shipped ones
  * Ensure all needed development headers are installed
  * Use patches from libdvdread package
  * Build-depend on libssh-gcrypt-dev instead of libssh-dev to avoid
    transitive linking to libssl
  * Build-depend on libgcrypt-dev instead of libssl-dev
  * New upstream beta release 17.0 Beta 4
    See: https://kodi.tv/kodi-v17-krypton-beta-4/
  * Refresh patches
  * Stop building with OpenSSL

 -- Balint Reczey <balint@balintreczey.hu>  Mon, 10 Oct 2016 23:00:38 +0200

kodi (17.0~beta3+dfsg1-1) experimental; urgency=medium

  * New upstream beta release 17.0 Beta 3
    See: https://kodi.tv/kodi-v17-krypton-beta-3/
  * Refresh patches
  * Use OpenGL ES and no VAAPI/VDAPU on arm64.
    This fixes FTBFS on arm64
  * Enable Google Tests on armel and mips, too.
    The test results don't make the build fail anyway
  * Build-depend on valgrind on amd64 and i386.
    This makes tests use Valgrind on those popular and fast architectures
  * Fix FTBFS on armel/armhf
  * Properly set hardening options
  * Re-enable TestSortUtils test
  * Fix building tests
  * Build-depend on default-libmysqlclient-dev to keep Lintian happy
  * Adjust "from debian" logo placement

 -- Balint Reczey <balint@balintreczey.hu>  Fri, 07 Oct 2016 10:27:11 +0200

kodi (17.0~beta2+dfsg1-1) experimental; urgency=medium

  * New upstream beta release 17.0 Beta 2
    See: https://kodi.tv/kodi-v17-krypton-beta-2/
  * Drop build-depenency on libjasper-dev (Closes: 818201)
  * Adjust packaging to new skin's font requirements.
    Add dependency on fonts-lato and texlive-fonts-extra, drop
    dependency on fonts-roboto-hinted, make symlinks to new
    fonts instead of shipping them.
  * Add transitional dummy packages from xbmc
  * Drop obsoleted dependencies and patches
  * Silence Lintian complaining for missing misc:Depends of transitional
    packages
  * Ignore failed clean of components without Lintian noticing
  * Build-depend on liblcms2-dev for Little CMS support

 -- Balint Reczey <balint@balintreczey.hu>  Sat, 24 Sep 2016 14:57:31 +0200

kodi (17.0~alpha3+dfsg1-1) experimental; urgency=medium

  [ Lukas Rechberger ]
  * Skip timestamps to make build reproducible (Closes: #825285)

  [ Balint Reczey ]
  * Build depend on groovy instead of groovy2 (Closes: #824187)
  * Recommend kodi-visualization-spectrum
  * New upstream alpha release 17.0 Alpha 2
    See: https://kodi.tv/kodi-v17-krypton-alpha-2/
  * Stop excluding paths from orig tarball which are already removed
  * Refresh patches and changed paths in d/rules
  * Fix FTBFS due to format string warnings
  * Disable building DVDCSS
  * Build-depend on libbluray-dev (>= 0.7.0) to match version required by ./configure
  * Derive embedded libdvdnav and libdvdread from additional original tarballs
  * Fix building with Google Test
  * Ignore failing tests but run them with Valgrind when it is available
  * Update d/copyright
  * Add information about multiple orig tarballs
  * New upstream alpha release 17.0 Alpha 3
    See: https://kodi.tv/kodi-v17-krypton-alpha-3/
  * Refresh patches
  * Really revert patches to embedded dvdnav and dvdread copies in clean target
  * Drop J2ME client support in sync with upstream
  * Don't crash on missing version checker addon
  * Position "from Debian" image better on new skin
  * Drop symlinks to fonts used in the replaced skin

 -- Balint Reczey <balint@balintreczey.hu>  Fri, 05 Aug 2016 01:23:53 +0200

kodi (16.1+dfsg1-1) unstable; urgency=medium

  * New upstream version 16.1
    See https://kodi.tv/kodi-16-1-jarvis-mark-xvi

 -- Balint Reczey <balint@balintreczey.hu>  Sun, 24 Apr 2016 15:51:42 +0200

kodi (16.1~rc2+dfsg1-1) unstable; urgency=medium

  * New upstream release candidate 16.1 RC2
    See: https://kodi.tv/kodi-16-1-jarvis-release-candidate-2/
  * Fix GetKernelBitness() on s390x to fix FTBFS on that arch
  * Skip tests on armel and mips to prevent FTBFS
  * Stop excluding files from upstream tarball which are already removed
    upstream
  * Don't modify GetVersionShort(), return package version in GetVersion()
    instead

 -- Balint Reczey <balint@balintreczey.hu>  Tue, 29 Mar 2016 10:52:16 +0200

kodi (16.0+dfsg1-3) unstable; urgency=medium

  * Fix system info for s390x and arm64 architectures
  * Skip tests failing on buildds to fix FTBFS on most ports
  * Skip sorting test failing in the test code on armhf and armel

 -- Balint Reczey <balint@balintreczey.hu>  Fri, 25 Mar 2016 10:49:06 +0100

kodi (16.0+dfsg1-2) unstable; urgency=medium

  * Enable Google Tests at build-time
  * Fix user agent string and related test
  * Disable bindnow hardening option because it breaks playing DVDs

 -- Balint Reczey <balint@balintreczey.hu>  Tue, 15 Mar 2016 15:08:54 +0100

kodi (16.0+dfsg1-1) unstable; urgency=medium

  * New upstream version 16.0
    See https://kodi.tv/kodi-16-0-jarvis-mark-xvi/
  * Refresh patches
  * Change build-dependency on libcec-platform-dev to libp8-platform-dev.
    The library has been renamed
  * Build-depend on libcec-dev (>= 3.1) which is built with p8-platform
  * Stop shipping menu file
  * Override false positive lintian warning about missing JavaScript source

 -- Balint Reczey <balint@balintreczey.hu>  Mon, 22 Feb 2016 23:08:18 +0100

kodi (16.0~rc3+dfsg2-1) experimental; urgency=medium

  * New upstream release candidate 16.0 RC3
    (Closes: #792299) (CVE-2015-3885)
    See http://kodi.tv/kodi-16-0-jarvis-release-candidate-3/
  * Refresh patches
  * Don't use libcadec, wait for the codec to be included in FFmpeg instead
  * Drop libhdhomerun-dev build dependency
  * Add libcrossguid-dev and uuid-dev as build-dependencies
  * Drop workarounds for screensavers dropped by upstream
  * Use hinted Roboto fonts adapting to their new location in filesystem
  * Enable PIE
  * Make C-Pluff build with PIC only enabling PIE-enabled build to succeed
  * Update debian/copyright for 16.0 RC3 changes

 -- Balint Reczey <balint@balintreczey.hu>  Sat, 13 Feb 2016 22:53:08 +0100

kodi (15.2+dfsg1-3) unstable; urgency=medium

  * Disable PIE due to build failure on amd64

 -- Balint Reczey <balint@balintreczey.hu>  Mon, 25 Jan 2016 10:35:02 +0100

kodi (15.2+dfsg1-2) unstable; urgency=medium

  * Fix 03-privacy.patch to disable rss feed
  * Disable debugging by default (Closes: #777041)
  * Build-depend on fonts-droid-fallback instead of obsoleted fonts-droid
    (Closes: #804695)
  * Enable all hardening options during build
  * Migrate to libpng-dev build-dependency (Closes: #810186)

 -- Balint Reczey <balint@balintreczey.hu>  Sun, 24 Jan 2016 10:55:08 +0100

kodi (15.2+dfsg1-1) unstable; urgency=medium

  [ Balint Reczey ]
  * Skip handling migration to automatic debug packages when it is not supported by debhelper
  * Update debian/watch to not skip part of oddly named versions
  * New upstream release 15.2
    See http://kodi.tv/kodi-15-2-isengard-final-release/

  [ Andreas Cadhalpun ]
  * Fix FTBFS with upcoming FFmpeg 2.9 release (Closes: #803831)

 -- Balint Reczey <balint@balintreczey.hu>  Fri, 06 Nov 2015 18:42:22 +0400

kodi (15.2~rc3+dfsg1-1) unstable; urgency=medium

  * New upstream release candidate 15.2 RC3
    See http://kodi.tv/kodi-15-2-isengard-release-candidate-3

 -- Balint Reczey <balint@balintreczey.hu>  Tue, 06 Oct 2015 12:06:19 +0200

kodi (15.2~rc1+dfsg1-2) unstable; urgency=medium

  * Make Breaks/Replaces relation to xbmc packages versioned.
    This lets dummy transition-only xbmc packages coexist with kodi.
    Also remove Provides/Replaces relations remaining from xbmc packaging.
    (Closes: #799823)
  * Split architecture-indepedent data to kodi-data.
    Only the kodi and kodi-standalone binaries are kept in kodi package which is
    now Architecture:any since it contains the architecture-specific path to
    kodi.bin. (Closes: #799979)

 -- Balint Reczey <balint@balintreczey.hu>  Sat, 26 Sep 2015 15:13:36 +0200

kodi (15.2~rc1+dfsg1-1) unstable; urgency=medium

  [ Balint Reczey ]
  * Really fix s390x build
  * Call ./configure through dh_auto_configure
  * Convert to package to use multiarch library dirs
  * Stop shipping kodi-dbg and disable debugging during build.
    This is a preparation for the automatically generated debug packages
    and switching to FFmpeg resulted less reported crashes to BTS.
    Kodi-dbg packages used quite a big space on mirrors and weren't used
    frequently.
  * Make kodi-addons-dev Replaces/Breaks: kodi-bin (<= 15.1+dfsg1-3)
    This is needed to manage moving .cmake files to to kodi-addons-dev.
  * Migrate from kodi-dbg to ddebs properly.
    Thanks to Mattia Rizzolo
  * Make kodi-addons-dev Architecture: any
  * Simplify debian/rules using exporting DH_OPTIONS
  * New upstream release candidate 15.2 RC1
    See http://kodi.tv/kodi-15-2-isengard-release-candidate-2/
  * Refresh patches

  [ Tobias Grimm ]
  * Fixed file name of patches/09-use-correct-ftgl.h
  * Install *.cmake files in kodi-addons-dev

  [ Mattia Rizzolo ]
  * debian/rules: correct use of `echo`

 -- Balint Reczey <balint@balintreczey.hu>  Mon, 21 Sep 2015 10:38:00 +0200

kodi (15.1+dfsg1-3) unstable; urgency=medium

  * Make configure more verbose when building on architecture not supported
    by upstream
  * Fix FTBFS on aarch64 (Closes: #796532)
  * Don't use NEON on arm/armhf. (Closes: #797204)
  * Fix build on s390x

 -- Balint Reczey <balint@balintreczey.hu>  Sun, 30 Aug 2015 10:20:07 +0200

kodi (15.1+dfsg1-2) unstable; urgency=medium

  * Don't stop configuration for unknown architectures
  * Drop unknown ./configure options
  * Continue configuration for unknown arches even further (Closes: #790635)
  * Link with libatomic to fix FTBFS on powerpc and some other architectures
  * Fix broken symlinks to DejaVuSans font files

 -- Balint Reczey <balint@balintreczey.hu>  Tue, 18 Aug 2015 23:51:14 +0200

kodi (15.1+dfsg1-1) unstable; urgency=medium

  * New upstream release 15.0
    See http://www.kodi.tv/kodi-15-0-isengard-one-release-to-rule-them-all/
  * Depend on libav.*-dev provided by src:ffmpeg
  * Recommend udisks2 instead of udisks.
    Udisks has been removed from unstable but support for udisks2 is not
    implemented yet.
  * Ship patch helping Jessie backports
  * Refresh patches
  * Eliminate __DATE__ macros from source to make build more reproducible
  * Build-depend on libsdl2.*-dev instead of libsdl.*-dev
  * Build-depend on libgif-dev
  * Drop obsoleted fix of installed header's include paths
  * Refresh include file list included by kodi-addons-dev
  * Build depend on libcec (>= 3)
  * Build-depend on groovy2 instead of groovy
  * Sort build dependencies
  * Fix packaging repository URL
  * Remove removed files from debian/copyright
  * Fix filenames with spaces in debian/copyright
  * Ship TexturePacker in kodi-addons-dev in /usr/lib/kodi
  * Build depend on libcec-platform-dev
  * Stop using embedded gnulib modules in rsxs screensaver (Closes: #795813)
  * Add missing copyright paragraphs to d/copyright
  * Stop marking files as excluded which are removed from upstream tarball
    already
  * Bump standards version to 3.9.6
  * New upstream release 15.1
    See http://kodi.tv/kodi-15-1-isengard-maintenance-release/
  * Move TexturePacker to kodi-bin
  * Stop building TexturePacker statically

 -- Balint Reczey <balint@balintreczey.hu>  Tue, 18 Aug 2015 14:16:59 +0200

kodi (14.2+dfsg1-2) unstable; urgency=medium

  * Recommend udisks (Closes: #787293)

 -- Balint Reczey <balint@balintreczey.hu>  Thu, 04 Jun 2015 09:39:30 +0200

kodi (14.2+dfsg1-1) experimental; urgency=medium

  * Fix addon shared library naming on MIPS
  * Drop non-machine-readable parts of debian/copyright
  * Generate machine-readable debian/copyright for all files
  * Clean up generated debian/copyright
  * Remove non-free files in d/copyright
  * Fix debian/watch file
  * Update debian/copyright with new removals
  * Drop get-orig-source target from d/rules.
    Use uscan for generating repacked original tarball.
  * Imported Upstream version 14.1+dfsg1
    http://kodi.tv/kodi-14-1-helix-bugfix-release
  * Copyright updates
  * Use avformat_flush(), it is now exported by FFmpeg
  * Stop using files omitted from DFSG-free tarballs
  * Sort filenames omitted from original tarball
  * Omit embedded Boost header from original tarball
  * Download original tarball from GitHub
  * Imported Upstream version 14.2+dfsg1
    http://kodi.tv/kodi-14-2-helix-the-final-translation

 -- Balint Reczey <balint@balintreczey.hu>  Sat, 17 Jan 2015 00:30:36 +0100

kodi (14.0+dfsg1-1) experimental; urgency=medium

  * New upstream release 14.0
    See http://kodi.tv/kodi-14-0-helix-unwinds
  * Refresh patches
  * Generate "from Debian" logo from SVG

 -- Balint Reczey <balint@balintreczey.hu>  Fri, 02 Jan 2015 13:19:52 +0100

kodi (14.0~beta1+dfsg1-1) experimental; urgency=medium

  * First packaged Kodi version based on xbmc 2:13.2+dfsg1-4
    See http://kodi.tv/introducing-kodi-14 for the rationale behind the
    name change (Closes: #767180)
  * Use packaged FFmpeg
  * Stop using internal ffmpeg functions
  * Build-depend on libcec-dev >= 2.2
  * Add upstream patches for fixing suspend and adding MIPS support

 -- Balint Reczey <balint@balintreczey.hu>  Sat, 08 Nov 2014 11:14:40 +0100