1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
|
include /usr/share/dpkg/default.mk
include /usr/share/rustc/architecture.mk
export CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
export DEB_HOST_RUST_TYPE DEB_HOST_GNU_TYPE
export PATH := /usr/share/cargo/bin:$(PATH)
export CARGO=/usr/share/cargo/bin/cargo
export CARGO_HOME=$(CURDIR)/debian/cargo_home
export DEB_CARGO_CRATE=$(DEB_SOURCE)_$(DEB_VERSION_UPSTREAM)
export DEB_BUILD_MAINT_OPTIONS=hardening=+bindnow
%:
dh $@
override_dh_auto_clean:
dh_auto_clean
rm -rf debian/cargo_registry
override_dh_auto_configure:
$(CARGO) prepare-debian debian/cargo_registry --link-from-system
rm -f Cargo.lock
dh_auto_configure -- \
-Dhost_arch="$(DEB_HOST_RUST_TYPE)" \
override_dh_auto_test:
dh_auto_test -- --timeout-multiplier 3
|